• [6.10.0-rc1] WebUI Sometimes Slow to Load/Unresponsive

    • Minor

    I upgraded to 6.10.0-rc1 a few days ago and I have been having some issues with the webUI becoming very slow to load and unresponsive. It will take 10-15 seconds for the page to fully load and become functional. The same behavior happens on the Main array tab, the other main pages seem to be unaffected. The problem seems to come and go at random; sometime later it will resolve itself and then be back again a few hours later.


    I'm using Firefox 92.0, I have my ad-blockers and similar disabled for my unraid pages. I haven't tried any other browsers to see if it is Firefox specific, but it started with my 6.10.0-rc1. I assume it's probably has to do with the webUI changes that came with 6.10.0-rc1.


    I can't seem to find any reason for the sluggish behavior. At first it seemed like it only happened when I had some drives spun down, but that doesn't seem to be the case anymore. It's not correlated with a heavy CPU load or low RAM availability.


    I have attached some screenshots to show what it looks like before loading fully.

    I also attached my diagnostics, let me know if there is any other info you need.








    User Feedback

    Recommended Comments

    Interestingly I find when I navigate to the dashboard specifically it causes a spike in gpu usage and the typically idle gpu fans to spin up to 100% for a few seconds

    Link to comment

    @benmandude Some things thatd help troubleshoot this:


    * Testing on separate browser (Edge, Safari, Chromium, anything really)

    * When you're seeing this, does clearing the browser cache help? If this is a pain, try using a private/incognito window, should provide a relative outcome.

    * Connecting from another device - browser doesn't matter, just other system that's not logged in to your server's UI at that time


    And for the "this is everything one could possibly need to see what's happening here" version (or at least point to the next place to check logs from at the very least):

    * When you are encountering this, create a HAR file recording the occurrence and the share it here for analysis; this link has solid steps for doing so across multiple browser types. PLEASE take special note of the warnings section of the article - while creating the HAR recording, do NOTHING other than recreate/show the loading issue, then stop the recording (don't go logging into your bank or something silly like that lol)


    If you go this route, attach the file here so it can be gone through. I'm sure the limetech guys can sort it out, but if it comes in this weekend, I should have time to look at it hopefully sometime Monday and see what I can make of it.

    Link to comment

    Finally got around to testing this out.


    The issue persists using FF private mode.

    I do not have the same issue using Chrome.


    The same on my Linux laptop, FF is slow to load, Chrome is not.


    In testing out Chrome, I have found the FF is slower on most pages, but I guess the dashboard and main were just what stood out to me most.


    I have done the HAR recordings on the dashboard and main tab in both FF and Chrome and attached them.


    I might try out a fresh FF profile to see if it is any of my FF extensions causing issues, but I have most of them disabled for my Unraid domain.


    Edit: I tried FF in safe mode and still have the same issue.





    Edited by benmandude
    Link to comment

    Awesome! I'll try to check out the HAR tonight if time allows - if not, itll likely be next weekend due to work stuffs.


    Quick questions -

    * what're you using as your router (pfsense, opnsense, asus/tplink/etc) default/model, etc)?

    * as for DNS - is apollo's mac and IP explicitly defined in your router, or relying upon the host and/or dhcp settings?

    Link to comment

    @benmandude I just realized you'd noted you *don't* have the same issue with chrome - that pretty well negates the questions posted above (well... not completely, but mostly hehehe), I really should've re-read before pulling down the HARs lol 😅


    We're spending the vast majority of our wait time on DNS lookup:

            "cache": {},
            "timings": {
              "blocked": 0,
              "dns": 8999,
              "connect": 1,
              "ssl": 0,
              "send": 0,
              "wait": 24,
              "receive": 0
            "time": 9024,
            "_securityState": "insecure",
            "serverIPAddress": "",
            "connection": "80"



    The exact same amount of time for both the dashboard AND main/array pages - I'd start with restarting FF in safe mode. Having this happen only in one browser narrows this down quite a bit, and while it doesn't rule out unraid itself completely, it's certainly far less likely it's something server side.


    At a glance, I'd venture one of your plugins is still causing issues. While I didn't spend a ton of time on it up to this point, a quick once-over show's us having issues with connecting to graphql, around the same time the my servers plugin is doing it's work. With our DNS lookups taking a full 9s, and in both instances happening right after protocol upgrade...

           "response": {
              "status": 101,
              "statusText": "Switching Protocols",
              "httpVersion": "HTTP/1.1",


    ... it seems more likely this is either an issue on the browser side; whether it's specific to Mozilla overall though or just one of your plugins interfering, we'll know more after your testing FF in safe mode.

    Link to comment

    I tried it in safe mode yesterday and it had the same issue.


    The weird thing is it doesn't always load slowly. This morning it has been fine, no issues with page loading slowly.

    I have attached a HAR of that.


    As for your questions.


    I have a Asus RT-AC66U B1 router running the Asuswrt-Merlin firmware.


    I have a pi-hole setup on a RaspberryPi connected to my router.

    The pi-hole is advertised as the default DNS server, and I also have it set to forward any errant DNS requests to the pi-hole.


    I did not have definition for apollo setup. But I just put an entry in the pi-hole for a local DNS record for "apollo" to its IP.


    Edited by benmandude
    Link to comment

    Sounding more like it has something to do with the way either mozilla or pihole is handling the myservers plugin - I'd start systematically narrowing it down from there, it certainly doesnt sound like its something in the servers config at this point 

    Link to comment

    I did some more digging on my end and I think I have found the culprit, my VPN client. I'm using AirVPN with the eddie client.


    Since you said it was a DNS lookup wait I started thinking about my VPN.

    I'm quite certain that all of the HAR files I have provided have been with my VPN turned off. However after I wasn't having any issues this morning, I went and turned on my VPN and the slow loading was immediately present.


    I guess that probably leaves two options:

    I had my VPN on and didn't realize it and that is what has been causing issues. However that would beg the question why is FF slow to load and Chrome isn't when tested at the same time.

    The other being that when I turn off my VPN something is erroring and leaving my network connection in an incorrect state, possibly using the wrong DNS server or something along that line.


    In the eddie client, I was using the wintun driver option and have reverted back to the standard driver. I then turned off the VPN and the loading issue went away.

    I'm going to keep an eye on it and see if the loading issue comes back and under what circumstances. But I guess for now I think I can focus on my VPN client being the root issue.


    I'll update if I find out otherwise. Thanks for digging into the issue.





    • Like 1
    Link to comment

    I had severe dns latency when using airvpn years back, though never with that level of "exactly 9s" consistency.


    If I'm remembering right, after pulling my freakin hair out for something like 3 days, I ended up finding ipv6 as the common underlying component... No idea "whose fault" it was - airvpn, RT-ac68u, FF [version 3 at the time], hell even .net as it was on both linux and windows machines, etc. I just found that once I squashed anything that even thought itself to be ipv6, it just... vanished. 


    Idk if that old-as-hell "problem", whatever it was, is still around, but figured I'd mention it given youd mentioned em.


    Best of luck!

    Link to comment

    I know this post is about 2 weeks old, but I am having nearly the same issue with my "Dashboard" and "main" pages. Except I can confirm that the same issue happens in Firefox and Chrome (Brave), as well as in any browser on my iPhone. So this doesn't seem isolated to one particular browser or device.


    -All graphs are missing (Always, except immediately following a reboot)

    -All storage devices are missing (visually) (Always, except immediately following a reboot)

    -Sometimes Disk Location is missing but not always

    -Sometimes Docker containers are missing (visually) but not always.

    -Sometimes only the top bar loads and none of the dashboard page loads at all until I refresh the page a few times.


    I'm not sure at what point this issue is happening, it'll usually go several days before it starts happening.

    So far the only way I have been able to fix it is to reboot.


    Screenshots below, and diagnostics attached.


    EDIT: I just rebooted so I could have my dash back and even after a fresh reboot it takes 10-15sec for the missing parts to show up.








    Edited by relink
    added info
    Link to comment
    On 10/30/2021 at 9:45 PM, BVD said:

    This is almost certainly your router settings. I'd start there.

    I've been using the same router for years now, im not sure what exactly id be looking for.

    Link to comment

    I'd start with any packet inspection or blocking rules (e.g. surricata/pfblocker if using pfsense, that kind of thing). Short of that, I'd recommend creating a new issue report and including the same information the original user posted above.

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.