• [6.10.0-RC2 & RC3] GPU Passthrough not working and causes eventual WebUI crash

    • Urgent

    Hi, after experiencing this before and rolling back to 6.10RC1 where things run fine I thought I'd check this out again.


    Trying to passthrough a GPU in either an existing VM or a new one (with a fresh vdisk and no boot media inserted) causes no video output clicking on the VM tab causes the whole WebUI to crash. Trying "virsh shutdown [vm name]" in a terminal just locks the terminal session up.


    I'm not binding my GPU to VFIO and I've tried both Q35/i440fx 6.0 and 6.1 with the same outcome. This happens regardless of whether I give a vbios or not.


    All BIOS settings are the same and all xml settings are the same.


    Any help or ideas would be appreciated. GPU is an AMD 5700XT which works fine in 6.10.0-RC1 with the AMD Vendor Reset plugin, etc.


    Attached diagnostics after having to force a shutdown.


    Edit: Now with RC3 VM's are booting but locking up the server on shutdown. Diagnostics from the thread here added.




    User Feedback

    Recommended Comments

    Guess I'm going back to RC1 till another RC or 6.10 official comes out as I can't use any VM with passthrough on this version.

    Link to comment
    On 2/9/2022 at 7:35 PM, DarkMan83 said:

    You should always bind your GPU, to circumvent any problems related to binding!

    But it works fine on RC1 without having to bind my GPU, meaning there's a regression there. Also, not binding my GPU allows me to use it in dockers, etc. when the VM isn't running which is a feature I'd rather not/shouldn't have to give up.

    Link to comment

    Reported this here but I still can't passthrough my GPU to a VM without a sever crash on RC3, only this time it's on shutdown and not on boot.

    Link to comment

    Hi there,


    Unfortunately these types of issues can happen when you use AMD-based devices (CPU/GPU) for use with VFIO.  There is just a lack of consistency with the experience across kernel and package updates.  These issues don't seem to plague NVIDIA users.  There is a limit to how much we can do to support AMD when they aren't even supporting this themselves.  I wouldn't call this as much a "bug" with Unraid as it is with the kernel itself and from our perspective, having problems with AMD-based GPUs and GPU pass through is a known issue and limitation of AMD.  Hopefully AMD will do a better job supporting VFIO in the future.

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.