• [6.10.0-rc8] No network asssignment

    • Minor

    I've made quite a few changes recently and have been up against this issue for a while - I have two network adapters and can't point the right one at eth0.

    Onboard is gigabit, and I have a 10gb fibre card that I want to be the default. I want to have the onboard activated so that I can use wake on lan which doesn't work with the fibre.

    I've managed to lose the option to assign eth0 and eth1, and can't get it back. Have tried reverting to rc7 and back, and many many reboots but it fails to show. It's left me with the wrong adapter as default.

    Diagnostics attached. Goodness knows what horrors lurk within....


    User Feedback

    Recommended Comments

    network-rules.cfg is missing, it should exist when there's more than 1 NIC, delete/rename network.cfg (/boot/config) and reboot to see if it's created.

    Link to comment

    renamed networked.cfg - I can't see that a replacement has been created, but I haven't re-configured anything. No network-rules.cfg either.

    I'd been looking for a config file thinking there might be an issue with it but couldn't find one. I've recently swapped motherboard (and cpu), so the mac address of eth0 will have changed.


    Edited by jsebright
    Link to comment

    IIRC network.cfg is only re-created after changing something, but network-rules.cfg should have been created after the reboot, so not sure what the problem is.

    Link to comment

    Time to re-create the flash drive? I'm not on the "My Servers" yet - will that slow down provisioning a new one if necessary.

    Appreciate the swift help. Thanks.

    Link to comment

    Did a scan of the flash and it came up OK, so am saving that option for later.

    I swapped cards that I need (10gb & drive controller), and removed a PCIE usb card that I can swap for another in a bit. I've finally got the "Interface Rules" back and can assign eth0 and eth1.

    I've not yet been successful in splitting the IOMMU groupings yet and have been trying unsuccessfully to get that to work. This is probably where some of the issues came in. I have also experienced problems with network not coming back up after waking from sleep - probably related, see this post:


    Going off topic.

    My ideal setup is where I can use onboard (intel HD930) graphics for a VM and perhaps some transcoding (quite rare),  pass through a usb hub to the VM, Fibre connection as main, with gb for waking from sleep, server will go to sleep at night and wake up OK when needed.

    Stopping that is that I can't manage to split the audio part of the HD930 out into it's own IOMMU (so am using an extra card), and have been having problems with the network cards not working - seemingly when I've got the USB controller in (that was being stubbed).


    Possible issue remains is that some combination of hardware has prevented the Network-Rules from being created / maintainable.

    I'm going to try a different USB card and could try more moving around of cards to see if I manage to break the audio out and don't need the additional graphics - although I'm sure that will cause problems with getting VMs to use the onboard.

    Link to comment

    I had this same issue (No Network) when attempting to upgrade from stable 6.9.2 to RC8.  I have two NICs (USB and PCI).


    I copied my network.cg and network-rules.cfg files from my USB backup however after booting network-rules.cfg is missing again.  I tried this several times and then gave up and downgraded back to 6.9.3 for now.


    Let me know if I can help provide any additional info etc. ?

    Edited by kemcro
    Link to comment

    Have the same problem with Dell PowerEdge R720 server, Unraid 6.10.2-rc3 will delete the network-rules.cfg every time you replace this some how it deletes this all the time.


    Come on Unraid fix this.... 


    I have an PowerEdge R710 too, that is the media center, running 6.9.2 version with no problems WILL not be updating to the new version anytime soon


    Version 6.9.2 has the two network.cfg and the network-rules.cfg files 

    Version 6.10.2-rc3 has only the network.cfg file, Not the network-rules.cfg file.




    Link to comment
    1 hour ago, jayferret said:

    Unraid 6.10.2-rc3

    You should be running 6.10.2 stable, not -rc3, also if you need help please post the diagnostics, also note that if you have NICs that use the tg3 driver they will be blacklisted, see the release notes for more info:



    Link to comment

    I encountered the same problem after upgrading to 6.10.2 (stable). I have 2 network adapters and the 10 GBit Mellanox card used to be set to eth0. Setting it to eth0 based on NIC is no longer available in 6.10. Seems like a bug or a change made related to 6.10.

    Both network adapters still show up as eth0 and eth1, though. Setting them to different IP addresses allows to connect to the web-GUI through both, but the main problem is that I no longer can configure the Mellanox card to be the primary network adapter. 
    Docker service is also defaulting to the internal eth0.

    Edited by rob_robot
    Link to comment
    21 minutes ago, rob_robot said:

    I have 2 network adapters and the 10 GBit Mellanox card used to be set to eth0. Setting it to eth0 based on NIC is no longer available in 6.10.

    It's a known issue, I can also reproduce it, it's being looked at.

    • Like 1
    • Thanks 2
    Link to comment

    Hi JorgeB,
    after upgrading to 6.10.3 it is working again. Thanks a lot! The interface rules drop-down menu inside network settings is back.

    • Like 1
    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.