• [6.11.0-rc5] Host to custom docker macvlan network communication no longer works.

    • Urgent

    I have a custom docker bridge network, that hosts most of my containers, including swag proxy. I also have a custom macvlan network, that hosts my containers that need a unique IP, like home assistant.


    With the 'Host access to custom networks' I was able to reach home assistant from Unraid and from swag, but after updating to rc5 this option no longer works.


    I can ping Unraid host from swag successfuclly, but from home assistant I am unable to ping Unraid host (and vice versa). Pinging from/to other computers from home assistant works fine.


    This is breaking reverse proxy for me, as well as communication between home assistant and other containers (e.g. zigbee2mqtt).


    After full server restart I've just stopped getting IP altogether, server sits at 169.**.


    EDIT: Going back to rc4 didn't fix anything, still sitting at 169.** reporting full connectivity with the switch, everything seems fine in GUI mode, but Unraid ignores (?) DHCP.


    EDIT2: Somehow, restarting my switch fixed DHCP issue. Weird, cause other Unraid I have is connected to the same switch and it updated yesterday just fine. Original issue with docker accessing host persists.


    EDIT3: Rolled back to rc4, it fixed the docker <-> host access issue. Something must be up with rc5 not respecting that option.

    • Like 2
    • Upvote 1

    User Feedback

    Recommended Comments

    The original issue is not fixed tho, DHCP/IP problems were just a 'side quest'. After getting that sorted, I'm still not able to ping my home assitant in a custom docker macvlan network, even tho 'Host access to custom networks' is enabled.


    After confirming everything DHCP/IP related works and home assistant is still not reachable on rc5, I've gone back to rc4 and home assistant docker is reachable from host, so it must be something to do with the upgrade.

    Link to comment

    I have confirmed the same issue on my second Unraid server that runs rc5. It went unnoticed there, because only secondary DNS server has its own macvlan IP, so it's not as impacting as home-assistant.

    Link to comment

    I'm having almost the exact same problem with this build. Looking for a permanent solution too.

    It also happened to me with rc4 but I was able to get things working again by uninstalling and reinstalling the NPM docker, but I also restarted both the router and switch, not sure I've done that this time... 

    Any resolution welcomed.. 

    ### UPDATE ###

    Ok, so it was obvious once it finally clicked (after rolling back and restarting the router and switches did nothing) 
    I shut down docker.  Turned the host access to NO, and applied, then set to YES and re-applied.... started the services, and all is well. 
    I TOTALLY forgot that sometimes settings get out of whack with the GUI... it's happened with other network settings to me... it was just a while ago and I fortunately don't have these kinds of issues often... 
    I would love to go back to RC5 again and see if all is well, but I can't afford the time today, and there will prolly be a RC6 soon enough...  Seems like somehow this gets hosed for some people on the RC5 update..  and I am super curious if toggling that setting is the fix there too, but I am operational again and have to get back to other stuff...  

    Thanks to everyone (here and in the Unraid Community Discord) 

    Edited by Garbonzo
    Link to comment

    Having same problem, I use pi-hole and pipe my other dockers through it. After RC5 none of my dockers can use DNS hosted by pihole. Removing the custom DNS config from the container restores connectivity. Workaround above to toggle the setting and restart Docker did not help.


    update: on 6.11 stable problem still there. Toggling the host setting wasn't working however with docker off, I changed macvlan to ipvlan, saved and then change ipvlan back to macvlan and saved again then started docker. It seems to be working again.


    Definitely some weird config issue introduced with rc5

    Edited by nickp85
    Link to comment

    I'm seeing this issue as well. If tried toggling off and back on, starting docker between changes and it still doesn't work. Toggling worked for me prior to this release when the setting stopped working after hard reboots/crashes.

    Link to comment

    I still had luck, but had to toggle again after a reboot (this is after rolling back to rc4) 
    I am hesitant to go back to rc5 again after seeing others saying toggling it doesn't fix for them. 
    I thought I had read 6.11 was out of beta, but I may have misread that... anyway, I am probably going to sit revisiting rc5 out this time, and try again if there is a rc6+ prior to release. 

    • Upvote 1
    Link to comment

    Okay, I've installed 6.11 stable on my secondary server and did the 'turn off docker -> change setting -> change it back -> turn on docker' dance. Pi-hole docker is able to ping server IP and server is able to ping pi-hole, so it looks like it's fixed in stable 6.11. I'm not going to do an update on my main today, might try tomorrow.

    Link to comment
    1 hour ago, Xenor said:

    Okay, I've installed 6.11 stable on my secondary server and did the 'turn off docker -> change setting -> change it back -> turn on docker' dance. Pi-hole docker is able to ping server IP and server is able to ping pi-hole, so it looks like it's fixed in stable 6.11. I'm not going to do an update on my main today, might try tomorrow.

    I am planning on doing the stable tomorrow as well, I have to power down for other things anyway... I was still in the next release, thats why I wasn't seeing the stable... I was "almost" sure I was mistaken about the stable being out... xD


    Link to comment



    To this issue. I am on 6.11.5 and I used to do the Toggle "Host access to custom networks" to disabled, start docker, stop docker, and then set "Host access to custom networks" to enabled and start docker again. This used to fix it Pre- 6.11.5


    Now going forward on the latest release I can't get connectivity between my host and the docker containers on the custom br0 network.


    Any help would be appreciated, I've tried a full restart, resetting router, and multiple iterations of turning docker on/off.

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.