Jump to content
  • [6.7.0-rc1] exit_boot() and efi_main() from syslinux selection


    bamhm182
    • Minor

    My install has been booting just fine, and then I upgraded to 6.7.0-rc1 from 6.6.6 and am getting the following when I try to boot from any of my options:

     

    Loading /bzimage... ok

    Loading /bzroot... ok

    Loading /bzroot-gui... ok

    exit_boot() failed!

    efi_main() failed!

     

    I have moved my vfio-pci arguments over to the new config file, but other than that, I haven't touched anything since the last reboot. I'm on UEFI. Any ideas? I'm going to go remove that config file and see if that helps any.

     

    EDIT: It didn't change anything. Also, my default syslinux.cfg file entry is as follows:

     

    label unRAID...

    kernel /bzimage

    append pcie_acs_override=downstream initrd=/bzroot,/bzroot-gui

     

    I could probably roll back to 6.6.6 and be fine, but I'm going to take the time waiting to set up my bare metal hard drive. Let me know if there is anything you would like me to try.

     

    EDIT 2: I rolled back to 6.6.6 and as I predicted, everything was fine again. I then reinstalled 6.7.0-rc1 and it did the same thing. I made sure not to make any changes to syslinux.cfg or vfio-pci.cfg this time.



    User Feedback

    Recommended Comments

    Is there any extra information I can provide to help get an answer to why this is happening since I can't exactly pull diagnostics?

     

    I tried reverting to 6.6.6 and doing the upgrade again with the same results.

    Share this comment


    Link to comment
    Share on other sites

    Never seen that particular error before 🙄

     

    How much RAM is installed?  What is capacity of your usb flash boot device?

    Did you try a "safe mode" boot?

    Did you run "memtest"?

    Share this comment


    Link to comment
    Share on other sites

    I have 32 GB of RAM and a 32 GB flash drive plugged into an adapter plugged into the USB 3 header on my motherboard. I have tried to boot into each of the modes except memtest.

    Share this comment


    Link to comment
    Share on other sites

    Try using a usb2 port instead.

    Share this comment


    Link to comment
    Share on other sites

    googling that issue did turn up some results.  Make sure you have 'secure boot' turn off in bios.  You might also try UEFI-mode boot too.  To do this you will see a directory on the flash device called:

    EFI-

    rename to:

    EFI

    (that is, just take off the dash suffix).

    Next, configure bios for UEFI boot off the USB flash device.

    Share this comment


    Link to comment
    Share on other sites

    I went to go give it a shot with your suggestions and I noticed that rc2 was available. This worked without any problem. Then, as I come here to say that, it came back.

     

    So, my computer was already set up as UEFI and I couldn't find anything in my bios about secure boot. I switched the drive to a USB 2 slot and it booted fine. I put it back to a USB 3 spot and it worked fine. I put my vfio-pci.cfg file back and it died. I removed that file, still dead. Out of all the modes, it seems to boot into safe mode w/o GUI pretty consistently. Either GUI mode seems to always die. Normal CLI mode is a hit or a miss.

     

    EDIT: I may have just found the variable. It seems that when I have everything plugged in (mouse/keyboard to PCI USB card, dvi/HDMI to GTX970, Ethernet to 4 port pci nic, Ethernet to onboard, HDMI to onboard) then it dies. With HDMI/mouse/keyboard to onboard, it boots just fine.

     

    EDIT 2: I'm wrong. I unplugged everything and slowly plugged things in one by one and rebooting hoping it would die eventually. I now have everything plugged in and no idea why it is doing this seemingly randomly.

    Edited by bamhm182

    Share this comment


    Link to comment
    Share on other sites


    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.