Jump to content
  • [6.8.0 RC-1] Can't boot with vfio-pci.ids enabled


    apazzy
    • Solved

    I've just updated to 6.8.0 RC-1 from 6.7.3 RC-2 and my machine doesn't seem to boot.

     

    I'm unable to capture any logs when trying to boot with this enabled, any help would be appreciated.

     

    Boot seems to hang right after the VFIO driver loads with the following messages:

    VFIO - User Level meta-driver version: 0.3
    vfio-pci 0000:01:00.0 vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem

    This used to be normal behavior, AFAIK that was when the host let go of the only video card in the system and continued to boot, so I'm not sure if something else is trying to get released.

     

    I tried disabling specific IDs as online people mentioned a more recent kernel had trouble with passing through USB controllers, but that didn't seem to do anything.

     

    Anyone else having this issue?

     

    EDIT: Reverted to 6.7.3 for now to get things working, I'll be able to try suggestions tomorrow.



    User Feedback

    Recommended Comments

    I gave RC3 a shot last night, same issue. No syslogs captured and no video output since I'm trying to passing through the only video card.

     

    I'm thinking of trying to turn on the ACS patch later tonight but I'm not sure if that will do anything. Any other ideas would be appreciated.

    • Like 1

    Share this comment


    Link to comment
    Share on other sites

    What do you mean by "vfio-pci.ids enabled" - are you referring to a kernel command line parameter?

    Or referring to config/vfio-pci.cfg file?  If so, what are contents of that file?

    Share this comment


    Link to comment
    Share on other sites

    In this case I'm referring to the kernel command line parameter. If I attempt to boot with the parameter identifying any devices, the system hangs at the point identified in the first post.

     

    I'm not at home to paste the exact boot command, but I've tried with various different ids listed and it only boots with the parameter completely removed.

    Share this comment


    Link to comment
    Share on other sites
    1 hour ago, apazzy said:

    In this case I'm referring to the kernel command line parameter.

    Get rid of that and use config/vfio-pci.cfg file instead.  refer to "New vfio-bind method" here.

     

     

    Share this comment


    Link to comment
    Share on other sites


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.