Jump to content
  • [6.8.0-RC6] Passed through USB device to VM is returned to the OS


    jbartlett
    • Minor

    I created a new Win10 VM, first one on RC6, passing through a Logitech receiver/mouse and a Corsair keyboard (1b1c:1b20) and video card. Standard procedure, same process I've done three times on RC5 when setting up a new VM.

     

    After starting the VM, the keyboard becomes unresponsive on the unraid console, as expected as it's being passed through to the VM. Roughly 25 seconds later, the keyboard becomes responsive again on the console and not responding in the VM.

     

    I expect this issue to go away on RC7 with the rollback but logging for posterity.

    vm1-diagnostics-20191118-2155.zip

    • Thanks 1


    User Feedback

    Recommended Comments

     I have the same issue with RC6.  In my case my logitech unifying receiver is not passed through to my Windows 10 VM,  I have to use the usb hot plugin to assign it to the VM.  No problem with RC5.  I also have experienced lock ups when attaching my Iphone via usb in RC6.  Again no problem with RC5.

    Share this comment


    Link to comment
    Share on other sites

    That's unfortunate.

     

    ps: the "best" way to pass USB devices is to pass the entire controller to the VM.  "USB Assignment" kinda works but very device dependent and there is not a lot of appetite on part of qemu/libvirt developers to make it rock solid.

    Share this comment


    Link to comment
    Share on other sites

    Yup, I'll end up going that route going forward for the time being.

     

    Forgot to add that the keyboard was lost at the exact moment the loading logo vanished and the video driver initialized the display.

    Share this comment


    Link to comment
    Share on other sites

    Same issue with RC8 and RC9.  I reverted back to 6.7.2 and no issue.  I guess I should try to pass through the USB controller to the VM.  

    Share this comment


    Link to comment
    Share on other sites

    I have the same issue in 6.8.0 stable release. As I went ahead upgraded from rc 9 I cannot go back to a version that was working. How could I downgrade to the last version that was working? Super annoying that I'm unable to use my VMs now. 

    Share this comment


    Link to comment
    Share on other sites

    6.8.1 RC 1

    My passed through USB keyboard was still returned back to the OS during the Windows 10 boot process

    Share this comment


    Link to comment
    Share on other sites


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.