• [6.9.0 RC2] Mover file does not exist

    • Minor

    When swapping my cache drive for a new one, i encountered a issue when moving data off my cache disk to the array with the mover.
    Lot of files did not get moved by the mover due a "does not exist" notice and No such file or directory.

    I had to move the files manually in the terminal. Files where not locked, neither where there permission issues.


    /mnt/user/appdata/linuxserver-plex/Library/Application Support/Plex Media Server/Metadata/TV Shows/8/145fa310d3a3602fe884933af4b1bb329951e0a.bundle/Contents/com.plexapp.agents.thetvdb/seasons/2/posters/d08056a72b0fb9cf1c627be9efe8d0bd1db65595


    Moving from /mnt/cache to /mnt/disk2/ resulted in this logging:

    Jan 11 18:19:34 UnNASty root: Specified filename /mnt/disk2/appdata/linuxserver-plex/Library/Application Support/Plex Media Server/Metadata/TV Shows/8/145fa310d3a3602fe884933af4b1bb329951e0a.bundle/Contents/_combined/seasons/2/posters/com.plexapp.agents.thetvdb_d08056a72b0fb9cf1c627be9efe8d0bd1db65595 does not exist.

    Jan 11 18:19:34 UnNASty move: move_object: /mnt/disk2/appdata/linuxserver-plex/Library/Application Support/Plex Media Server/Metadata/TV Shows/8/145fa310d3a3602fe884933af4b1bb329951e0a.bundle/Contents/_combined/seasons/2/posters/com.plexapp.agents.thetvdb_d08056a72b0fb9cf1c627be9efe8d0bd1db65595 No such file or directory

    No further logging found.

    This happend to most files of my appdata plex docker container.
    My guess it has to do with the length of the path?

    • Upvote 2

    User Feedback

    Recommended Comments


    This should be fixable by editing /usr/local/sbin/in_use and adding this:

    [[ -L "$file" ]] && exit 1 # ignore symlinks


    before this:

    fuser -s "$FILE" && exit


    At the moment I'm testing this in the go-file:

    # -------------------------------------------------
    # Workaround for mover bug (tested with Unraid 6.9.2, 6.11.2, 6.11.3)
    # https://forums.unraid.net/bug-reports/prereleases/690-rc2-mover-file-does-not-exist-r1232/
    # -------------------------------------------------
    if md5sum --status -c <<<"01a522332c995ea026c6817b8a688eee /usr/local/sbin/mover" || md5sum --status -c <<<"0a0d06f60de4a22b44f634e9824245b6 /usr/local/sbin/mover"; then
      sed -i '/shareUseCache="yes"/a\ \ \ \ \ \ \ \ find "${SHAREPATH%/}" -type l -depth | \/usr\/local\/sbin\/move -d $LOGLEVEL' /usr/local/sbin/mover
    It fixes


    • Upvote 1
    Link to comment
    On 6/19/2022 at 1:06 PM, mgutt said:

    This should be fixable by editing /usr/local/sbin/in_use and adding this:

    [[ -L "$file" ]] && exit 1 # ignore symlinks



    I'm testing this for a while now. Sadly it only avoids the error message, but the symlink is still not moved. If I enable the mover logs, it returns this, now:

    Aug  5 23:00:11 thoth move: move: skip /mnt/cache/Backups/Shares/appdata/20220731_044024/plex/Library/Application Support/Plex Media Server/Metadata/Artists/8/d45a63406b0ffd7d7558edc16e5e1b232cbccf1.bundle/Contents/_combined/posters/tv.plex.agents.music_b2d667cd09e7ce58d93780d1eb32630ed9cf61e0 [10301,88e801e1] /Backups/Shares/appdata/20220630_044049/plex/Library/Application Support/Plex Media Server/Metadata/Artists/8/d45a63406b0ffd7d7558edc16e5e1b232cbccf1.bundle/Contents/_combined/posters/tv.plex.agents.music_b2d667cd09e7ce58d93780d1eb32630ed9cf61e0 [-1]



    There must be an additional problem in /usr/local/sbin/move. Sadly it's a binary file, so I can't help any further (limetech needs to solve this).



    Link to comment

    Same problem here with Unraid 6.11.5


    I was preparing to replace my cache drive.


    As a workaround I used the unBALANCE Plugin to move the remaining appdata files. @SpaceInvaderOne explained it in method 2 in this excellent video:


    Edited by Leo007
    Link to comment


    Same issue here when trying to fully empty my cache drive containing appdata/docker-files.

    Also, the mover is super slow, barely above 100 KB/s…


    (I am using the unraid tuner plugin)

    Link to comment
    32 minutes ago, jakami99 said:

    trying to fully empty my cache drive containing appdata/docker-files

    Nothing can move open files. Did you disable Docker and VM Manager in Settings?

    Link to comment

    +1 The Same on 6.11.5

    Yes, I disabled Docker and VMs.

    I must moved the rest data on appdata/system/docker from cache to array and later from array to cache back again.


    Link to comment


    On 2/17/2023 at 1:05 AM, Revan335 said:

    +1 The Same on 6.11.5

    Yes, I disabled Docker and VMs.

    I must moved the rest data on appdata/system/docker from cache to array and later from array to cache back again.


    +1, saw the same thing when I attempted to add a second cache drive today with 6.11.5




    3 hours ago, ljm42 said:

    This should be fixed in the next release


    Glad that we should see a fix soon



    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.