Jump to content
  • BR0 is not showing up with 6.8.0-rc1 as before


    olympia
    • Solved Minor

    Following the upgrade I noticed my dockers with custom/fix IP address are not starting up with execution error.

    It turned out that the network type has got auto assigned to none and when checked, br0 is not available anymore in the network type.

     

    Was there a change regards to this?



    User Feedback

    Recommended Comments

    Could someone please confirm that br0 is showing up by default in docker settings/ network type?

     

    I only have "Bridge", "Host" and "None" as choices in the dropdown menu now, while "custom : br0" is not available as in v6.7.2

    Share this comment


    Link to comment
    Share on other sites
    8 minutes ago, olympia said:

    Could someone please confirm that br0 is showing up by default in docker settings/ network type?

    Yes, custom networks show up in 6.8.0-RC1.  Both of mine are in the list.  You must have an issue that prevents custom networks from being available.

     

    image.png.c01077c46d3bcced4dffdb015cb6b507.png

    Share this comment


    Link to comment
    Share on other sites

    Thank you for both!

     

    @bonienlthat did the trick! Many thanks for the hint! (Maybe something to include in the release notes :))

    Share this comment


    Link to comment
    Share on other sites

    Spoke too soon.

     

    While re-applying network settings helps, but after a reboot "custom : br0" disappears until I am re-applying network settings once again.

     

    So I need to re-apply network settings after each reboot for some reason to make custom nw available for dockers.

    Do you have an idea why is this? Shall I provide another diags?

    Share this comment


    Link to comment
    Share on other sites

    @bonienl

    @dlandon

     

    OK, I think I've got this figured out and it looks like this is caused by a race condition between detecting custom networks for dockers and the tips & tweak plugin applying "Disable NIC Flow Control" and "Disable NIC Offload".

     

    If I have tips & tweaks on default settings then custom networks are showing up for dockers, if I set the above two options to yes, then customer networks are not detected.

     

    Does this make any sense to you?

     

    Share this comment


    Link to comment
    Share on other sites
    14 hours ago, olympia said:

    Does this make any sense to you?

    Yes.

    Tips and tweaks makes changes to the interface, which becomes disabled, causing docker not to see it when it is started and hence the custom network br0 is not created.

    Oct 15 11:24:25 Tower kernel: br0: port 1(eth0) entered disabled state
    Oct 15 11:24:25 Tower tips.and.tweaks: Tweaks Applied
    Oct 15 11:24:33 Tower rc.docker: qbittorrent: Error response from daemon: network 69343f3bce328d98de4c1f7a854261aad7985f52c84c8026adbe8aef3826c91b not found

     

    Edited by bonienl

    Share this comment


    Link to comment
    Share on other sites
    14 minutes ago, olympia said:

    So I guess this is something for @dlandon  to address in the tips and tweaks plugin?

    This can not be solved in the plugin itself, I am afraid (due to how Unraid initiates all steps).

    Why do you want to disable flow-control and offload in the first place? Use defaults as much as possible.

    Share this comment


    Link to comment
    Share on other sites

    I have no hard reason, I was just following the recommendation of a trustworthy plugin author kind of blindly :)

     

    I presume this should be handled somehow (maybe a warning in the plugin could be enough), because I don't think I will be the only one with this issue, especially when 6.8.0 stable gets released.

    Share this comment


    Link to comment
    Share on other sites
    8 hours ago, olympia said:

    Thanks @bonienl!

    So I guess this is something for @dlandon  to address in the tips and tweaks plugin?

    There is nothing for me to address in the plugin.  You make changes based on your own needs and there is no guarantee that the changes won't cause any problems.

     

    Some people have reported issues with flow control and offloads.  If disabling those doesn't work for you, then leave them enabled.

    • Thanks 1

    Share this comment


    Link to comment
    Share on other sites

    OK, I close it here, I continue with dlandon in the plugin thread.

     

    Thanks for the attention.

    Share this comment


    Link to comment
    Share on other sites


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.