• Docker custom Paths not working


    Glasti
    • Solved Minor

    Running the Hotio Plex Container.
    Unraid 6.9 RC2

     

    I have a some costum mapping to move some folder outside the appdata folder for more efficient backups.

    Checked  my backups from 6.8.3 before, and there the mapping worked.

     

    These are my mappings.

     

    /config <---> /mnt/user/appdata/plex
    
    
    /transcode <---> /dev/shm
    
    
    /data <---> /mnt/user/data
    
    
    /config/app/Plex Media Server/Media <---> /mnt/user/plex_data/Media
    
    
    /config/app/Plex Media Server/Cache/Transcode/Sync+ <---> /mnt/user/plex_data/Cache/Transcode/Sync+
    
    
    /config/app/Plex Media Server/Cache/PhotoTranscoder <---> /mnt/user/plex_data/Cache/PhotoTranscoder
    
    
    /config/app/Plex Media Server/Metadata <---> /mnt/user/plex_data/Metadata

    Now i have noticed that sometimes Metadata is still being written inside appdata Metadata folder. Also Metadata is not showing properly inside plex, meaning it is reading from the wrong folder. This seems to happen after script restart, docker restart and/or server reboot.
    If i then restart the container manually it looks at the correct folders again.

     

    I have no idea what is causing this and or how to fix it. I know other people with the same container and same setup that are not seeing this issue.. 

     

    Hope that someone can give me some suggestions on how to possibly fix this!

     

    Thanks


    Edit: I reposted it here from user costumisations as it feels like a 6.9 bug. 
     

    tower-diagnostics-20210117-1008.zip



    User Feedback

    Recommended Comments

    DOH, changing to `/mnt/cache/plex_data/*` worked. I swear i have tried this before and claimed it not working.... But i am wrong.. :D

     

    Link to comment
    Share on other sites


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.