• RC1 - formatting bug

    • Closed

    There seems to be an issue regarding creating a pool of drives (ZFS testing in this case) and having Unraid format them. It always seems to fail. I can add them back to a normal array and have them format normally, however, just not when added to a new pool. The type of RAIDz did not seem to matter.

    User Feedback

    Recommended Comments

    Just to add to this, trying to create a ZFS RAID0 pool w/ 2 SSDs and here are my steps:


    1. Stop array.

    2. Pool Devices.

    3. Add.

    4. Name, zfs_cache.

    5. Slots, 2.

    6. Assign 2 SSDs, same size.

    7. Select first disk and select zfs, raid0, unable to hit apply, only able to select done.

    8. fs indicates auto even though I selected zfs.

    9. Start array.

    10. Pool show as unformatted.

    11. Select format and always formats to btrfs.


    I have attempted multiple times w/ out success and maybe my workflow is incorrect...



    Link to comment
    13 hours ago, JorgeB said:

    Diagnostics please.

    See attached, tried again and can't make zfs stick as a type when added to a pool, always reverts back to auto, and once created and I select format from Array Operations tab, always btrfs.



    I can create a single zfs pool, but RAID0 zfs pool no sucess and what is odd zpool list show both correctly, ZFS Master plugin shows both pools correctly as RAID0, but from Pool Devices tab shows unmounted/unrecognized FS and the same from the Array Operations Tab, see pics below:









    Edited by Govnah
    Link to comment

    I did some more digging/testing and apparently the old pool still existed and prevented the formatting of the drives as they were still connected to that pool in the BG. I did a 'zpool destroy' on that old pool and attempted to format and it had no issues. That leads me to believe that the issue is the pools not being edited properly when created or destroyed via the GUI.

    • Like 1
    Link to comment
    20 hours ago, Govnah said:

    See attached



    13 hours ago, Govnah said:

    Seems RC2 has addressed my issue

    Unlikely that fixed it since nothing was changed about zfs formatting problem, probably the reboot helped.

    Link to comment
    12 hours ago, chlballi said:

    I did some more digging/testing and apparently the old pool still existed and prevented the formatting of the drives as they were still connected to that pool in the BG.

    The problem was not the pool existing, problem was that the pool was online/mounted, so it could not be reformatted, if the pool is online you must export it first:


    zpool export pool_name


    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.