• rpc.statd not starting on boot

    • Solved Minor

    Running 6.10.0 RC1


    I have a remote NFS share that is normally mounted with UD. This worked well on stable release after reboots.

    After upgrade UD will not mount the remote share and fails with:


    Sep 23 17:55:20 unraid unassigned.devices: Error: shell_exec(/sbin/mount -t 'nfs' -o rw,noacl '' '/mnt/remotes/' 2>&1) took longer than 10s!
    Sep 23 17:55:20 unraid unassigned.devices: NFS mount failed: 'command timed out'.
    Sep 23 17:55:20 unraid unassigned.devices: Mount of '' failed: 'command timed out'.


    When running the command on the terminal I get:


    root@unraid:~# /sbin/mount -t 'nfs' -o rw,noacl '' '/mnt/remotes/'
    mount.nfs: rpc.statd is not running but is required for remote locking.
    mount.nfs: Either use '-o nolock' to keep locks local, or start statd.


    Then I run



    It gives no output, but immediately afterwards the NFS share mounts without problem.


    Seems like rpc.statd or rpcbind is not loaded automatically at startup. How can I resolve this?



    User Feedback

    Recommended Comments

    3 hours ago, jluerken said:

    exactly the same problem

    Do you mean you are using Unassigned Devices for this? UD is a plugin and questions about a plugin should be posted to its support thread.

    Link to comment
    3 hours ago, jluerken said:

    same problem using 6.10.0 RC2

    The original poster marked this as solved after this reply

    On 10/4/2021 at 3:02 PM, ljm42 said:

    Is NFS support enabled on the Settings -> NFS page?

    Does that not solve it for you?


    If not then maybe you don't have

    3 hours ago, jluerken said:

    exactly the same problem

    Maybe a new report with your diagnostics would be appropriate.

    • Haha 1
    Link to comment

    This issue is related to the Unassigned Devices Plugin, please close this report and continue discussion in the UD topic.


    Link to comment

    I am adding some logging to UD to show that the NFS mount will not work until NFS is enabled.  I also am disabling the Penguin icon when adding a NFS mount with a warning on the dialog when NFS is not enabled.


    NFS is required to be enabled for NFS clients on Unraid.

    • Like 2
    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.