• Spindown logic in RC2?


    I don't know if this is a bug but I wasn't sure where else to post it.




    I have two spindown problems in RC2:

    I've set default spindown to 15 minutes to help with testing.


    (1) The USB disk in Unassigned devices

    Unraid tries to spin it down (good!) but doesn't actually do it. That may be a problem with the drive's USB interface so I've cron'd a user script to spin it down with hdparm -y /dev/sdb (which works.) It looks like unRAID never detects that it's spun down (or a successful return from its own spindown call) because absent drive activity I see this every 15 minutes in the log whatever the drive's status:

    Dec 20 06:45:05 NAS emhttpd: spinning down /dev/sdb
    Dec 20 07:00:06 NAS emhttpd: spinning down /dev/sdb


    (2) The Fast pool

    These are 2.5" 7200rpm WD Blacks which also don't spin down. I see nothing in the log indicating unRAID attempts to spin them down except when I trigger it manually with the Web GUI

    Dec 19 21:09:57 NAS emhttpd: spinning down /dev/sdj
    Dec 19 21:09:57 NAS emhttpd: spinning down /dev/sdf
    Dec 19 21:09:57 NAS emhttpd: spinning down /dev/sdi


    I've attached diagnostics but this is more a request for information. Should I see spindown calls for Pool drives in syslog?


    (I should mention I haven't seen the array disks spin down either but they're set to 2 hours and haven't really had a chance. I'll lower it and keep an eye out.)


    User Feedback

    Recommended Comments

    3 minutes ago, TRusselo said:

    How could I tell?  What is it?  would it be causing my drives to stay spun up? How can i stop it?


    They only spin down if I tell them to.  Where they used to only spin up when needed.

    Found my issue. RESOLVED for me.

    Grafana Unraid Stack (GUS) Docker. ill go there for support.

    Edited by TRusselo
    Link to comment
    12 hours ago, TRusselo said:

    Found my issue. RESOLVED for me.

    Grafana Unraid Stack (GUS) Docker. ill go there for support.



    Specifically it's the smartctl calls in telegraf (part of GUS.) Alternatively you can comment out the [[inputs.smart]] block in Grafana-Unraid-Stack/telegraf/telegraf.conf to disable them.


    Seems for whatever reason (new kernel, new smartctl) these calls are recorded as disk activity which causes the disks to fail unraid's "If inactive for X minutes, spindown" test.

    • Like 1
    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.