• Unraid OS version 6.10.0-rc1 available


    6.10.0 Summary of New Features


    As always, prior to updating, create a backup of your USB flash device:  "Main/Flash/Flash Device Settings" - click "Flash Backup".


    UPC and My Servers Plugin

    The most visible new feature is located in the upper right of the webGUI header.  We call this the User Profile Component, or UPC.  The UPC allows a user to associate their server(s) and license key(s) with their Unraid Community forum account.


    Starting with this release, it will be necessary for a new user to either sign-in with existing forum credentials or sign-up, creating a new account via the UPC in order to download a Trial key.  All key purchases and upgrades are also handled exclusively via the UPC.


    Signing-in provides these benefits:

    1. No more reliance on email and having to copy/paste key file URLs in order to install a license key - keys are delivered and installed automatically to your server.
    2. Notification of critical security-related updates.  In the event a serious security vulnerability has been discovered and patched, we will send out a notification to all email addresses associated with registered servers.
    3. Ability to install the My Servers plugin (see below).
    4. Posting privilege in a new set of My Servers forum boards.


    Once a license key has been provisioned, it is not necessary to remain signed-in, though there is no particular reason to sign-out.  Exception: if you have installed the My Servers plugin, signed-in servers will maintain a websocket connection to a Lime Technology cloud server for the purpose of transmitting real-time status.


    My Servers Plugin

    My Servers is what we call our set of cloud-based or cloud-enabled services and features that integrate with your Unraid server(s).  Once installed here are some of the features of My Servers:

    • My Servers Dashboard - when logged into the forum a new My Servers menu item appears. Clicking this brings up a Dashboard which displays a set of tiles representing each signed-in server.  Here you can see real-time status such as whether the server is online or offline, storage utilization and other information.  In addition, links are created to bring up a server webGUI, either locally on the LAN or remotely over the Internet (if Remote Access has been enabled).
    • flash backup - every registered server is provided with a private git repo initially populated with the contents of your USB flash boot device (except for certain files which contain private information such as passwords).  Thereafter, configuration changes are automatically committed.  Through the My Servers webApp it's possible to download a custom zip file that can be fed as input to the USB Flash Creator tool to move your configuration to a new USB flash device.
    • License key download - Again, through the My Servers webApp you can download your license key directly.


    My Servers is an optional add-on, installed through Community Apps or via direct plugin URL.  Detailed instructions can be found here.


    Security Changes

    • It is now mandatory to define a root password.  We also created a division in the Users page to distinguish root from other user names.  The root UserEdit page includes a text box for pasting SSH authorized keys.
    • For new configurations, the flash share default export setting is No.
    • For all new user shares, the default export setting is No.
    • For new configurations, SMBv1 is disabled by default.
    • For new configurations, telnet, ssh, and ftp are disabled by default.
    • We removed certain strings from Diagnostics such as passwords found in the 'go' file.



    Both libvirt and qemu have been updated.  In addition qemu has been compiled with OpenGL support.


    The built-in FireFox browser available in GUI-mode boot is built as an AppImage and located in the bzfirmware compressed file system image.  This saves approximately 60MB of RAM.


    The Wireguard plugin has been integrated into webGUI, that is, no need for the plugin.  If you had the plugin installed previously, it will be uninstalled and moved to the "Plugins/Plugin File Install Errors" page. No action is needed unless you want to press the Delete button to remove it from that page. Your WireGuard tunnels and settings will be preserved.


    Simplified installation of the Community Apps plugin.  The webGUI automatically includes the Apps menu item, and if CA is not already installed, the page offers an Install button.  No need to hunt for the plugin link.


    Let's Encrypt SSL provisioning change.  In previous releases code that provisions (allocates and downloads) a LE SSL certificate would first test if DNS Rebinding Protection was enforced on the user's LAN; and, if so, would not provision the certificate.  Since there are other uses for a LE certificate we changed the code so that provision would always proceed.  Next, we changed the logic behind the Auto selection of "Use SSL/TLS" setting on the Management Access page.  Now it is only possible to select Auto if both a LE certificate has been provisioned and DNS Rebinding Protection is not enforced.  This is a subtle change but permits certain My Servers features such as Remote Access.


    Linux Kernel

    Upgrade to Linux 5.13.8 kernel which includes so-called Sequoia vulnerability mitigation.


    In-tree GPU drivers are now loaded by default if corresponding hardware is detected:

    • amdgpu
    • ast
    • i915
    • radeon


    These drivers are required mostly for motherboard on-board graphics used in GUI boot mode.  Loading of a driver can be prohibited by creating the appropriate file named after the driver:

    echo "blacklist i915" > /boot/config/modprobe.d/i915.conf

    Alternately, the device can be isolated from Linux entirely via the System Devices page.  Note that in Unraid OS 6.9 releases the in-tree GPU drivers are blacklisted by default and to enabling loading a driver you need to create an empty "conf" file.  After upgrading to Unraid OS 6.10 you may delete those files, or leave them as-is.  This change was made to greatly improve the Desktop GUI experience for new users.


    Added support for Intel GVT-g, which lets you split your Intel i915 iGPU into multiple virtual GPUs and pass them through to multiple VMs, using @ich777's Intel-GVT-g plugin.


    Added support for gnif/vendor-reset.  This simplifies @ich777's AMD Vendor Reset plugin which permits users to get their AMD video cards to reset properly.


    Base Packages

    Virtually the entire base package set has been updated.


    Other improvements available in 6.10, which are maybe not so obvious to spot from the release notes and some of these improvements are internal and not really visible:



    Event driven model to obtain server information and update the webGUI in real-time

    • The advantage of this model is its scalability. Multiple browsers can be opened simultaneously to the webGUI without much impact
    • In addition stale browser sessions won't create any CSRF errors anymore
    • People who keep their browser open 24/7 will find the webGUI stays responsive at all times


    Docker labels

    • Docker labels are added to allow people using Docker compose to make use of icons and GUI access
    • Look at a Docker 'run' command output to see exactly what labels are used


    Docker custom networks

    • A new setting for custom networks is available. Originally custom networks are created using the macvlan mode, and this mode is kept when upgrading to version 6.10
    • The new ipvlan mode is introduced to battle the crashes some people experience when using macvlan mode. If that is your case, change to ipvlan mode and test. Changing of mode does not require to reconfigure anything on Docker level, internally everything is being taken care off.


    Docker bridge network (docker0)

    • docker0 now supports IPv6. This is implemented by assigning docker0 a private IPv6 subnet (fd17::/64), similar to what is done for IPv4 and use network translation to communicate with the outside world
    • Containers connected to the bridge network now have both IPv4 and IPv6 connectivity (of course the system must have IPv6 configured in the network configuration)
    • In addition several enhancements are made in the IPv6 implementation to better deal with the use (or no-use) of IPv6


    Plugins page

    • The plugins page now loads information in two steps. First the list of plugins is created and next the more time consuming plugin status field is retrieved in the background. The result is a faster loading plugins page, especially when you have a lot of plugins installed


    Dashboard graphs

    • The dashboard has now two graphs available. The CPU graph is displayed by default, while the NETWORK graph is a new option under Interface (see the 'General Info' selection)
    • The CPU graph may be hidden as well in case it is not desired
    • Both graphs have a configurable time-line, which is by default 30 seconds and can be changed independently for each graph to see a longer or shorter history.
    • Graphs are updated in real-time and are useful to observe the behavior of the server under different circumstances


    Other Changes

    • We switched to a better-maintained version of the WSD server component called wsdd2 in an effort to eliminate instances where the wsd daemon would start consuming 100% of a CPU core.
    • Fixed issue where you couldn't create a docker image on a share name that contains a space.
    • Fixed issue where 'mover' would not move to a pool name that contains a space.
    • Fixed issue in User Share file system where permissions were not being honored.
    • We increased the font size in Terminal.
    • Many other small bug fixes and improvements.



    Special thanks to all our beta testers and especially:

    @bonienl for his continued refinement and updating of the Dynamix webGUI.

    @Squid for continued refinement of Community Apps and associated feed.

    @dlandon for continued refinement of Unassigned Devices plugin and patience as we change things under the hood.

    @ich777 for assistance and passing on knowledge of Linux kernel config changes to support third party drivers and other kernel-related functionality via plugins.

    @SimonF for refinements to System Devices page and other webGUI improvements.  We intend to merge your mover progress changes during this RC series.



    Version 6.10.0-rc1 2021-08-07


    Base distro:

    • aaa_base: version 15.0
    • aaa_glibc-solibs: version 2.33
    • aaa_libraries: version 15.0
    • acl: version 2.3.1
    • acpid: version 2.0.32
    • adwaita-icon-theme: version 40.1.1
    • apcupsd: version 3.14.14
    • appres: version 1.0.5
    • at: version 3.2.2
    • at-spi2-atk: version 2.38.0
    • at-spi2-core: version 2.40.3
    • atk: version 2.36.0
    • attr: version 2.5.1
    • avahi: version 0.8
    • bash: version 5.1.008
    • beep: version 1.3
    • bin: version 11.1
    • bind: version 9.16.19
    • bluez-firmware: version 1.2
    • bridge-utils: version 1.7.1
    • brotli: version 1.0.9
    • btrfs-progs: version 5.13.1
    • bzip2: version 1.0.8
    • ca-certificates: version 20210526
    • cairo: version 1.16.0
    • celt051: version
    • cifs-utils: version 6.13
    • coreutils: version 8.32
    • cpio: version 2.13
    • cpufrequtils: version 008
    • cracklib: version 2.9.7
    • cryptsetup: version 2.3.6
    • curl: version 7.78.0
    • cyrus-sasl: version 2.1.27
    • db48: version 4.8.30
    • dbus: version 1.12.20
    • dbus-glib: version 0.112
    • dcron: version 4.5
    • dejavu-fonts-ttf: version 2.37
    • devs: version 2.3.1
    • dhcpcd: version 8.1.9
    • diffutils: version 3.8
    • dmidecode: version 3.3
    • dnsmasq: version 2.85
    • docker: version 20.10.6
    • dosfstools: version 4.2
    • e2fsprogs: version 1.46.3
    • ebtables: version 2.0.11
    • editres: version 1.0.7
    • eject: version 2.1.5
    • elogind: version 246.10
    • elvis: version 2.2_0
    • encodings: version 1.0.5
    • etc: version 15.0
    • ethtool: version 5.13
    • eudev: version 3.2.10
    • file: version 5.40
    • findutils: version 4.8.0
    • flex: version 2.6.4
    • floppy: version 5.5
    • fluxbox: version 1.3.7
    • fontconfig: version 2.13.92
    • freeglut: version 3.2.1
    • freetype: version 2.11.0
    • fribidi: version 1.0.10
    • fuse3: version 3.10.4
    • gawk: version 5.1.0
    • gd: version 2.3.2
    • gdbm: version 1.20
    • gdk-pixbuf2: version 2.42.6
    • genpower: version 1.0.5
    • getty-ps: version 2.1.0b
    • git: version 2.32.0
    • glew: version 2.2.0
    • glib2: version 2.68.3
    • glibc: version 2.33
    • glibc-zoneinfo: version 2021a
    • glu: version 9.0.2
    • gmp: version 6.2.1
    • gnutls: version 3.6.16
    • gptfdisk: version 1.0.8
    • graphite2: version 1.3.14
    • grep: version 3.6
    • gtk+3: version 3.24.30
    • gzip: version 1.10
    • harfbuzz: version 2.8.2
    • haveged: version 1.9.14
    • hdparm: version 9.62
    • hicolor-icon-theme: version 0.17
    • hostname: version 3.23
    • htop: version 3.0.5
    • hwloc: version 2.2.0
    • icu4c: version 69.1
    • imlib2: version 1.7.1
    • inetd: version 1.79s
    • infozip: version 6.0
    • inih: version 53
    • inotify-tools: version
    • iproute2: version 5.13.0
    • iptables: version 1.8.7
    • iputils: version 20210722
    • irqbalance: version 1.7.0
    • jansson: version 2.13.1
    • jemalloc: version 5.2.1
    • jq: version 1.6
    • json-c: version 0.15_20200726
    • keyutils: version 1.6.3
    • kmod: version 29
    • krb5: version 1.19.2
    • lbzip2: version 2.5
    • less: version 590
    • libICE: version 1.0.10
    • libSM: version 1.2.3
    • libX11: version 1.7.2
    • libXau: version 1.0.9
    • libXaw: version 1.0.14
    • libXcomposite: version 0.4.5
    • libXcursor: version 1.2.0
    • libXdamage: version 1.1.5
    • libXdmcp: version 1.1.3
    • libXevie: version 1.0.3
    • libXext: version 1.3.4
    • libXfixes: version 6.0.0
    • libXfont: version 1.5.2
    • libXfont2: version 2.0.5
    • libXfontcache: version 1.0.5
    • libXft: version 2.3.4
    • libXi: version 1.7.10
    • libXinerama: version 1.1.4
    • libXmu: version 1.1.3
    • libXpm: version 3.5.13
    • libXrandr: version 1.5.2
    • libXrender: version 0.9.10
    • libXres: version 1.2.1
    • libXt: version 1.2.1
    • libXtst: version 1.2.3
    • libXxf86dga: version 1.1.5
    • libXxf86misc: version 1.0.4
    • libXxf86vm: version 1.1.4
    • libaio: version 0.3.112
    • libarchive: version 3.5.1
    • libcap-ng: version 0.8.2
    • libcgroup: version 0.41
    • libdaemon: version 0.14
    • libdmx: version 1.1.4
    • libdrm: version 2.4.107
    • libedit: version 20210714_3.1
    • libepoxy: version 1.5.8
    • libestr: version 0.1.9
    • libevdev: version 1.11.0
    • libevent: version 2.1.12
    • libfastjson: version 0.99.9
    • libffi: version 3.3
    • libfontenc: version 1.1.4
    • libgcrypt: version 1.9.3
    • libglvnd: version 1.3.3
    • libgpg-error: version 1.42
    • libgudev: version 236
    • libidn: version 1.38
    • libjpeg-turbo: version 2.1.0
    • liblogging: version 1.0.6
    • libmnl: version 1.0.4
    • libnetfilter_conntrack: version 1.0.8
    • libnfnetlink: version 1.0.1
    • libnftnl: version 1.2.0
    • libnl3: version 3.5.0
    • libpcap: version 1.10.1
    • libpciaccess: version 0.16
    • libpng: version 1.6.37
    • libpsl: version 0.21.1
    • libpthread-stubs: version 0.4
    • libseccomp: version 2.5.1
    • libssh: version 0.9.5
    • libssh2: version 1.9.0
    • libtasn1: version 4.17.0
    • libtiff: version 4.3.0
    • libtiff: version 4.3.0
    • libtirpc: version 1.3.2
    • libunistring: version 0.9.10
    • libunwind: version 1.5.0
    • libusb: version 1.0.24
    • libusb-compat: version 0.1.7
    • libuv: version 1.41.0
    • libvirt: version 7.3.0
    • libvirt-php: version 0.5.5
    • libwebp: version 1.2.0
    • libwebsockets: version 4.2.0
    • libx86: version 1.1
    • libxcb: version 1.14
    • libxkbcommon: version 1.3.0
    • libxkbfile: version 1.1.0
    • libxml2: version 2.9.12
    • libxshmfence: version 1.3
    • libxslt: version 1.1.34
    • libzip: version 1.8.0
    • listres: version 1.0.4
    • lm_sensors: version 3.6.0
    • lmdb: version 0.9.29
    • logrotate: version 3.18.1
    • lshw: version B.02.19.2
    • lsof: version 4.94.0
    • lsscsi: version 0.32
    • lvm2: version 2.03.12
    • lz4: version 1.9.3
    • lzip: version 1.22
    • lzo: version 2.10
    • mc: version 4.8.26
    • miniupnpc: version 2.1
    • mkfontscale: version 1.2.1
    • mpfr: version 4.1.0
    • mtdev: version 1.1.6
    • nano: version 5.8
    • ncompress: version 5.0
    • ncurses: version 6.2_20201219
    • net-tools: version 20181103_0eebece
    • nettle: version 3.7.3
    • network-scripts: version 15.0
    • nfs-utils: version 2.5.4
    • nghttp2: version 1.44.0
    • nginx: version 1.19.9
    • nss-mdns: version 0.14.1
    • ntfs-3g: version 2017.3.23
    • ntp: version 4.2.8p15
    • numactl: version 2.0.13
    • oniguruma: version 6.9.7
    • openssh: version 8.6p1
    • openssl: version 1.1.1k
    • openssl-solibs: version 1.1.1k
    • p11-kit: version 0.24.0
    • pam: version 1.5.1
    • pango: version 1.48.7
    • patch: version 2.7.6
    • pciutils: version 3.7.0
    • pcre: version 8.45
    • pcre2: version 10.37
    • php: version 7.4.18
    • pixman: version 0.40.0
    • pkgtools: version 15.0
    • procps-ng: version 3.3.17
    • pv: version 1.6.6
    • qemu: version 6.0.0
    • qrencode: version 4.1.1
    • reiserfsprogs: version 3.6.27
    • rpcbind: version 1.2.5
    • rsync: version 3.2.3
    • rsyslog: version 8.2102.0
    • sakura: version 3.5.0
    • samba: version 4.12.15
    • sdparm: version 1.12
    • sed: version 4.8
    • sessreg: version 1.1.2
    • setxkbmap: version 1.3.2
    • sg3_utils: version 1.46
    • shadow: version 4.8.1
    • shared-mime-info: version 2.1
    • slim: version 1.3.6
    • smartmontools: version 7.2
    • spice: version 0.15.0
    • sqlite: version 3.36.0
    • ssmtp: version 2.64
    • startup-notification: version 0.12
    • sudo: version 1.9.7p2
    • sysfsutils: version 2.1.0
    • sysvinit: version 2.99
    • sysvinit-scripts: version 15.0
    • talloc: version 2.3.2
    • tar: version 1.34
    • tcp_wrappers: version 7.6
    • tdb: version 1.4.5
    • telnet: version 0.17
    • tevent: version 0.11.0
    • traceroute: version 2.1.0
    • transset: version 1.0.2
    • tree: version 1.8.0
    • ttyd: version 20210507
    • usbredir: version 0.8.0
    • usbutils: version 013
    • utempter: version 1.2.0
    • util-linux: version 2.37.1
    • vbetool: version 1.2.2
    • vsftpd: version 3.0.5
    • vte3: version 0.50.2
    • wayland: version 1.19.0
    • wget: version 1.21.1
    • which: version 2.21
    • wireguard-tools: version 1.0.20210424
    • wsdd2: version
    • xauth: version 1.1
    • xcb-util: version 0.4.0
    • xclock: version 1.0.9
    • xdpyinfo: version 1.3.2
    • xdriinfo: version 1.0.6
    • xev: version 1.2.4
    • xf86-input-evdev: version 2.10.6
    • xf86-input-keyboard: version 1.9.0
    • xf86-input-mouse: version 1.9.3
    • xf86-input-synaptics: version 1.9.1
    • xf86-video-ast: version 1.1.5
    • xf86-video-mga: version 2.0.0
    • xf86-video-vesa: version 2.5.0
    • xfsprogs: version 5.12.0
    • xhost: version 1.0.8
    • xinit: version 1.4.1
    • xkbcomp: version 1.4.5
    • xkbevd: version 1.1.4
    • xkbutils: version 1.0.4
    • xkeyboard-config: version 2.33
    • xkill: version 1.0.5
    • xload: version 1.1.3
    • xlsatoms: version 1.1.3
    • xlsclients: version 1.1.4
    • xmessage: version 1.0.5
    • xmodmap: version 1.0.10
    • xorg-server: version 1.20.13
    • xprop: version 1.2.5
    • xrandr: version 1.5.1
    • xrdb: version 1.2.0
    • xrefresh: version 1.0.6
    • xset: version 1.2.4
    • xsetroot: version 1.1.2
    • xsm: version 1.0.4
    • xterm: version 368
    • xtrans: version 1.4.0
    • xwd: version 1.0.8
    • xwininfo: version 1.1.5
    • xwud: version 1.0.5
    • xxHash: version 0.8.0
    • xz: version 5.2.5
    • yajl: version 2.1.0
    • zlib: version 1.2.11
    • zstd: version 1.5.0

    Linux kernel:

    • version 5.13.8 (CVE-2021-33909 CVE-2021-33910)
    • CONFIG_USB4: Unified support for USB4 and Thunderbolt
    • CONFIG_USB4_NET: Networking over USB4 and Thunderbolt cables
    • CONFIG_DRM_I915_GVT: Enable Intel GVT-g graphics virtualization host support
    • CONFIG_DRM_I915_GVT_KVMGT: Enable KVM/VFIO support for Intel GVT-g
    • CONFIG_VFIO_MDEV: Mediated device driver framework
    • CONFIG_VFIO_MDEV_DEVICE: VFIO driver for Mediated devices
    • CONFIG_FTRACE: Tracers
    • CONFIG_FUNCTION_TRACER: Kernel Function Tracer
    • CONFIG_KPROBES: Kprobes
    • CONFIG_DEBUG_KERNEL: Kernel debugging
    • CONFIG_KALLSYMS_ALL: Include all symbols in kallsyms
    • CONFIG_X86_X32: removed
    • md_unraid: version 2.9.18


    • emhttp new defaults:
      - root password required
      - newly created shares not exported by default
      - predefined 'flash' share not exported by default
      - ftp, ssh, telnet: disabled by default
      - NetBIOS disabled by default
      - WSD enabled (and using newer 'wsdd2' package)
      - Enhanced macOS interoperability enabled
    • mover: fix bug not moving shares with embedded spaces
    • shfs: fix bug where permissions being ingored ('default_permissions' was missing in mount command)
    • webgui: support simultanious LAN SSL with self-signed cert and DNS-based SSL with Lets Encrypt cert
    • webgui: Suppress non-relevant IPv6 routes in routing table
    • webgui: Fixed smart temperature settings sometimes not possible
    • webgui: Add internal container reference
    • webgui: Diagnostics: Remove lines from go containing passwords etc
    • webgui: Better translation of docker container variables
    • webgui: Fix monitor false positives
    • webgui: Allow ruleset for local rules in rsyslog.conf
    • webgui: Include links in email and Discord agent notifications
    • webgui: Allow all notification agents to send links
    • webgui: Validate WebGUI ports before applying
    • webgui: Add vmxnet3 and e1000 into available NICs for VMs
    • webgui: Error checking etc on ports for syslog server
    • webgui: Check for flash offline / quick check on if it is corrupted
    • webgui: Only allow png files to be uploaded as user image
    • webgui: Diagnostics: Revamp anonymization
    • webgui: Add WireGuard GUI
    • webgui: Update DashStats.page
    • webgui: Bug fix in DashStats
    • webgui: Fix corruption check after a New Config is issued
    • webgui: Update alert text
    • webgui: Translation support (Unraid.net)
    • webgui: WireGuard: preset peer DNS server with "Remote tunneled access"
    • webgui: Plugins page loading improvements
    • webgui: Docker page loading improvements
    • webgui: Make WireGuard trademark visible on "full" page
    • webgui: Replace polling scripts with event driven Nchan interface
    • webgui: Improved format of stale and error plugin pages
    • webgui: Docker: Add crypto as a category
    • webgui: Dashboard: add CPU and NETWORK chart
    • webgui: Docker: compress too long author names
    • webgui: Convert notify polling to Nchan
    • webgui: Docker: process bash ANSI colors in web log display
    • webgui: dockerMan: remove HTML from descriptions
    • webgui: SSH authorized keys UI
    • webgui: Device_list replace .png icon with font icon
    • webgui: Compress too long share names in dropdown menus
    • webgui: Show management access and shares access groups for users
    • webgui: Added "User 'root'" reference on Management Access page
    • webgui: Show warning when javascript is disabled
    • webgui: Force creation of root password
    • webgui: Edit/Add Container: Fix browser console error
    • webgui: WireGuard: warn when directly connected with public IP
    • webgui: Fix network bonding display
    • webgui: Add tracking after system shutdown
    • webgui: Added notify when plugin fails to install
    • webgui: Add Apps link to install CA
    • webgui: Diagnostics: Add share summary
    • webgui: Suppress IPv6 anycast addresses in routing table
    • webgui: Diagnostics: Add share summary
    • webgui: Diagnostics: Include current plugin versions
    • webgui: Diagnostics: add DHCP log
    • webgui: Diagnostics fix plugin deprecated max version error
    • webgui: Docker: Support CA tag
    • webgui: Delete DockerRepositories.page
    • webgui: dockerMan Security: Remove HTML tags from Config elements
    • webgui: When viewing source, identify which .page file is responsible
    • webgui: System devices additions
    • webgui: Create syslog entry when user logs out
    • webgui: privatize host in diagnostics
    • webgui: Create favicon.ico
    • webgui: Update Credits.page
    • Like 22

    User Feedback

    Recommended Comments

    @uldise I'm not sure it is about iowait.....



    @-Daedalus I agree. I don't care about IO wait at all....And it is quite annoying when using the dashboard for monitoring.

    I didn't notice whether it exists before 6.10 releases....

    Link to comment
    7 minutes ago, Leoyzen said:

    I'm not sure it is about iowait.....

    you see you have pretty high emby usage there ...

    Link to comment
    41 minutes ago, alturismo said:

    you see you have pretty high emby usage there ...

    But it is not as much as graph in dashboard.

    (Average about 10%~15% in htop but  30%~70% in dashboard).


    I don't think it is about "Medium Load on **single process** (Emby with 35%)"

    Link to comment
    1 hour ago, Leoyzen said:

    I don't care about IO wait at all....

    On contrary, you should care about iowait.

    Too high iowait makes your system slow and unresponsive even if you have a powerful CPU.


    Link to comment
    4 hours ago, Leoyzen said:

    I'm not sure it is about iowait.....

    that it is - ~20% of your CPU are this iowait.

    and this is not new - one of my unraid servers is still on 6.5.3, and it's the same..


    3 hours ago, bonienl said:

    Too high iowait makes your system slow and unresponsive even if you have a powerful CPU.

    i agree with that. for example, my system have high iowait when NFS is in use. when transferring the same over samba, no problems. not sure what is the reason of such behavior..

    Link to comment
    4 hours ago, bonienl said:

    On contrary, you should care about iowait.

    Too high iowait makes your system slow and unresponsive even if you have a powerful CPU.


    @bonienl @uldiseOk I got it.

    I haven't noticed that before, but it is quite strange after upgrading 6.10...Maybe some behaviors have been changed as the status of io-waits which makes me feel "different" between 6.9.2 and 6.10.


    I will stay tuned.

    Link to comment
    On 8/17/2021 at 5:30 AM, ljm42 said:


    Hi @danioj, we have tested this on stock Unraid and can't reproduce the problem. If this was not an issue in 6.9.2, then I suspect a plugin has a conflict with some of the changes in 6.10.


    Would you please open a new thread here:

    with all the relevant info and include your diagnostics so we can see what plugins you have?


    Also, please try booting in safe mode and see if the problem goes away.


    Understood. I will set some time aside at the weekend to do as you ask.

    • Like 1
    Link to comment
    On 8/17/2021 at 6:45 AM, debit lagos said:


    Hate to even suggest (let alone ask) but did you clear your browser's cache to see if that clears it up?  Standard TTP for me after any upgrade.  


    It wasn't mentioned so thought I'd throw it out there... 


    Don't hate to ask, it's common to forget an obvious step sometimes, nice to be reminded to check the basics.


    However, on this occasion, I had tried that. Also, as mentioned, was able to reproduce the issue on an iPhone that had never access unRAID before.

    • Like 2
    Link to comment

    For some reason I am unable to set a custom br0 IP on any docker containers no more. The drop down only has host/bridge/none.



    Link to comment
    2 hours ago, jongyrocka said:

    For some reason I am unable to set a custom br0 IP on any docker containers no more. The drop down only has host/bridge/none.



    Settings - Docker - Advanced View with the service stopped


    Link to comment
    1 hour ago, Squid said:

    Settings - Docker - Advanced View with the service stopped



    Cheers - This was already enabled, but changing the custome network type back to 'ipvlan' seem to resolve the issue.

    Link to comment
    On 8/11/2021 at 3:38 AM, bonienl said:

    - Docker labels

    • Docker labels are added to allow people using Docker compose to make use of icons and GUI access
    • Look at a Docker 'run' command output to see exactly what labels are used



    Has anyone played with this yet? I can only get the the GUI access to work. Label sample below from my docker compose file.


          net.unraid.docker.icon: https://raw.githubusercontent.com/linuxserver/docker-templates/master/linuxserver.io/img/sonarr-icon.png
          #net.unraid.docker.managed: dockerman
          net.unraid.docker.webui: http://[IP]:[PORT:8989]/




    Link to comment

    Unfortunately, you are not offering me the update.


    I am currently using stable version 6.9.2. Even though I’m looking for a new update, it says it’s the latest. If I switch to "next" then there is no option either.

    Link to comment
    53 minutes ago, s_otto said:

    Unfortunately, you are not offering me the update.


    I am currently using stable version 6.9.2. Even though I’m looking for a new update, it says it’s the latest. If I switch to "next" then there is no option either.

    Can your server even hit the internet?  EG: After a reboot does the Apps tab work?

    Link to comment

    I don't feel like it's an improvement at all... It seems to be taking away on privacy and security with the cloud connect idea... I store private data on my Unraid server and I don't want that connected to any cloud (if I wanted that there are way more easy ways to host files in stead of running an Unraid server.


    And also... nfs v4 is long being asked for but totally ignored by the devs... Nfs v4 is probably not needed by  them and therefore no time is being spent on makeing it work... Better spend the time in a cloud system that a lot of us don't want and certainly don't need to have.


    Sorry about this hard comment, but I really feel like I shouldn't have chosen Unraid as a file server solution a few years back (I surely wouldn't have if I knew then what I know now).

    Link to comment
    3 hours ago, Guido said:


    And also... nfs v4 is long being asked for but totally ignored by the devs... Nfs v4 is probably not needed by  them and therefore no time is being spent on makeing it work...

    Not true.  It is being considered and will be implemented in due time.  There will be some testing I will need to do to be sure it doesn't break UD remote shares. I'm sure you'd like us to be sure it doesn't cause any major issues.


    The stale file handle issue has been around a long time with no clear answer and we want to see if it can eventually solve the stale file handle problem.

    Link to comment
    7 hours ago, Guido said:

    I store private data on my Unraid server and I don't want that connected to any cloud (if I wanted that there are way more easy ways to host files in stead of running an Unraid server.

    Where did you get the idea that stuff was being stored in the cloud?  Only thing being "stored" is a flash backup which is completely optional.  The rest of it is to allow easy access remotely to your server (basically a no-brainer reverse proxy to your server) which is also completely optional.

    Link to comment

    Any news of the intel hw transcoding problem? any progress for RC2?

    Edited by arturovf
    Link to comment
    8 minutes ago, Kopernikus said:

    What's the advantage of using ipvlan over macvlan?

    Hopefully less crashing on some unknown combination of software and hardware.

    Link to comment
    On 8/9/2021 at 3:10 PM, limetech said:


    Try clearing your browser cache.

    I am having this same issue.  Clearing Cache is not making a difference at all.  I am able to connect directly to the machine with RealVNC, so the issue is not in the host.

    Link to comment
    1 hour ago, Trucking Geek said:

    I am having this same issue.  Clearing Cache is not making a difference at all.  I am able to connect directly to the machine with RealVNC, so the issue is not in the host.


    The issue is with the client. If clearing the cache didn't help, then completely restart the browser. If the browser is Chrome, then the best thing is probably to fully reboot the client.

    Link to comment
    31 minutes ago, ljm42 said:


    The issue is with the client. If clearing the cache didn't help, then completely restart the browser. If the browser is Chrome, then the best thing is probably to fully reboot the client.

    OK.  So I cleared the cache then immediately closed Chrome.  I then rebooted the PC.  Logged back into the PC, and opened Chrome. Opened Unraid page for the server, and clicked on the VM and then on VNC Remote.  Still failed to connect.  I was using this VNC session on here for weeks without issue.  (To include some reboots, as it is a Windoze Client...)  Never an issue until today.   To be fair, I had taken these steps before ever starting the first post also.

    Link to comment

    This is now closed for further comments

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.