• Unraid OS version 6.11.0-rc1 available


    This release includes some bug fixes and update of base packages.  Sorry no major new feature in this release, but instead we are paying some "technical debt" and laying the groundwork necessary to add better third-party driver and ZFS support.  We anticipate a relatively short -rc series.


    Special thanks to @bonienl for implementation of background downloading, and @ich777 for working with us for better third-party driver integration, still a work-in-process.


    Please note: It would be extremely helpful to us to report issues by creating separate Reports here rather than creating a reply in this topic.


    As always, prior to updating, create a backup of your USB flash device:  "Main/Flash/Flash Device Settings" - click "Flash Backup".





    Special thanks to all our beta testers and especially:

    @bonienl for his continued refinement and updating of the Dynamix webGUI.

    @Squid for continued refinement of Community Apps and associated feed.

    @dlandon for continued refinement of Unassigned Devices plugin and patience as we change things under the hood.

    @ich777 for assistance and passing on knowledge of Linux kernel config changes to support third party drivers and other kernel-related functionality via plugins.

    @JorgeB for rigorous testing of storage subsystem


    Version 6.11.0-rc1 2022-07-25


    With this release there have been many base package updates including several CVE mitigations.

    The Linux kernel update includes mitigation for Processor MMIO stale-data vulnerabilities.

    The plugin system has been refactored so that 'plugin install' can proceed in the background. This alleviates issue where a user may think installation has crashed and closes the window, when actually it has not crashed.

    Many other webGUI immprovements.

    Bug fixes

    Fixed issue in VM manager where VM log can not open when VM name has an embedded '#' character.

    Fixed issue where Parity check pause/resume on schedule was broken.

    Change Log vs. Unraid OS 6.10

    Base distro:

    • aaa_base: version 15.1
    • aaa_glibc-solibs: version 2.35
    • aaa_libraries: version 15.1
    • adwaita-icon-theme: version 42.0
    • appres: version 1.0.6
    • at-spi2-core: version 2.44.1
    • atk: version 2.38.0
    • bind: version 9.18.5
    • btrfs-progs: version 5.18.1
    • ca-certificates: version 20220622
    • cifs-utils: version 6.15
    • coreutils: version 9.1
    • curl: version 7.84.0
    • dbus: version 1.14.0
    • dmidecode: version 3.4
    • docker: version 20.10.17 (CVE-2022-29526 CVE-2022-30634 CVE-2022-30629 CVE-2022-30580 CVE-2022-29804 CVE-2022-29162 CVE-2022-31030)
    • editres: version 1.0.8
    • ethtool: version 5.18
    • file: version 5.42
    • findutils: version 4.9.0
    • freeglut: version 3.2.2
    • freetype: version 2.12.1
    • fribidi: version 1.0.12
    • fuse3: version 3.11.0
    • gdbm: version 1.23
    • gdk-pixbuf2: version 2.42.8
    • git: version 2.37.1
    • glib2: version 2.72.3
    • glibc: version 2.35
    • gnutls: version 3.7.6
    • gptfdisk: version 1.0.9
    • harfbuzz: version 4.4.1
    • hdparm: version 9.64
    • htop: version 3.2.1
    • icu4c: version 71.1
    • inotify-tools: version
    • iproute2: version 5.18.0
    • iptables: version 1.8.8
    • json-c: version 0.16_20220414
    • kernel-firmware: version 20220705_f5f02da
    • kernel-headers: version 5.18.9
    • kmod: version 30
    • libX11: version 1.8.1
    • libXcursor: version 1.2.1
    • libaio: version 0.3.113
    • libcap-ng: version 0.8.3
    • libdrm: version 2.4.110
    • libepoxy: version 1.5.10
    • libevdev: version 1.12.1
    • libgcrypt: version 1.10.1
    • libgpg-error: version 1.45
    • libidn: version 1.41
    • libjpeg-turbo: version 2.1.3
    • libmnl: version 1.0.5
    • libnetfilter_conntrack: version 1.0.9
    • libnfnetlink: version 1.0.2
    • libnftnl: 1.2.2
    • libnl3: version 3.6.0
    • libtiff: version 4.4.0
    • libtiff: version 4.4.0
    • liburcu: version 0.13.1
    • libusb: version 1.0.26
    • libxcb: version 1.15
    • libxkbcommon: version 1.4.1
    • libzip: version 1.9.2
    • libX11: version 1.8.1
    • listres: version 1.0.5
    • logrotate: version 3.20.1
    • lsof: version 4.95.0
    • lzip: version 1.23
    • mc: version 4.8.28
    • mcelog: version 184
    • mkfontscale: version 1.2.2
    • nano: version 6.3
    • nettle: version 3.8
    • nfs-utils: version 2.6.1
    • nghttp2: version 1.48.0
    • ntfs-3g: version 2022.5.17
    • oniguruma: version 6.9.8
    • openssh: version 9.0p1
    • openssl: version 1.1.1q (CVE-2022-1292 CVE-2022-2097 CVE-2022-2274)
    • openssl-solibs: version 1.1.1q (CVE-2022-1292)
    • pango: version 1.50.8
    • pciutils: version 3.8.0
    • pcre2: version 10.40
    • php: version 7.4.30 (CVE-2022-31625 CVE-2022-31626)
    • rsync: version 3.2.4
    • samba: version 4.15.8
    • setxkbmap: version 1.3.3
    • shared-mime-info: version 2.2
    • sqlite: version 3.39.2
    • sudo: version 1.9.11p3
    • sysfsutils: version 2.1.1
    • tdb: version 1.4.7
    • tevent: version 0.12.1
    • tree: version 2.0.2
    • util-linux: version 2.38
    • wget: version 1.21.3
    • xauth: version 1.1.2
    • xclock: version 1.1.1
    • xdpyinfo: version 1.3.3
    • xfsprogs: version 5.18.0
    • xkeyboard-config: version 2.36
    • xload: version 1.1.4
    • xmodmap: version 1.0.11
    • xsm: version 1.0.5
    • xterm: version 372
    • xwud: version 1.0.6

    Linux kernel:

    • version 5.18.14 (CVE-2022-21123 (CVE-2022-21123 CVE-2022-21125 CVE-2022-21166)
    • oot: md/unraid: version 2.9.23
    • CONFIG_VIRTIO_IOMMU: Virtio IOMMU driver
    • CONFIG_X86_AMD_PSTATE: AMD Processor P-State driver
    • CONFIG_FIREWIRE: FireWire driver stack
    • CONFIG_FIREWIRE_OHCI: OHCI-1394 controllers
    • CONFIG_FIREWIRE_SBP2: Storage devices (SBP-2 protocol)
    • CONFIG_FIREWIRE_NET: IP networking over 1394
    • CONFIG_INPUT_UINPUT: User level driver support
    • CONFIG_INPUT_JOYDEV: Joystick interface
    • CONFIG_INPUT_JOYSTICK: Joysticks/Gamepads
    • CONFIG_JOYSTICK_XPAD: X-Box gamepad support
    • CONFIG_JOYSTICK_XPAD_FF: X-Box gamepad rumble support
    • CONFIG_JOYSTICK_XPAD_LEDS: LED Support for Xbox360 controller 'BigX' LED


    • rc.nginx: enable OCSP stapling on certs which include an OCSP responder URL
    • rc.wireguard: add better troubleshooting for WireGuard autostart
    • rc.S: support early load of plugin driver modules
    • upc: version v1.3.0
    • webgui: Plugin system update
      • Detach frontend and backend operation
      • Use nchan as communication channel
      • Allow window to be closed while backend continues
      • Use SWAL as window manager
      • Added multi remove ability on Plugins page
      • Added update all plugins with details
    • webgui: docker: use docker label as primary source for WebUI
      • This makes the 'net.unraid.docker.webui' docker label the primary source when parsing the web UI address. If the docker label is missing, the template value will be used instead.
    • webgui: Update Credits.page
    • webgui: VM manager: Fix VM log can not open when VM name has an embedded '#'
    • webgui: Management Access page: add details for self-signed certs
    • webgui: Parity check: fix regression error
    • webgui: Remove session creation in scripts
    • webgui: Update ssh key regex
      • Add support for ed25519/sk-ed25519
      • Remove support for ecdsa (insecure)
      • Use proper regex to check for valid key types
    • webgui: misc. style updates
    • Like 12
    • Thanks 3
    • Upvote 1

    User Feedback

    Recommended Comments

    So far so good.


    A couple of minor problems I haven't dug into:


    – I see this in the log, not sure what's causing it.

    kernel: Attempt to set a LOCK_MAND lock via flock(2). This support has been removed and the request ignored.


    – Nerd Pack hangs on retrieving plugin information


    • Like 1
    • Upvote 1
    Link to comment

    Yeah nerdpack is throwing this error a lot: 

    root: Warning: preg_grep() expects parameter 2 to be array, string given in /usr/local/emhttp/plugins/DevPack/scripts/devmanager on line 72


    Link to comment

    Love to see these quick release series. Hope all goes smoothly.

    • Upvote 1
    Link to comment

    Upgraded my i9-12900K system to this version yesterday and so far no issues to report and all is running smoothly.

    As CS01-HS reported i also noticed the following in the logs...


    kernel: Attempt to set a LOCK_MAND lock via flock(2). This support has been removed and the request ignored.


    I see someone else has uploaded their diags already but if you need another set please let me know. If this post gets any bigger ill create a separate bug report.


    Edited by Titan84
    Link to comment
    20 hours ago, CS01-HS said:

    – Nerd Pack hangs on retrieving plugin information


    Nerd pack needs to be updated. It keeps a database for each Unraid version. The database for 6.11 doesn't exist.


    • Thanks 3
    Link to comment

    well I messed up that original reply somehow... sorry mods


    46 minutes ago, tombunraider said:

    I saw that v6.11.0-rc2 is released now, but there's currently no changelog or thread.


    There is always a cumulative changelog available through the Unraid GUI :)


    Edited by tjb_altf4
    • Haha 1
    Link to comment
    6 hours ago, tjb_altf4 said:

    There is always a cumulative changelog available through the Unraid GUI :)

    Except when there isn't




    Interesting... when I took that screenshot, I hadn't yet visited the update OS page... I just clicked the (i) in the yellow banner on the top of whatever unraid page I had up. Opening the release notes from the update OS page works, and now that I've done that the release notes will appear if I open the release notes from the yellow banner.

    Link to comment

    I updated to 6.11.0-rc1 on my backup server.  Update went well. 


    The only thing I have noticed is that motherboard and CPU temps are not showing in GUI dashboard.  They were present in 6.10.3.  I am using the IPMI plugin and that continues to report CPU and MB temps in the GUI footer.


    There was also a motherboard BIOS update available (security mitigations) and I did that update before the unRAID update.  That could be the cause I suppose but, again, IPMI plugin still detects sensors and displays the temps.




    Link to comment
    On 7/27/2022 at 4:55 AM, bonienl said:


    Nerd pack needs to be updated. It keeps a database for each Unraid version. The database for 6.11 doesn't exist.


    Any ideas how quickly this can be resolved? I rely heavily on the tools in NerdPack so if its going to be several days I'm going to need to roll back.

    Link to comment
    7 minutes ago, weirdcrap said:

    Any ideas how quickly this can be resolved? I rely heavily on the tools in NerdPack so if its going to be several days I'm going to need to roll back.


    You should ask in the respective support thread of the plugin.


    Link to comment
    1 hour ago, bonienl said:


    You should ask in the respective support thread of the plugin.


    I did, I just hadn't really seen much of any activity from the plugin dev in the respective thread, their github, or the forum in general as of late (the last visit was 2 months ago).


    These pre-release threads tend to get more attention when things break in the RCs even when the issue isn't caused by the RC specifically so I figured I'd ask here as well.


    I'm going to roll back until this is fixed.


    EDIT: My statement above was not meant to imply I expect this to be fixed immediately. I understand we're all community members here who volunteer our free time to making unraid better.

    Edited by weirdcrap
    Link to comment

    This is now closed for further comments

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.