Jump to content
  • Unraid OS version 6.7.0-rc3 available


    limetech

    More bug fixes.  More refinements to webGUI, especially check out latest Community Apps plugin!

     

    Other highlights:

    • Parity sync/Data rebuild/Check pause/resume capability.  Main components in place.  Pause/resume not preserved across system restarts yet however.
    • Enhanced syslog capability.  Check out Settings/Nework Services/Syslog Server.

     

    Special thanks once again to @bonienl and @Mex.

     

    Version 6.7.0-rc3 2019-02-09

    Base distro:

    • jq: version 1.6
    • oniguruma: version 5.9.6_p1
    • php: version 7.2.14

    Linux kernel:

    • version: 4.19.20
    • md/unraid: version 2.9.6 (support sync pause/resume)
    • patch: PCI: Quirk Silicon Motion SM2262/SM2263 NVMe controller reset: device 0x126f/0x2263

    Management:

    • emhttp: use mkfs.btrfs defaults for metadata and SSD support
    • emhttp: properly dismiss "Restarting services" message
    • firmware:
    • added BCM20702A0-0a5c-21e8.hcd
    • added BCM20702A1-0a5c-21e8.hcd
    • vfio-pci script: bug fixes
    • webgui: telegram notification agent bug fixes
    • webgui: VM page: allow long VM names
    • webgui: Dashboard: create more space for Dokcer/VM names (3 columns)
    • webgui: Dashboard: include links to settings
    • webgui: Dashboard: fix color consistency
    • webgui: Syslinux config: replace checkbox with radio button
    • webgui: Docker page: single column for CPU/Memory load
    • webgui: Docker: usage memory usage in advanced view
    • webgui: Dashboard: fixed wrong display of memory size
    • webgui: Dashboard: fix incorrect memory type
    • webgui: Plugin manager: align icon size with rest of the GUI
    • webgui: Plugin manager: enlarge readmore height
    • webgui: Plugin manager: add .png option to Icon tag
    • webgui: Plugin manager: table style update
    • webgui: Added syslog server functionality
    • webgui: syslog icon update
    • webgui: Main: make disk identification mono-spaced font
    • webgui: Added parity pause/resume button
    • webgui: Permit configuration of parity device(s) spinup group.
    • Like 6
    • Upvote 1


    User Feedback

    Recommended Comments



    Upgraded both my RC2 servers without issue.  Will examine logs for any issues tomorrow 

    Share this comment


    Link to comment
    Share on other sites

    Upgraded to RC3 with only one notice in systemlog:

     

    unRAID root: Starting php-fpm [09-Feb-2019 19:47:21] NOTICE: PHP message: PHP Warning: PHP Startup: Unable to load dynamic library 'libvirt-php.so' (tried: /usr/lib64/php/extensions/libvirt-php.so (libidn2.so.4: cannot open shared object file: No such file or directory), /usr/lib64/php/extensions/libvirt-php.so.so (/usr/lib64/php/extensions/libvirt-php.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

     

    CVE's oustanding as of RC3:

     

    Curl has a few CVE's again. Latest is at 7.64.

    Oniguruma is at version 6.9.1

    (5.9.6_p1) has multiple CVE's

     

     

     

     

     

     

    Edited by Dazog

    Share this comment


    Link to comment
    Share on other sites
    13 minutes ago, Dazog said:

    unRAID root: Starting php-fpm [09-Feb-2019 19:47:21] NOTICE: PHP message: PHP Warning: PHP Startup: Unable to load dynamic library 'libvirt-php.so' (tried: /usr/lib64/php/extensions/libvirt-php.so (libidn2.so.4: cannot open shared object file: No such file or directory), /usr/lib64/php/extensions/libvirt-php.so.so (/usr/lib64/php/extensions/libvirt-php.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

    Not see that error here.  Maybe one of your installed plugins are causing this? (try booting in safe mode)

    Share this comment


    Link to comment
    Share on other sites

    Updated just right now. 

     

    I think something is off with the Main page. I just tried to use the mover and I can't see any real time updates for the read/write speed 

     

    Also, shows as everything moved, but my storage is the same in my cache drive. 

    Share this comment


    Link to comment
    Share on other sites

    Did anyone notice a drastic slowdown starting with RC2 when moving files? Sometimes i cant even access radarr, because it hangs. My Windows 10 VM says SSD Usage 100% and reaction time 1200seconds or something liek that..^^

    Edited by nuhll
    • Upvote 1

    Share this comment


    Link to comment
    Share on other sites
    7 hours ago, gacpac said:

    I think something is off with the Main page. I just tried to use the mover and I can't see any real time updates for the read/write speed 

    Working fine for me.

     

    Start your server in safe mode, and recheck.

    Share this comment


    Link to comment
    Share on other sites

    Any chance of kernel 4.20  and a newer drm in the 6.7 series?

    Edited by GreySyntax

    Share this comment


    Link to comment
    Share on other sites
    5 hours ago, nuhll said:

    Did anyone notice a drastic slowdown starting with RC2 when moving files? Sometimes i cant even access radarr, because it hangs. My Windows 10 VM says SSD Usage 100% and reaction time 1200seconds or something liek that..^^

    Yup. My storage took since yesterday to clean after the mover. But today I still see the readings the main page way to off. Like no reading or writing in hours and at the stats plugin. No activity for hours, I don't have a graph for HDD activity

    Share this comment


    Link to comment
    Share on other sites

    I cant even start mover. I just get alot of

     

    Feb 10 17:16:33 Unraid-Server emhttpd: error: send_file, 139: Broken pipe (32): sendfile: /usr/local/emhttp/update.htm
    Feb 10 17:16:33 Unraid-Server emhttpd: error: send_file, 139: Broken pipe (32): sendfile: /usr/local/emhttp/update.htm
    Feb 10 17:16:33 Unraid-Server emhttpd: error: send_file, 139: Broken pipe (32): sendfile: /usr/local/emhttp/update.htm
    Feb 10 17:16:33 Unraid-Server emhttpd: error: send_file, 139: Broken pipe (32): sendfile: /usr/local/emhttp/update.htm
    Feb 10 17:16:50 Unraid-Server shfs: share cache full
    Feb 10 17:19:56 Unraid-Server nginx: 2019/02/10 17:19:56 [error] 6635#6635: *23748 upstream timed out (110: Connection timed out) while reading upstream, client: 192.168.86.42, server: , request: "POST /update.htm HTTP/2.0", upstream: "http://unix:/var/run/emhttpd.socket:/update.htm", host: "7e8791b3aa0bbd8fe33ae9faa95413a1af5ece0a.unraid.net:444", referrer: "https://7e8791b3aa0bbd8fe33ae9faa95413a1af5ece0a.unraid.net:444/Main"

    Share this comment


    Link to comment
    Share on other sites
    6 hours ago, bonienl said:

    Working fine for me.

     

    Start your server in safe mode, and recheck.

    Just did and the cache is almost full now for no reason, same error, that size doesn't match what's really inside and the main page read and write, doesn't seem to be as fast or fluent as using rc2 and stable. 

     

    I'm rolling back

    Share this comment


    Link to comment
    Share on other sites
    4 minutes ago, gacpac said:

    I'm rolling back

    Please provide diagnostics before rolling back. They will help us investigate.

    Share this comment


    Link to comment
    Share on other sites
    8 minutes ago, gacpac said:

    Just did and the cache is almost full now for no reason, same error, that size doesn't match what's really inside and the main page read and write, doesn't seem to be as fast or fluent as using rc2 and stable. 

     

    I'm rolling back

    I'm uploading 2 diagnostics. 

    Diagnostics in safe mode 1151

    Diagnostics back to normal 1158

    tower-diagnostics-20190210-1151.zip

    tower-diagnostics-20190210-1158.zip

    Share this comment


    Link to comment
    Share on other sites

    People having problems with slowdowns, do you use encrypted xfs? 

     

     

    Share this comment


    Link to comment
    Share on other sites

    I think we have the same problem. I have a thread about it in the general support area as I thought I had the same problem in 6.6.6. Probably remembered wrong. Write speed on encrypted xfs is giving me like 10-15 MB/s. Changed to unencrypted xfs and got full speed back. Maybe need a separate bug report for that. 

     

    Edit:

    Made one

     

    Edited by Niklas

    Share this comment


    Link to comment
    Share on other sites
    11 minutes ago, dee31797 said:

    Sometimes when my SSD cache shows a different size to what's actually on there, a manual TRIM brings it back closer to even.

    /sbin/fstrim -a -v | logger &> /dev/null

    the manual trim worked, but I don't know something is off with those readings in the main page. Maybe I'm crazy

    Share this comment


    Link to comment
    Share on other sites
    3 hours ago, GreySyntax said:

    Any chance of kernel 4.20  and a newer drm in the 6.7 series?

    Last we were told is 4.20 is aim with possible 5.0 depending on when it is finalized.

     

     

    • Upvote 1

    Share this comment


    Link to comment
    Share on other sites
    2 hours ago, bonienl said:

    Please provide diagnostics before rolling back. They will help us investigate.

    I can recreate the issue without problem with the SSD. The used size is increased at restart and to fix the problem I have to do a manual trim. 

     

    I'll use it for couple more days before rolling back and report the issues here. 

    Share this comment


    Link to comment
    Share on other sites

    Having just looked at CA for the first time in a while (my server is running fine and I don't fiddle with it much), here's what I said to Squid about all the new CA icons:

     

    Quote

    I like the new icon style and shapes, but intensely dislike the lack of color. I know you're just following trends set by MS, Apple, & Google in their interfaces, but color is so vital to humans in recognizing things. Looking at my Settings | User Utilities section now is just one big sea of blue on a black (dark theme) background. It takes much more effort to look at each icon to see if it's the one I want, instead of just being able to find a color pattern. I guarantee you that ControlR and Unbalance are now the first things I see when I look at that screen simply because they're red and green (respectively) in an otherwise monochrome blur. FIP and Stats Settings are the next things I see - even though they're primarily blue, they're at least different shades of blue. Heck, I find ControlR on my phone screen because of the red circles even though my home screen page is full of different colored icons scattered everywhere (even though Android deems it necessary to put an ugly white circle behind them).

     

    Again, I get that you're following the herd, but when the herd is headed toward a cliff...

     

    Based on the comments, I'm going to guess that when I install 6.7, all the icons will be monochrome. For that reason alone, this will be one upgrade I'm not looking forward to.

     

    Just my 3 cents worth (gotta account for inflation)... 

    </rant> 

     

    I took a look at SpaceInvaderOne's video review of 6.7rc1 and I'll repeat my thoughts. The icon shapes are nice, but they're nothing but a sea of white. Again, I get that this is the latest trend in design, but it is, in my opinion a terrible one. There is considerably more cognitive load in mentally parsing the shapes when there is no color to help out. This is especially tough on those of us whose eyesight isn't quite as good as it used to be.

     

    There is a reason why modern IDEs all do syntax highlighting. This is an absolute God-send in comparison to the dark ages of working on a monochrome green or amber monitor! Just try disabling syntax highlighting in your modern IDE and see how hard that makes it - there's no good reason to go back.

     

    Again, I get that you're just following the "modern" trend, and I have tremendous appreciation for the incredible amount of work that goes into keeping the system updated with all the latest security patches and all the new features you're bringing to the table, but this is one trend I wouldn't mind missing out on. I'm sure that there will be a number of security patches in the 6.7 release, and I'd be remiss in skipping it just because of the UI design, but, based on what I've seen, I'd be tempted.

     

    And, yes, I really hate that my Android phone shows all my notification icons in white against a black background. When they allowed color there, I could tell at a glance if I had an orange text notification icon - now I have to analyze each one to see if it's the "new text message" shaped white square, among the sea of other white, essentially square, icons.

     

    </rant>

    • Like 1
    • Upvote 3

    Share this comment


    Link to comment
    Share on other sites
    24 minutes ago, FreeMan said:

    Having just looked at CA for the first time in a while (my server is running fine and I don't fiddle with it much), here's what I said to Squid about all the new CA icons:

     

     

    I took a look at SpaceInvaderOne's video review of 6.7rc1 and I'll repeat my thoughts. The icon shapes are nice, but they're nothing but a sea of white. Again, I get that this is the latest trend in design, but it is, in my opinion a terrible one. There is considerably more cognitive load in mentally parsing the shapes when there is no color to help out. This is especially tough on those of us whose eyesight isn't quite as good as it used to be.

     

    There is a reason why modern IDEs all do syntax highlighting. This is an absolute God-send in comparison to the dark ages of working on a monochrome green or amber monitor! Just try disabling syntax highlighting in your modern IDE and see how hard that makes it - there's no good reason to go back.

     

    Again, I get that you're just following the "modern" trend, and I have tremendous appreciation for the incredible amount of work that goes into keeping the system updated with all the latest security patches and all the new features you're bringing to the table, but this is one trend I wouldn't mind missing out on. I'm sure that there will be a number of security patches in the 6.7 release, and I'd be remiss in skipping it just because of the UI design, but, based on what I've seen, I'd be tempted.

     

    And, yes, I really hate that my Android phone shows all my notification icons in white against a black background. When they allowed color there, I could tell at a glance if I had an orange text notification icon - now I have to analyze each one to see if it's the "new text message" shaped white square, among the sea of other white, essentially square, icons.

     

    </rant>

    I don't post much but I have to agree its harder to discern what icon your looking at, example would be unbalance or speedtest it just draws you to it when navigating both by its color and shape/image

    • Like 2

    Share this comment


    Link to comment
    Share on other sites

    It is still up to the plugin author to decide what icon to use. The previous colored icons are still supported in Unraid 6.7

    Share this comment


    Link to comment
    Share on other sites
    9 minutes ago, bonienl said:

    It is still up to the plugin author to decide what icon to use. The previous colored icons are still supported in Unraid 6.7

    The Unraid UI itself is all monochrome icons now...

     

    There are far bigger issues in the world to worry about - I just wanted to voice my opinion. Thanks for listening.

    Edited by FreeMan

    Share this comment


    Link to comment
    Share on other sites

    If unraid is "finished" they might add themes to it?

    Share this comment


    Link to comment
    Share on other sites



    Guest
    This is now closed for further comments

  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.