Jump to content
  • Unraid OS version 6.7.0-rc8 available


    limetech

    Hopefully last release before 6.7.0 stable.

     

    Two notes:

    1. Added sdparm command in order to get SAS spin-up/down implemented properly.  If you have SAS controllers with SAS HDD's please send me PM if you are willing to help debug this.
    2. Removed kernel patch which was trying to work around problematic Silicon Motion SM2262/SM2263 NVMe controllers.  A different workaround is recommended.

     

    Version 6.7.0-rc8 2019-04-30

    Base distro:

    • at-spi2-core: version 2.32.1
    • bash: version 5.0.007
    • cifs-utils: version 6.9
    • dhcpcd: version 7.2.0
    • docker: version 18.09.5
    • glib2: version 2.60.1
    • glibc-zoneinfo: version 2019a
    • gtk+3: version 3.24.8
    • icu4c: version 64.2
    • kernel-firmware: version 20190424_4b6cf2b
    • libcap: version 2.27
    • libcroco: version 0.6.13
    • libdrm: version 2.4.98
    • libpng: version 1.6.37 (CVE-2018-14048 CVE-2018-14550 CVE-2019-7317)
    • libpsl: version 0.21.0
    • nano: version 4.2
    • ncurses: version 6.1_20190420
    • nghttp2: version 1.38.0
    • openssh: version 8.0p1
    • pcre2: version 10.33
    • pixman: version 0.38.4
    • samba: version 4.9.6
    • sdparm: version 1.10
    • sg3_utils: version 1.44
    • sqlite: version 3.28.0
    • util-linux: version 2.33.2
    • wget: version 1.20.3 (CVE-2019-5953)
    • zstd: version 1.4.0

    Linux kernel:

    • version: 4.19.37
    • remove patch: PCI: Quirk Silicon Motion SM2262/SM2263 NVMe controller reset: device 0x126f/0x2263

    Management:

    • docker: preserve container fixed IPv4 and IPv6 addresses across reboot/docker restart
    • emhttp: ignore *.key files that begin with "._"
    • networking: pass user-specified MAC address through to bridge
    • smartmontools: update drivedb and hwdata/{pci.ids,usb.ids,oui.txt,manuf.txt}
    • webgui: Allow optional notifications on background docker update checks
    • webgui: Dashboard: fixed hanging when no share exports are defined
    • webgui: Minor textual changes
    • webgui: Add GameServers to category for docker containers

     



    User Feedback

    Recommended Comments



    23 hours ago, limetech said:

    The code is not in place to fix this yet, just the packages required for a fix.  I only have limited SAS h/w to test with and so far things not working correctly but I think it might be an issue with the enclosure I'm using.

     I should still have my SAS drive. I will try to add it back to the array this weekend and PM you to help out with testing.

    Share this comment


    Link to comment
    Share on other sites

    I don't know if this is a bug, but seems like it.

    I had no docker containers showing after a fubar.

    Found instructions to delete the docker img and go to previous apps to reinstall. I did that. 16 total. 

    Issues is that there are no IP's assigned, at least in the list. I haven't opened them yet.

     

     

    image.thumb.png.fc590a44839942baf5937f9cafcc86b9.png

    Share this comment


    Link to comment
    Share on other sites

    Seems more the containers did not get an IP address.

    Start with posting diagnostics

    Share this comment


    Link to comment
    Share on other sites

    I was just about to post. I figured it out. I had a docker network setup and was saved in the templates, but, because I hadn't set up the network after all the changes, it didn't know what to do. Had to go into each one and re-save in order to initialize it. 

    Share this comment


    Link to comment
    Share on other sites

    I am having issues updating to this version as one of my raid controllers does not get recognized by this version and i lose half my drives, but as soon as i roll back everything is back to normal, does anyone have any ideas?

    Share this comment


    Link to comment
    Share on other sites
    Just now, ChuckB258 said:

    does anyone have any ideas?

    Please post the diagnostics after updating.

    Share this comment


    Link to comment
    Share on other sites
    8 hours ago, eschultz said:

    We'll include QEMU 4.x in Unraid 6.8

    along with multiple cache pools, right???!!!?!!? 🙏

    • Like 1

    Share this comment


    Link to comment
    Share on other sites

    Hi,

     

    I still have the same problem with this update that I have had with every 6.7.0RCx version, namely that once I reboot, multiple drives fail to mount/are disabled. On reversion to 6.6.7 all the drives are fine.

    I have tried:

    Install --> reboot

    Install --> Power down all VMs and containers --> Turn off Docker and VM manager --> Reboot

    Install --> Power down all VMs and containers --> Turn off Docker and VM manager --> Stop Array --> Reboot

    Regardless of the process I follow, loads of drives appear failed/corrupt/disabled after reboot and array started.

     

    reversion to 6.6.7 returns system to normal operations, except disks 2 and 5 which remain disabled.

     

    See attached diagnostics, taken after upgrade and reboot, followed by reversion

    .thenewdalebeast-diagnostics-20190501-0848.zip

     

    If I get some time this weekend, I will do another upgrade, and pull diags at every step.

     

    Edited by Duggie264

    Share this comment


    Link to comment
    Share on other sites
    14 minutes ago, Duggie264 said:

    Regardless of the process I follow, loads of drives appear failed/corrupt/disabled after reboot and array started.

     

    reversion to 6.6.7 returns system to normal operations.

     

    See attached diagnostics, taken after upgrade and reboot, before any other action.

    There are known issues with the HP240 kernel/driver in v6.7, it affects other (all?) users with that controller.

    Share this comment


    Link to comment
    Share on other sites

    Is it possible to enable the AMD APU iGPU Drivers in this build somehow? @eschultz

    Edited by billington.mark

    Share this comment


    Link to comment
    Share on other sites
    4 hours ago, johnnie.black said:

    There are known issues with the HP240 kernel/driver in v6.7, it affects other (all?) users with that controller.

    That is HP's "hpsa" driver:

    https://sourceforge.net/projects/cciss/files/hpsa-3.0-tarballs/

     

    The version in Linux kernel 4.19 is "3.4.20-125".  You can see from above link that there are newer hpsa versions, but those drivers are designed to be built/integrated into RedHat variation of the kernel and do not build with our kernel.

     

    Checking kernel 5.0 and 5.1, reveals they all also use hpsa driver "3.4.20-125".  Why hardware vendors insist to maintain their own driver vs. the stock kernel driver is a mystery.  Eventually someone who HP cares about will complain and they'll update the stock kernel driver.

    • Upvote 1

    Share this comment


    Link to comment
    Share on other sites
    4 hours ago, billington.mark said:

    Is it possible to enable the AMD APU iGPU Drivers in this build somehow? @eschultz

    Why?

    Share this comment


    Link to comment
    Share on other sites

    Mhh after update from 6.7.0-RC5 to 6.7.0-RC8 my unraid stuck at reboot.

     

     

    IMG_20190503_213223.jpg

    IMG_20190503_213021.jpg

    Share this comment


    Link to comment
    Share on other sites

    Those errors suggest a problem reading the USB stick.

    Share this comment


    Link to comment
    Share on other sites

    MH before I did the update, everything was still running. do I have to connect the stick to another pc now and save the config?

    And then reinstall unraid,  or is there another solution?

    Share this comment


    Link to comment
    Share on other sites
    2 minutes ago, Chrysen said:

    MH before I did the update, everything was still running. do I have to connect the stick to another pc now and save the config?

    And then reinstall unraid,  or is there another solution?

    I believe one option is power off the system and pull the usb.  plug it into your laptop and run a disk check. In windows you would go to my computer ( or this pc for windows 8 and up, i think), right click the usb drive and select properties, select tools tab and then select the check button under the error checking section.  

    Share this comment


    Link to comment
    Share on other sites

    thats it Unraid boot normally now.  But My Unraid Server is offline ( 6.7.0-RC8) , if i downgrade my unraid Server back to 6.7.0-RC5 all fine.

     

    And i had to reinstall my Plugins because i get many Errors and unassigned devices plugin stuck.

    Edited by Chrysen

    Share this comment


    Link to comment
    Share on other sites

    Smooth update from rc7, no issues to report.

    Share this comment


    Link to comment
    Share on other sites

    Same for me. Update went fine and server is running for 4 days now without any issues so far.

    Share this comment


    Link to comment
    Share on other sites
    On 5/3/2019 at 5:25 PM, limetech said:

    Why?

    So docker images can make use of iGPU transcoding.

    Share this comment


    Link to comment
    Share on other sites

    I deleted the /boot/config/network.cfg file and rebooted my Server, after reboot  i Setup my Network Connections new.  Old fail since 6.7.0-rc6

    Share this comment


    Link to comment
    Share on other sites

    I'm having issues with my VM since the update. I get an issue with a USB device so I removed all USB devices then when I saved those settings I get an error regarding an unknown vendor. Any ideas?

    Share this comment


    Link to comment
    Share on other sites
    11 hours ago, J89eu said:

    I'm having issues with my VM since the update. I get an issue with a USB device so I removed all USB devices then when I saved those settings I get an error regarding an unknown vendor. Any ideas?

    Post the diagnostics, the applicable VM XML file, and a screenshot of the error.

    Share this comment


    Link to comment
    Share on other sites



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.