• [6.10.0] Waiting for label UNRAID, UNRAID boot device not found


    dlaventu
    • Solved Annoyance

    Never had a problem after an update, but after upgrading to 6.10, the boot process stop waiting for a device label UNRAID for 30 sec and stop saying UNRAID boot device not found, I revert back to 6.9.2 and everyhting runs fine on the same USB 2 drive without format, no change, just replace boot files with the backup files... I'm using a USB2 Lexar JumpDrive FireFly 4GB. Every plugins are up to date before the upgrade.

     

     

    unraid-diagnostics-20220518-2132.zip




    User Feedback

    Recommended Comments

    Try re-creating the flash drive, backup current one, download v6.10.0 and unzip the files after formatting or use the USB tool, then restore the config folder from the backup.

    Link to comment

    Seems like quite a few people are getting this, I submitted a bug report previously here 

     

    Link to comment

    Back in Unraid 6.9.2, open a web terminal and run this:

    blkid

     

    Then post the line that contains LABEL="UNRAID". Mine looks like this:

    /dev/sda1: LABEL_FATBOOT="UNRAID" LABEL="UNRAID" UUID="---" BLOCK_SIZE="512" TYPE="vfat"

    (I changed the UUID, not sure if that is private)

    Link to comment
    2 hours ago, limetech said:

    @dlaventu - How did you create your current bootable USB flash?  Meaning what tool did you use?

     

    I don’t remember, that was years ago (November 2015), I used what was recommended in doc, it’s working since then and I never touched the flash drive from day one, it’s directly connected on an USB port on the motherboard inside the server case. I always upgraded from my Unraid server web page when a new stable version came up, I never used manual mode and never downloaded a new version by myself.

    • Thanks 1
    Link to comment
    1 hour ago, limetech said:

    6.10.1 released, please retest

     

    Everything works fine with 6.10.1 !!! Thanks :D

    Link to comment
    On 5/21/2022 at 3:14 AM, dlaventu said:

    I don’t remember, that was years ago (November 2015), I used what was recommended in doc, it’s working since then and I never touched the flash drive from day one,

     

    I think you win the prize for the longest continuously running USB flash device!

    • Haha 1
    Link to comment

    I updated to 6.10.2 the other day. Was able to boot fine, but after a power outage this morning, I am unable to boot. Have tested with my existing boot device and a new one which has been recently reformatted with the USB creator using a backup taken this morning.

    Link to comment

    Exactly how is it failing when you try to boot?  Are you sure the BIOS has the Unraid flash drive set as the boot device?

     

    it might be worth carrying out the procedure documented here to see if that helps.

    Link to comment

    So I worked a lot on this over the weekend and ended up reverting to 6.9.2. Any version of 6.10.x that I put on any number of different thumbdrives would initially boot to the UNRAID OS selection screen, but fail at the step while waiting for the volume "UNRAID" to come online.

     

    Is it possible the older hardware has some kind of issue that I need should know about? My system is based off a Supermicro X9SRi with a Xeon  E5-2630L and 24GB of DDR3 ECC.

     

    You can see in the images below that I am able to get past the intial BIOS boot, but boot will not complete. This happens on my original USB drive that I've been running for about 8 years, a new USB drive that I restore a backup to, or a USB drive with a fresh install of UNRAID 6.10.x to. Doesn't seem to matter. 

     

    poweron.jpg.fb84c5aae3bde71e1981eaa1a084b127.jpg

     

     

    newusb.jpg.96d65b95b0d6f351e2809e9735c4d855.jpg

     

    Link to comment

    Does renaming the EFI folder to EFI- (note the dash) or vice versa on the USB drive resolve this for you?

     

    One of my unRaid machines requires the "-" as part of it's version of BIOS. A few previous version upgrades ago, this was wiped out for EFI~ (note the tilde) and when my machine restarted I ran into your same issue. I was able to boot to the menu but loading unraid timed out. Popping the drive out and renaming that folder to add the dash resolved this for this machine. For others, renaming it to "EFI" or "EFI~" works. Just depends on your BIOS and your UEFI settings.

    Link to comment


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.