Jump to content
  • [6.12.2] SMB Share size not including ZFS formatted drives

    Thx And Bye
    • Solved Minor

    I've formatted two drives of my array with ZFS by now.  

    The web-ui is correctly showing the total size of the array. 

    When mounting the share via SMB on Windows it doesn't include the zfs drives in the size.

    The 2TB of a btrfs formatted cache is added correctly to the size of the share.

    It's not a major issue but it could cause Windows to not accept a transfer due to insufficient space.




    User Feedback

    Recommended Comments

    Can confirm this issue, no problem if all drives are zfs formatted, see the same as you if there's one or more zfs drives in the first slots, and it gives a completely wrong value if they are used as the last drives.

    Link to comment

    I've completed the transfer to all zfs drives now and only have zfs drives in my array. 

    Now the reported space in Windows makes absolutely no sense at all anymore. 


    Installed capacity is 2x16TB and 2x4TB and Windows reports 104TB total space.


    (currently verifying parity after the removal of the two remaining xfs drives)


    Edited by Thx And Bye
    Link to comment
    16 hours ago, Thx And Bye said:

    Now the reported space in Windows makes absolutely no sense at all anymore. 

    Interesting, when I tested, with an all zfs array it showed the correct space, but I was using all same size devices, it's likely part of the same bug, so when one is fixed all should be.

    Link to comment

    Just tested, it will happen if the share also exisits in a non zfs pool, so I'm guessing that share also exists on your btrfs downloads pool, so it's still the same bug.

    Link to comment
    5 hours ago, JorgeB said:

    that share also exists on your btrfs downloads pool, so it's still the same bug.


    Yes that is correct. I'll keep that pool btrfs then and will report back when this is fixed in a stable release.

    • Thanks 1
    Link to comment

    Retested with 6.12.3 with a full zfs share and btrfs cache pool.

    Changed Status to Solved

    Edited by Thx And Bye
    • Like 1
    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...