Jump to content
  • [6.12.4] - Mellanox ConnectX-3 showing as down.

    • Annoyance

    Posted as a separate incident with diagnostics from main release thread.


    Upgrade from 6.12.3 to 6.12.4 appeared to go OK, but I have a network card issue.

    I have a 10gb fibre card, and onboard 1gb nic. These are set to a bond and it mainly uses the 10gb (onboard is enabled for WOL - a script after waking forces the 10gb card to be active).


    My fibre card is constantly showing as disconnected (Interface Ethernet Port 1 is down. Check cable!) . Changing designations between eth0 and eth1 makes no difference.

    It is listed in system devices as

    [15b3:1003] 02:00.0 Ethernet controller: Mellanox Technologies MT27500 Family [ConnectX-3]


    The new system drivers shows two drivers:

    mlx4_core    Mellanox ConnectX HCA low-level driver    Inuse    net/ethernet/mellanox/mlx4
    mlx4_en    Mellanox ConnectX HCA Ethernet driver    Inuse    net/ethernet/mellanox/mlx4

    I have the Mellanox Firmware Tools installed -  which seems to report the card OK.


    Anyone else with this issue?


    User Feedback

    Recommended Comments

    I also have a Mellanox X3 and it runs under 6.12.4 without any problems (update from 6.12.1).







    I hope you find the cause. it works for me ...


    Edited by andber
    • Like 1
    Link to comment

    No issues for me as well, updated two servers with ConnectX-3 so far, might also be a good idea to reboot the switch, if one is in use, I sometimes need to do that after a reboot to get the link back, if not try to roll back to 6.12.3 and confirm it still works.

    • Like 1
    Link to comment

    Rolled back and it was still not working, but I didn't do a restore

    Tried swapping "cable" but it didn't make a difference.

    Could be something failing at a bad time, so have taken the card out and will try it in another machine soon.

    Not keen on rebooting the switch as it's POE and have quite a few devices hanging off it. I haven't tried swapping ports on the switch.

    Seems like it might not be a 6.12.4 issue specifically.


    Thanks for suggestions and support @JorgeB & @andber

    • Like 1
    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...