Jump to content
  • [6.6.6] No VM compatible hardware allows to create VMs


    hawihoney
    • Minor

    When in a VM that's started without VM-compatible hardware, the UI shows two small inconsistences. Please have a look at the images.

     

    - Clicking on VM Manager brings up the information that I can't create KVM VMs (VM2.png). It's not possible to configure VM Manager. That's ok, I think.

     

    - The tab VMS is still shown (VM1.png) even on that hardware. Does that mean I can't create a VM but I can run a VM? Is this ok?

     

    - When entering the VMS tab, I'm allowed to create a VM, regardless of what the VM Manager reports (VM3. png).

     

    To sum it up: I can't configure the VM Manager, but I can create VMs and run them (at least I can try). IMHO, the VMS tab has to be removed in that case.

     

    VM1.png

    VM2.png

    VM3.png




    User Feedback

    Recommended Comments

    Hm, I doubt you did get the point.

     

    I don't have virtualization support in a machine and part of the unRAID thinks I have.

     

    The part that's correct is the VM Manager.

     

    The part that's wrong IMHO is the VMS tab and the VMS page.

     

    Link to comment

    Ah ok. Now i get your point. Maybe a good idea to post your diagnostics for the devs to have a deeper look into it. I never tried to use Unraid on a platform that hasn't virtualisation support neither do i have some hardware laying around to test with. I guess that virtualisation without HW support would work but extremly slow. I don't really know how it's implemented, but on a standard Linux distro if there is no support KVM modules aren't used and in this case only Qemu is used for virtualisating an guest OS. It's basically a software virtualisation in this case similar to Virtualbox but way slower.

    Link to comment

    I was not aware that they even made 64-bit capable systems without some sort of hardware virtualisation!  I would have thought that on UnRAID if the user does not have hardware that can support any sort of virtualisation at the hardware level one probably does no want to even attempt it as it would be such an outlier case.  

     

    That is very different to the current behavior of supporting virtualisation as long as there is basic support at the motherboard/CPU level.  There is also support for the increasingly common case of the next level which adds hardware passthrough capabilities

     

     

    Link to comment

    As I wrote in my first post it's what you see in a unRAID VM running on unRAID. It's nothing important, just a small GUI correction.

     

    Link to comment


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.

×
×
  • Create New...