• 6.7.0/6.8.0 NFS Kodi share discovery broken

    • Solved Minor

    Not sure if this is a bug or what but here goes.


    NFS shares not being seen by Librelec-Kodi. In the 6.6.7 version I could browse and find nfs shares.  After the update to 6.7 I cannot.  I downgraded to 6.6.7 and was again able to browse for nfs shares. Re-Upgraded and was then again not able.


    I manually added the export into kodi and it works, just cannot browse for it.


    • Like 1

    User Feedback

    Recommended Comments

    I see the same issue with SMB and NFS. Kodi on Android TV on 6.7

    Edited by Dazog
    Link to comment

    I had the same issue as well.  LibreElec 9.02. Also had to downgrade.


    Wondering if it has anything to due with this change.


    smb: disable samba auto-register with avahi for now

    Edited by Kujo
    Link to comment

    Just found this thread and I can still confirm that this is an issue. I first thought it was a libnfs issue as my Ubuntu NFS shares are being seen, hence I reported it here:



    But as we found out over there and by seeing this thread here, I guess we can be pretty sure (probably not 100%) that this is an Unraid issue.

    As a TeamKodi and LibreELEC member by myself and therefor knowing how many users are using UnRaid, I see a lot of them complaining, that they are not able to browse their NFS shares anymore. Those shares still can be added inside Kodi (in a much more complicated way) or mounted by the OS via system mounts, but simply adding sources in Kodi by browsing the shares was a very welcome feature which is obviously gone.


    If that was done on purpose and if there's a reason to do so, then please explain. I'm all ears and open for any kind of conversation....


    If you need anything else from my side, logs or whatever (beside the wireshark traces or the command outputs at the linked GH issue), then please ping me either here or at #Kodi IRC on Freenode by using "@Davu".


    Thanks in advance.

    • Upvote 1
    Link to comment

    If anyone is having issues with this with Windows 10, I was able to find a solution. I basically just created a user in Unraid and when I tried to connect to my unraid tower from my Windows computer, I put in my username and password for the user I just created in Unraid and selected "Remember my credentials" and it worked. It connects to my mapped network drives even after a reboot now. I'm not sure why all of a sudden this was necessary, I've never done that before until now. Hopefully this helps anyone else out using SMB on Windows 10.

    Link to comment

    Found this thread through this Kodi forum post -



    NFS network browsing is broken on some servers, certainly FreeNAS and Unraid servers.

    It's a FreeNAS/Unraid issue. Most other NFS servers can be browsed without a problem. The FreeNAS and Unraid servers may just need rpcbind to be compiled with the option --enable-rmtcalls.

    If your NFS server cannot be browsed by Kodi then report the issue to your NFS server software maintainer(s) so that they can hopefully fix it.

    Any thoughts as this is still a problem?

    Link to comment

    Just tried 6.8 and it still is not working on Kodi.  

    I also tried to disable config setting on Settings/Global Share Settings called "Tunable (support hard links)".  The default is Yes, but with certain very old media and DVD players which access shares via NFS, you may need to set this to No.

    Link to comment

    I'm also seeing kodi unable to browse nfs shares. I had no issues in 6.7.X - but after I upgraded to 6.8 I fiddled with the samba/global share sections and it stopped being browsable.  No fiddling has been able to restore it.


    Edited by rilles
    Link to comment

    Just an FYI guys, I think we have this sorted thanks to @limetech!  We were able to recreate the issue and in an internal build today, we think we may have it squashed.  Stay tuned...

    • Like 2
    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.