Jump to content
  • [6.7.2] config/vfio-pci.cfg has no effect


    dgaschk
    • Minor
    2019-09-21T23:33:56.395403Z qemu-system-x86_64: vfio_region_write(0000:65:00.0:region1+0xd71e0, 0x0,8) failed: Device or resource busy

    I created a vfio-pci.cfg but the binding to a Windows 10 VM on Supermicro X11SPM-F with GeForce RTX 2080 SUPER doesn't seem to work. I get the same result as not having a vfio-pci.cfg file when I attempt to start the VM:

     

    VM log:

    ErrorWarningSystemArrayLogin -boot strict=on \ -device pcie-root-port,port=0x10,chassis=1,id=pci.1,bus=pcie.0,multifunction=on,addr=0x2 \ -device pcie-root-port,port=0x11,chassis=2,id=pci.2,bus=pcie.0,addr=0x2.0x1 \ -device pcie-root-port,port=0x12,chassis=3,id=pci.3,bus=pcie.0,addr=0x2.0x2 \ -device pcie-root-port,port=0x13,chassis=4,id=pci.4,bus=pcie.0,addr=0x2.0x3 \ -device pcie-root-port,port=0x14,chassis=5,id=pci.5,bus=pcie.0,addr=0x2.0x4 \ -device pcie-root-port,port=0x8,chassis=6,id=pci.6,bus=pcie.0,multifunction=on,addr=0x1 \ -device pcie-pci-bridge,id=pci.7,bus=pci.1,addr=0x0 \ -device pcie-root-port,port=0x9,chassis=8,id=pci.8,bus=pcie.0,addr=0x1.0x1 \ -device pcie-root-port,port=0xa,chassis=9,id=pci.9,bus=pcie.0,addr=0x1.0x2 \ -device qemu-xhci,p2=15,p3=15,id=usb,bus=pcie.0,addr=0x7 \ -device virtio-serial-pci,id=virtio-serial0,bus=pci.2,addr=0x0 \ -drive 'file=/mnt/disks/Scorch/VM/Windows 10/vdisk1.img,format=raw,if=none,id=drive-virtio-disk2,cache=writeback' \ -device virtio-blk-pci,scsi=off,bus=pci.4,addr=0x0,drive=drive-virtio-disk2,id=virtio-disk2,bootindex=1,write-cache=on \ -drive file=/mnt/user/backup/Win10_1903_V1_English_x64.iso,format=raw,if=none,id=drive-sata0-0-0,readonly=on \ -device ide-cd,bus=ide.0,drive=drive-sata0-0-0,id=sata0-0-0,bootindex=2 \ -drive file=/mnt/user/backup/virtio-win-0.1.160-1.iso,format=raw,if=none,id=drive-sata0-0-1,readonly=on \ -device ide-cd,bus=ide.1,drive=drive-sata0-0-1,id=sata0-0-1 \ -netdev tap,fd=29,id=hostnet0,vhost=on,vhostfd=30 \ -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:da:47:b1,bus=pci.3,addr=0x0 \ -chardev pty,id=charserial0 \ -device isa-serial,chardev=charserial0,id=serial0 \ -chardev socket,id=charchannel0,fd=31,server,nowait \ -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=org.qemu.guest_agent.0 \ -device usb-tablet,id=input0,bus=usb.0,port=3 \ -vnc 0.0.0.0:0,websocket=5700 \ -k en-us \ -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vram64_size_mb=0,vgamem_mb=16,max_outputs=1,bus=pci.7,addr=0x1 \ -device vfio-pci,host=65:00.0,id=hostdev0,bus=pci.5,addr=0x0 \ -device vfio-pci,host=65:00.1,id=hostdev1,bus=pci.6,addr=0x0 \ -device usb-host,hostbus=1,hostaddr=5,id=hostdev2,bus=usb.0,port=1 \ -device usb-host,hostbus=1,hostaddr=7,id=hostdev3,bus=usb.0,port=2 \ -sandbox on,obsolete=deny,elevateprivileges=deny,spawn=deny,resourcecontrol=deny \ -msg timestamp=on 2019-09-21 05:40:54.258+0000: Domain id=1 is tainted: high-privileges 2019-09-21 05:40:54.258+0000: Domain id=1 is tainted: host-cpu char device redirected to /dev/pts/0 (label charserial0) 2019-09-21T05:40:54.449416Z qemu-system-x86_64: -device vfio-pci,host=65:00.0,id=hostdev0,bus=pci.5,addr=0x0: vfio 0000:65:00.0: group 28 is not viable Please ensure all devices within the iommu_group are bound to their vfio bus driver. 2019-09-21 05:40:54.488+0000: shutting down, reason=failed

    I am able to BIND and start the VM if I edit the Syslinux configuration with "{append initrd=/bzroot} vfio-pci.ids=10de:1e81,10de:10f8,10de:1ad8,10de:1ad9" and this noted here:

     

    In safe mode the VM tab reports "Libvirt Service failed to start." Please see second diagnostics.

     

    Rebooting to normal after safe-mode seems to have fixed some things.  The BIND is now working with a stock Syslinux configuration so vfio-pci.cfg appears to be working. (Or are there effects remaining form the previous mods?)

     

    Starting the VM resulted in this line filling the syslog: 

    2019-09-21T23:33:56.395403Z qemu-system-x86_64: vfio_region_write(0000:65:00.0:region1+0xd71e0, 0x0,8) failed: Device or resource busy

    Adding these lines to my go file allows the VM to operate acceptably:

    #fix video for VM
    echo 0 > /sys/class/vtconsole/vtcon0/bind
    echo 0 > /sys/class/vtconsole/vtcon1/bind
    echo efi-framebuffer.0 > /sys/bus/platform/drivers/efi-framebuffer/unbind

    Please see latest diagnostics attached.

     

    rack-diagnostics-20190921-0547.zip vfio-pci.cfg

    rack-diagnostics-20190921-2315.zip

    rack-diagnostics-20190921-2356.zip

    Edited by dgaschk
    safe mode test added



    User Feedback

    Recommended Comments

    There are no comments to display.



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.