• [6.8.0] <wsdd high cpu>


    diyjeff
    • Minor

    Just noticed that on the Dashboard one cpu at a time goes to 100%.  Running top shows wsdd taking 100% (I am assuming that means 100% on one processor).  It jumps around to both regular and HT processors, all of which are not pinned to a VM.  It does not seem to be impacting any function or performance; I have not seen this before upgrading to 6.8.0.  I do not see any issues in the system log.

    • Thanks 3



    User Feedback

    Recommended Comments



    I noticed the same thing a few times during the rc cycle; wsdd pegging one CPU/HT at 100% and bouncing around among them. 

     

    It has been a while since I saw this and it seemed to happen most frequently when I was running PC backups to the unRAID server.  It was not repeatable every time I ran a backup (or under other circumstances I could document), so, I never entered a bug report. 

     

    Every once in a while wsdd just decides it needs the undivided attention of one of the CPUs/HTs.  I am not sure if that is anything @limetech can resolve.

     

     

     

    Link to comment

    Can you try to add

    -i br0

    to the WSD options (see SMB settings). This restricts WSD to operate on the main interface (br0) only.

    • Thanks 2
    Link to comment

    same here noticed wsdd taking 1 thread 100% cpu.. for over 4 hours straight, never saw this in RC5 when i saw on that for a week or so.

     

    ended up turning of discovery completely.

    Link to comment

    bonienl,

      I tried the "-i br0" and so far the cpu pegging has stopped.  I don't know how long it took for the issue to originally appear, but so far so good.  Will update tomorrow if it changes.  After that it will be weeks before I will be able to check again.

     

    Next morning: Still no high cpu usge.

    Edited by diyjeff
    Update
    Link to comment

    Finally stumbled across this bug report (previous web searches didn't include this thread). It happened to me, only have a desktop Win10 system running "Media Center Master" that scans media for new metadata. I just set the WSD Options to be "-i br0".

     

    I will report back if I run across the issue again.

    Link to comment
    On 12/12/2019 at 11:58 PM, bonienl said:

    Can you try to add

    
    -i br0

    to the WSD options (see SMB settings). This restricts WSD to operate on the main interface (br0) only.

    I just saw this suggestion and entered it into WSD options. I have not seen the problem since I reported it last Thursday. I will report if it occurs again with the option set.

    Link to comment
    On 12/17/2019 at 12:04 AM, Hoopster said:

    I just saw this suggestion and entered it into WSD options. I have not seen the problem since I reported it last Thursday. I will report if it occurs again with the option set.

    How do you set WSD options?  Also having the same issue with 100% CPU due to WSD.

    Link to comment
    46 minutes ago, RAINMAN said:

    How do you set WSD options?  Also having the same issue with 100% CPU due to WSD.

     

    Settings > SMB > WSD Options.

     

    image.png.cd912f116c568f6255d2e958638b420c.png

    • Thanks 2
    Link to comment

    Just wanted to report back that wsdd is hitting 100% CPU even with the "-i br0" options set. So that is not a fix, its just a band-aid.

     

    image.png.9e146f37e3b076c1a8b1690eeacbd505.png

    Link to comment
    24 minutes ago, BRiT said:

    Just wanted to report back that wsdd is hitting 100% CPU even with the "-i br0" options set. So that is not a fix, its just a band-aid.

    Two questions:

    1. Do have a bridging enabled for eth0? (otherwise br0 doesn't exist and reference need to be adjusted)

    2. Your CPU 27 is fully loaded. Any specifc CPU pinning done? (I would expect Unraid to use the lower CPUs)

    Link to comment
    6 minutes ago, bonienl said:

    Two questions:

    1. Do have a bridging enabled for eth0? (otherwise br0 doesn't exist and reference need to be adjusted)

    2. Your CPU 27 is fully loaded. Any specifc CPU pinning done? (I would expect Unraid to use the lower CPUs)

     

    1. Yes, bridging enabled with br0.

     

    2. Nothing pinned at all. No VM running. Only Dockers and no pinning defined. That core 27 was entirely 100% WSDD. As soon as I stopped and Disabled WSDD in SMB Settings, usage went to 0%. The CPU time was 116 hours (4.83 days), which puts it around December 21st when it went bezerk.

     

    The only items in the log that stand out are very typical to my system (happening for months if not years):

    A. nut_libusb get_string errors

    B. ffdetect from emby docker not liking certain media and it segfaulting.

     

    Here's entire diagnostics, but I had not seen any triggering events in syslog.

     

    reaver-diagnostics-20191226-1500.zip

     

     

    Link to comment

    Just noticed i have same issue

     

    Trying -i br0 now see how i go, wondered why i had so much cpu usage with nothing much happening

     

    Edit: still pegging one core...

    Edited by macmanluke
    Link to comment
    On 12/16/2019 at 10:04 PM, Hoopster said:

    I just saw this suggestion and entered it into WSD options. I have not seen the problem since I reported it last Thursday. I will report if it occurs again with the option set.

    Just saw it again for the first time since I set the -i br0 WSD option in SMB settings.  It's been about four weeks.

     

    image.thumb.png.017bf17a2048da878bad6a7049bbc267.png

    • Thanks 1
    Link to comment

    I have not tried enabling it in 6.8.1 since none of the release line-items looks like anything changed related to this.

    Link to comment

    I have this same thing going. I went to setting smb and put no for wsd.  That seemed to stop the core from being 100%. What does was do?

    Link to comment
    5 hours ago, Aage said:

    I have this same thing going. I went to setting smb and put no for wsd.  That seemed to stop the core from being 100%. What does was do?

    WS Discovery provides for the discovery of network devices (such as the unRAID server) by name without requiring SMB v1.0.  SMB v1.0 has some security issues and Microsoft has been trying to kill it for a while.  Windows updates would disable it and it would have to be re-enabled manually (and often in different ways) in order for the unRAID server to appear in Windows networks.

     

    Discovery by IP address has always worked, but discovery by name prior to 6.8.0 required SMB v1.0 to be enabled.

     

    WSD is a replacement discovery mechanism that does not rely on SMB v1.0.  It uses SMB v2 or higher.

    Link to comment

    Anyone know if there has been any actual fixes or changes to the WSDD codebase (SAMBA) to address this issue? Or has it remained rather raw?

    Link to comment

    Just adding that I am seeing this too.  Server doesn't crash, but dockers become very sluggish, some are dead in the water.  VMs somehow are not impacted, I guess due to CPU pinning? But these spikes seem to hit all CPUs one at a time, like OP says.

     

    EDIT: Upgraded to 6.8.2 last night, will keep an eye on it and report back

    Edited by btrcp2000
    Link to comment

    Just an update since originally posting and adding "-i br0" in mid December I still have not observed the problem again.  Just to add I have 5 ethernet controllers in use in my server.  Two are dedicated and passed through to one VM, 2 more are passed through to a second VM and the third VM uses br0 and the server uses eth0.  A sixth controller is currently not used.

    Edited by diyjeff
    Update of original post
    Link to comment
    On 2/12/2020 at 12:02 AM, ptr727 said:

    Still happens on my 6.8.2, had to disable WSD.

    Can confirm this is still happening for me as well after updating to 6.8.2.

    Link to comment

    Also want to report this issue, tried the "-i br0" parameter, and it does work, hopefully it will work until this gets fixed.

     

    This 100% on 1 core issue affects me a lot cause I am running a low power cpu with barely 4 cores, and every %cpu power counts. 

    Running ver. 6.8.2, had to disable docker cause apparently this issue affects them too.

     

    Thanks for posting the temporal fix. 

    Link to comment

    Also having this issue.

     

    Have noticed it twice. Added the the "-i br0" parameter now, hopefully a perm fix is on the way 

    Link to comment



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.