• [6.9.0] HDD's no spin down after update


    xruchai
    • Solved Minor

    After updating to 6.9 Final the HDD's (sata) no longer go into standby (after 30 min), no spin down.

     

    I also set the delay to 15 minutes but the HDD's just don't go into standby.

    I have not changed any system settings before, only when I tried to solve the problem (uninstalled plugins etc.).

     

    Before the update, on 6.8.3, the spin down worked fine.

     

    I hope that you can help.

     

    • Like 2


    User Feedback

    Recommended Comments



    On 3/3/2021 at 2:17 AM, Carpe_Diem said:

    In Dashboard, all three disk show constant read activity of exactly 341B/s or 682B/s (same in all drives at same time), but this is a "fake" read, because dashboard still shows that read activity with drives manually spinned down, which is of course, impossible.

     

    Executing any kind of SMART operation increments both number I/O's to the device (in this case Reads) and number sectors transferred (in this case sectors read).  This is true whether device is in standby or not.  HOWEVER, I have a fix for this coming in 6.9.1

     

     

     

    • Like 3
    • Thanks 1
    Link to comment
    Share on other sites
    h0schi

    Posted (edited)

    Same here ...

    No Auto Fan installed.

    Manual Spindown is working, but the HDDs spinup after a few minutes.

    The auto spindown only work on one HDD (that HDD is actual empty)

     

    I activate some features with the kernel helper.

    Can that be reason for the missing spindown ?

    Edited by h0schi
    Link to comment
    Share on other sites

    I had this issue with telegraf and Auto Fan.

    Resolved by removing auto fan and disabling smart readings in telegraf conf file.

     

    Don't think anything in unraid natively does this that can prevent spindown, must be an app or the features that can hopefully be disabled to get through until 6.9.1?

    Link to comment
    Share on other sites

    I also noticed this issue since 6.9.0. Manual spin down is working fine. Dynamix Fan control is not installed but ipmi support with fan control activated and also a telegraf container with hddtemp and smart. 

     

    Edit: It's definitely telegraf that I causing this issue. When the container is stopped, all disks spin down after the set delay.

    Edited by kennymc.c
    Link to comment
    Share on other sites
    14 hours ago, limetech said:

    Executing any kind of SMART operation increments both number I/O's to the device (in this case Reads) and number sectors transferred (in this case sectors read).  This is true whether device is in standby or not.  HOWEVER, I have a fix for this coming in 6.9.1

     

    I might have a simple fix, unless I'm missing something.

     

    sdg is Disk2 of my array.

     

    Here are diskstats for sdg and its only partition sdg1:

    root@NAS:~# grep sdg /proc/diskstats
       8      96 sdg 980673 22075722 182230404 6487392 284407 19425162 157662544 2604401 0 6664111 9193913 0 0 0 0 1749 102119
       8      97 sdg1 681558 22075722 182067420 1286206 282656 19425162 157662544 2491636 0 1400537 3777843 0 0 0 0 0 0

     

    And here are diskstats after a smart call:

    root@NAS:~# grep sdg /proc/diskstats
       8      96 sdg 980680 22075722 182230408 6487516 284407 19425162 157662544 2604401 0 6664239 9194037 0 0 0 0 1749 102119
       8      97 sdg1 681558 22075722 182067420 1286206 282656 19425162 157662544 2491636 0 1400537 3777843 0 0 0 0 0 0

     

    You can see several fields have increased on sdg but none on sdg1

     

    Now I open a file on Disk2:

    root@NAS:~# grep sdg /proc/diskstats
       8      96 sdg 980734 22077348 182243848 6487581 284407 19425162 157662544 2604401 0 6664306 9194102 0 0 0 0 1749 102119
       8      97 sdg1 681612 22077348 182080860 1286271 282656 19425162 157662544 2491636 0 1400604 3777908 0 0 0 0 0 0

     

    Which shows up as reads on the partition sdg1.

     

    Could the fix be a simple as monitoring partitions for activity rather than devices?

     

    I've been using this method to monitor and spin down an attached USB drive and my 2nd pool (3 spinners in BTRFS RAID5) for a few months now with no apparent problems. 

    • Like 2
    Link to comment
    Share on other sites

    For telegraf it is enough to disable hddtemp. The smart plugin does not seem to cause it. Maybe it works a little differently?

    Link to comment
    Share on other sites
    4 hours ago, CS01-HS said:

    Could the fix be a simple as monitoring partitions for activity rather than devices?

    Yes that's the fix

    • Like 2
    Link to comment
    Share on other sites
    h0schi

    Posted (edited)

    7 minutes ago, limetech said:

    Yes that's the fix

     

    Do you have any idea regarding my situation, @limetech

    I do not use telegraf and autofan.

    Edited by h0schi
    Link to comment
    Share on other sites
    24 minutes ago, h0schi said:

     

    Do you have any idea regarding my situation, @limetech

    I do not use telegraf and autofan.

    Do you have any plugins running smartctl or something similar that may cause IO on the disk?

     

     

    Link to comment
    Share on other sites

    No, i check every docker and VM.

    I installed a VM with Home Assistant, but the VM is on the cache-pool.

    I checked with Dynamix Active Stream if any connection is established via SMB, but there is no one.

     

    I activate some features with the Kernel Helper but i do not think that is the reason.

     

     

    Link to comment
    Share on other sites
    h0schi

    Posted (edited)

    Thanks for your help, @SimonF

     

    i activate following features with the Kernel Helper:

    - Build with DVB support

    - Build USBip-HOST

    - RMRR Relax Patch

    - Enable Intel i915 and 'intel_gpu_top'

    - Build GVT-g Support

     

     

    diagnostics-20210307-2003.zip

    Edited by h0schi
    Link to comment
    Share on other sites

    @h0schi Have you tried setting dorons SAS help smartctl wrapper to debug. This may give you an idea if anything is calling smartctl. 

     

    Diags are straight after a reboot, can you provide logs for the point where the drives should spin down, Looks like you have spin down after 2 hrs, and poll is set to 30mins.

     

    I think Unraid takes note of the polls not to affect the spin down, but try changing spin down to be less that poll time. Mine are set to 15mins and 30mins for poll.

     

    Not found anything else so far.

     

    Link to comment
    Share on other sites

    Can you tell me how i can change time of poll ?

    I change the spindown now to 15 minutes for testing, but i think 15 minutes for spindown is a bit low, hm ?

    Link to comment
    Share on other sites

     

     

    Tunable(poll) its in seconds default is 1800 30mins.

     

    image.thumb.png.1859b7112dde56178b3b7ee0280219bc.png

    Link to comment
    Share on other sites

    Thx !

    Thats strange, but why is affecting the spindown ?

    With 6.8.3 it‘s working without any problems.

     

    I will test the function with the 15min spindown-time.

    I hope that the disks will be spinup and spindown so often.

    Link to comment
    Share on other sites
    17 minutes ago, h0schi said:

    Thx !

    Thats strange, but why is affecting the spindown ?

    With 6.8.3 it‘s working without any problems.

     

    I will test the function with the 15min spindown-time.

    I hope that the disks will be spinup and spindown so often.

     

    I suggest you just hold off until 6.9.1 is published.  Will probably solve the problems you are seeing.

    • Like 1
    Link to comment
    Share on other sites
    h0schi

    Posted (edited)

    Yes,

    i think that will be the best way.

    For now i will set up the spindown timer to 15 minutes.

    I check at the moment the spinups and it seems to be ok.

     

    Thanks for your advices, @limetech & @SimonF

    Edited by h0schi
    Link to comment
    Share on other sites

    If its working you just need to make poll longer than spin down until 6.9.1 i.e. Spin down 2hrs poll 7300

    • Like 1
    Link to comment
    Share on other sites
    17 hours ago, kennymc.c said:

    For telegraf it is enough to disable hddtemp. The smart plugin does not seem to cause it. Maybe it works a little differently?

    I didn't have hddtemp enabled in telegraf.
    I only monitored through telegraf's smart plugin and disabling it did the trick. My disks are spinning down automatically again.

    Link to comment
    Share on other sites

    Short feedback, @SimonF and @limetech

    I increase the poll tunable to 3700 seconds and the spindown-timer to 1 hour.

    Additonal i check my content, the associated disks and move some files via unBalance-App.

     

    Seems to be fine for now :)

    Link to comment
    Share on other sites
    11 hours ago, ethronrion said:

    I didn't have hddtemp enabled in telegraf.
    I only monitored through telegraf's smart plugin and disabling it did the trick. My disks are spinning down automatically again.

    My mistake. I set the smart plugin to only monitor my nvme cache ssd so obviously this doesn't affect my other disks.

    Link to comment
    Share on other sites

    I have been trying to figure out this issue as well. No Auto Fan, but I do have the "IPMI Support" plugin and telegraf. I do NOT have [inputs.hddtemp] enabled, but DO have [inputs.smart] and [inputs.ipmi_sensor] enabled, so most likely my cause is related. Any ETA for a hotfix/6.9.1? Thanks!

    Edited by hoodust
    Link to comment
    Share on other sites
    On 3/5/2021 at 6:28 AM, Emil Hansen said:

    Same issue here, no problem in 6.8.3. I have only tried 6.9.0rc2 and 6.9.0 and the problem were there in both. I disabled autofan and telegraf and the problem disappeared. However, because of my hardware setup I am kinda dependent on the autofan plugin to spin up the fans when the HDDs gets warm.  

     

    I'm still running 6.9-Beta35 and I don't have any drive spin down issues and I'm still running Autofan. ;)

     

    I did try a few past, but I really need my Fans too. 

    Link to comment
    Share on other sites

    Thx for the fast Update (6.9.1)!

     

    My HDD´s spin down as they should, now (with enabled AutoFan). :D

    • Like 2
    Link to comment
    Share on other sites



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.