• [6.9.0] HDD's no spin down after update


    xruchai
    • Solved Minor

    After updating to 6.9 Final the HDD's (sata) no longer go into standby (after 30 min), no spin down.

     

    I also set the delay to 15 minutes but the HDD's just don't go into standby.

    I have not changed any system settings before, only when I tried to solve the problem (uninstalled plugins etc.).

     

    Before the update, on 6.8.3, the spin down worked fine.

     

    I hope that you can help.

     

    • Like 2


    User Feedback

    Recommended Comments



    My HDDs also spin down properly (with autofan and telegraf running.)

     

    Not only that but my non-cache pool drives which never spun down own their own do now. Perfect.

    Link to comment
    Share on other sites

    I was not able to resolve this until I uninstalled and stopped all the following:

    1. Dynamix fan plugin
    2. Telagraf
    3. Varkin
    4. InfluxDB
    5. HDDTemp
    Link to comment
    Share on other sites

    I have the same problem.

     

    Installed plugins

    1. Fix Common Problems

    2.CA Backup / Restore Appdata

    3. CA Config Editor

    4. Community Applications

    5. Dynamix Active Streams

    6. Dynamix Cache Directories

    7. Dynamix S3 Sleep

    8. Dynamix SSD TRIM

    9. Dynamix System Information

    10. Dynamix System Statistics

    11. Dynamix System Temperature

    12. Nerd Tools

    13. Preclear Disks

    14. Statistics

    15. Unassigned Devices

    16. Unassigned Devices Plus

    17. unBALANCE

    18. User Scripts

     

    This i see in the System Log:

    emhttpd: spinning up /dev/sde
    Mar 22 19:19:39 unRAID emhttpd: read SMART /dev/sde
    Mar 22 19:19:45 unRAID emhttpd: spinning up /dev/sdd
    Mar 22 19:19:45 unRAID emhttpd: read SMART /dev/sdd
    Mar 22 19:19:57 unRAID emhttpd: spinning up /dev/sdg
    Mar 22 19:19:58 unRAID emhttpd: read SMART /dev/sdg
    Mar 22 19:20:07 unRAID emhttpd: spinning up /dev/sdf
    Mar 22 19:20:08 unRAID emhttpd: read SMART /dev/sdf
    Mar 22 19:20:15 unRAID emhttpd: spinning up /dev/sdb

     

    After that happened, the disks don`t spin down anymore 😞

    Link to comment
    Share on other sites

    Do you have Version 6.9.1 installed?

    Edited by Redskyer
    Link to comment
    Share on other sites

    Hi, 

     

    I also got the same problem and its annoying me now. 

    I have updated to 6.9.1 but still no succes, when i manually spin my disk down.

    After a while they will be spun up again and i see the following in the logs:

     

    Apr 2 19:49:45 Tower emhttpd: read SMART /dev/sdd
    Apr 2 19:52:09 Tower emhttpd: read SMART /dev/sde
    Apr 2 19:52:47 Tower emhttpd: read SMART /dev/sdh
    Apr 2 19:52:47 Tower emhttpd: read SMART /dev/sdg
    Apr 2 19:52:47 Tower emhttpd: read SMART /dev/sdb
    Apr 2 19:52:47 Tower emhttpd: read SMART /dev/sdf
    Apr 2 19:52:47 Tower emhttpd: read SMART /dev/sdc
    Apr 2 19:52:48 Tower emhttpd: read SMART /dev/sdl
    Apr 2 19:52:58 Tower emhttpd: read SMART /dev/sdk

     

    but i dont have autofan or any plugins as mentioned in this topic enabled. Also no telegraf.

     

    Any one has an idea?

     

    Kind Regards,

    Dion

    Link to comment
    Share on other sites

    Did you trying to increase the a Tunable (poll_attributes) under Disk Settings ?
    Default is 1800.

    If you want to spindown the disks after 1 hour put in 3700, 2 hours put in 7300, etc.

    Link to comment
    Share on other sites

    With 6.9.2 seems to be fine, no spin up in 7 Hours.

     

    Thanks for fixing my Problem 👍

    Link to comment
    Share on other sites

    A few days later obvisiouly the same Problem again 😞

    Link to comment
    Share on other sites
    On 3/7/2021 at 9:39 PM, limetech said:

     

    I suggest you just hold off until 6.9.1 is published.  Will probably solve the problems you are seeing.

    The Problem is still present for me in 6.9.2

    Link to comment
    Share on other sites
    On 4/13/2021 at 12:26 AM, Xav said:

    A few days later obvisiouly the same Problem again 😞

     

    On 4/16/2021 at 10:55 PM, ben2000de said:

    The Problem is still present for me in 6.9.2

     

    Do the disks spindown after they woke up or do they stay spinning?

    Link to comment
    Share on other sites
    7 minutes ago, mgutt said:

     

     

    Do the disks spindown after they woke up or do they stay spinning?

    If you spindown some disks spin backup straight away.

     

    Happens on the schedule also. But effect varies between systems and some people do see an issue.

     

    I raised a new bug report.

     

     

    Link to comment
    Share on other sites
    18 hours ago, mgutt said:

     

     

    Do the disks spindown after they woke up or do they stay spinning?

    for me, the disks spinn down and then they read smart right away and spin up again.

    Tower emhttpd: read SMART /dev/sdd

    I have gone back to 6.9.1 there, they spin down nicely.

    Link to comment
    Share on other sites

    Same problem with 6.9.2 and Seagate-HDD.

     

    May 2 19:53:54 NAS emhttpd: spinning down /dev/sdb
    May 2 19:57:31 NAS emhttpd: read SMART /dev/sdb
    May 2 20:08:27 NAS emhttpd: spinning down /dev/sdb
    May 2 20:32:51 NAS emhttpd: read SMART /dev/sdb
    May 2 21:38:50 NAS emhttpd: spinning down /dev/sdb
    May 2 22:30:06 NAS emhttpd: read SMART /dev/sdb
    May 2 23:30:01 NAS emhttpd: spinning down /dev/sdb
    May 3 00:30:06 NAS emhttpd: read SMART /dev/sdb
    May 3 01:00:01 NAS emhttpd: spinning down /dev/sdb
    May 3 01:15:05 NAS emhttpd: read SMART /dev/sdb
    May 3 01:30:01 NAS emhttpd: spinning down /dev/sdb
    May 3 02:00:06 NAS emhttpd: read SMART /dev/sdb
    May 3 02:15:02 NAS emhttpd: spinning down /dev/sdb
    May 3 02:45:06 NAS emhttpd: read SMART /dev/sdb
    May 3 03:00:01 NAS emhttpd: spinning down /dev/sdb
    May 3 03:30:06 NAS emhttpd: read SMART /dev/sdb
    May 3 03:45:01 NAS emhttpd: spinning down /dev/sdb
    May 3 04:15:06 NAS emhttpd: read SMART /dev/sdb
    May 3 04:45:01 NAS emhttpd: spinning down /dev/sdb
    May 3 05:00:06 NAS emhttpd: read SMART /dev/sdb
    May 3 05:15:01 NAS emhttpd: spinning down /dev/sdb
    May 3 05:45:06 NAS emhttpd: read SMART /dev/sdb

    Edited by vernichter04
    Link to comment
    Share on other sites

    Same Problem here with Toshiba N300 NAS Systems 8TB, SATA 6Gb/s, bulk (HDWG180UZSVA) sind 6.9.2!

     

    [5:0:0:0]disk ATA TOSHIBA HDWG180 0603 /dev/sdb 8.00TB

    [10:0:0:0]disk ATA TOSHIBA HDWG180 0603 /dev/sdc 8.00TB

     

    May 3 22:07:52 Sugo root: plugin: running: anonymous
    May 3 22:34:28 Sugo emhttpd: spinning down /dev/sdb
    May 3 22:34:28 Sugo emhttpd: spinning down /dev/sdc
    May 3 23:02:42 Sugo emhttpd: read SMART /dev/sdb
    May 3 23:02:42 Sugo emhttpd: read SMART /dev/sdc
    May 3 23:34:23 Sugo emhttpd: spinning down /dev/sdb
    May 3 23:34:23 Sugo emhttpd: spinning down /dev/sdc
    May 4 00:02:16 Sugo emhttpd: read SMART /dev/sdb
    May 4 00:02:16 Sugo emhttpd: read SMART /dev/sdc

     

    PlugIns:

    CA Backup / Restore Appdata
    CA Cleanup Appdata
    Community Applications
    Disk Location
    Dynamix Cache Directories
    Dynamix SSD TRIM
    Dynamix System Statistics
    Fix Common Problems
    IPMI support    
    Nerd Tools    
    Network UPS Tools (NUT)
    Nvidia Driver
    Preclear Disks
    Recycle Bin
    Unassigned Devices
    Unassigned Devices Plus

     

     

    Link to comment
    Share on other sites

    I am seeing the same cycle. Drives spin down then an almost immediate SMART read causing them to spin back up.

     

    May 10 15:03:08 Tower emhttpd: spinning down /dev/sde
    May 10 15:03:13 Tower emhttpd: spinning down /dev/sdc
    May 10 15:03:25 Tower emhttpd: read SMART /dev/sde
    May 10 15:03:25 Tower emhttpd: read SMART /dev/sdc
    May 10 15:03:42 Tower flash_backup: adding task: php

    May 10 15:20:35 Tower emhttpd: spinning down /dev/sde
    May 10 15:20:35 Tower emhttpd: spinning down /dev/sdc
    May 10 15:20:44 Tower emhttpd: read SMART /dev/sde
    May 10 15:20:44 Tower emhttpd: read SMART /dev/sdc

     

    Is there a solution for this?

     

    Link to comment
    Share on other sites
    2 minutes ago, JHopple said:

    I am seeing the same cycle. Drives spin down then an almost immediate SMART read causing them to spin back up.

     

    May 10 15:03:08 Tower emhttpd: spinning down /dev/sde
    May 10 15:03:13 Tower emhttpd: spinning down /dev/sdc
    May 10 15:03:25 Tower emhttpd: read SMART /dev/sde
    May 10 15:03:25 Tower emhttpd: read SMART /dev/sdc
    May 10 15:03:42 Tower flash_backup: adding task: php

    May 10 15:20:35 Tower emhttpd: spinning down /dev/sde
    May 10 15:20:35 Tower emhttpd: spinning down /dev/sdc
    May 10 15:20:44 Tower emhttpd: read SMART /dev/sde
    May 10 15:20:44 Tower emhttpd: read SMART /dev/sdc

     

    Is there a solution for this?

     

    Are you running 6.9.0, 6.9.1 worked ok, 6.9.2 has some issues for some.

    Link to comment
    Share on other sites

     

    Just now, SimonF said:

    Are you running 6.9.0, 6.9.1 worked ok, 6.9.2 has some issues for some.

    6.9.2

    Link to comment
    Share on other sites
    SimonF

    Posted (edited)

    11 minutes ago, JHopple said:

     

    6.9.2

    Suggest downgrade to 6.9.1.

     

    Are you just sata?

     

    This is my bug post others are affected.

     

    Edited by SimonF
    Link to comment
    Share on other sites
    7 minutes ago, SimonF said:

    Suggest downgrade to 6.9.1.

     

    Are you just sata?

    Just SATA. I will downgrade.

    Tried setting the spin down timeout to less than poll interval. Didn't help. 

     

    Link to comment
    Share on other sites

    I have downgraded to 6.9.1 and I am still seeing the same pattern.

     

    May 10 16:05:50 Tower emhttpd: spinning down /dev/sdd
    May 10 16:05:50 Tower emhttpd: spinning down /dev/sdb
    May 10 16:06:01 Tower emhttpd: read SMART /dev/sdb
    May 10 16:06:02 Tower emhttpd: read SMART /dev/sdd

     

    My drives will not stay spun down.

     

     

    Link to comment
    Share on other sites
    1 hour ago, JHopple said:

    I have downgraded to 6.9.1 and I am still seeing the same pattern.

     

    May 10 16:05:50 Tower emhttpd: spinning down /dev/sdd
    May 10 16:05:50 Tower emhttpd: spinning down /dev/sdb
    May 10 16:06:01 Tower emhttpd: read SMART /dev/sdb
    May 10 16:06:02 Tower emhttpd: read SMART /dev/sdd

     

    My drives will not stay spun down.

     

     

    Which plugins are you using. Diags may be helpful.

    Link to comment
    Share on other sites



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.