• [6.9.x] Pool device replacement doesn't work

    • Minor

    How to reproduce:


    -start with a dual device pool in default raid1 profile

    -stop array, assign new device as a replacement, start array


    Unmountable: Too many missing/misplaced devices


    It worked on -beta25, it doesn't since -beta30, so it was introduced somewhere in between, diags below.


    User Feedback

    Recommended Comments

    Found a workaround :


    -stop array, remove 1 device in the pool

    -start array, let BTRFS work

    -stop array, add replacement device

    -start array, let btrfs work



    Edited by Alex.b
    Link to comment

    This is how BTRFS is designed.


    That is one of the reasons why I did throw BTRFS out of my systems. Consider a broken disk in a 2-disk RAID. What is needed as the first step? Put stress on the remaining disk (let BTRFS work #1). After that you can replace the failing disk and put stress on the remainig disk again (let BTRFS work #2).


    All other RAID systems I know about don't need #1.


    Link to comment
    10 minutes ago, hawihoney said:

    This is how BTRFS is designed.

    No, this is bug.


    It worked on -beta25, it doesn't since -beta30


    Link to comment

    It's an Unraid/GUI bug, you can still do it manually using the console.




    • Thanks 1
    Link to comment
    6 hours ago, Skylinar said:

    Is there any thread where I can see how it's done "manually using the console"?

    If you want start a thread in the general support forum, post the diags and what you want to do and I can post the instructions.

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.