Jump to content
  • Cannot set RX flow hash configuration: Operation not supported


    mgutt
    • Minor

    I have problems with my SMB multichannel setup and found out that windows supports the toeplitz hash function that needs a key length of 40 Bytes and some websites claim that XOR is supported as well. So I checked the RSS configuration of my network adapter:

    ethtool -x eth0
    RX flow hash indirection table for eth0 with 4 RX ring(s):
        0:      0     1     2     3     0     1     2     3
        8:      0     1     2     3     0     1     2     3
       16:      0     1     2     3     0     1     2     3
       24:      0     1     2     3     0     1     2     3
       32:      0     1     2     3     0     1     2     3
       40:      0     1     2     3     0     1     2     3
       48:      0     1     2     3     0     1     2     3
       56:      0     1     2     3     0     1     2     3
    RSS hash key:
    1e:ad:71:87:65:fc:26:7d:0d:45:67:74:cd:06:1a:18:b6:c1:f0:c7:bb:18:be:f8:19:13:4b:a9:d0:3e:fe:70:25:03:ab:50:6a:8b:82:0c
    RSS hash function:
        toeplitz: on
        xor: off
        crc32: off

    As you can see "toeplitz" is active and the key has a length of 40 bytes (hexadecimal). Should be correct. But I wanted to test if my problems will be solved if I enable XOR, but it fails:

    # ethtool -X eth0 hfunc xor
    Cannot set RX flow hash configuration: Operation not supported

    Then I tried to overwrite the key (with the same value), but this fails, too:

    # ethtool -X eth0 hkey 1e:ad:71:87:65:fc:26:7d:0d:45:67:74:cd:06:1a:18:b6:c1:f0:c7:bb:18:be:f8:19:13:4b:a9:d0:3e:fe:70:25:03:ab:50:6a:8b:82:0c
    Cannot set RX flow hash configuration: Operation not supported

    Finally I tried to allow XOR on an onboard NIC:

    ethtool -X eth1 hfunc xor
    Killed

    After that http://tower/Settings/NetworkSettings isn't loaded anymore and the CPU has maximum load:

    251834356_2020-09-2112_46_26.png.fce7664ba70fd0881063d773eb6dda44.png

     

    Then I tried to reboot the server, but it seems to be frozen as I'm still able to access through SMB (?) while the webclient is dead, external ssh is dead (putty) and the terminal hangs at "Starting diagnostics collection...

    868932080_WhatsAppImage2020-09-21at12_58_56.thumb.jpeg.1390607b08d2261af61bb47ba74e677a.jpeg

     

    After pressing the powerbutton the shutdown process repeated. But finally hanged again on "Starting diagnostics collection..." so I needed to hold the powerbutton to force shutdown.

     

    I'm not sure if this is a bug related to Unraid, Slackware or the network adapter, but it seems to be a bug as all search engine results are related to bugs.



    User Feedback

    Recommended Comments

    There are no comments to display.



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.