Jump to content
  • Docker update dialog sometimes breaks

    • Minor

    Please see post

    for more information.


    Sometimes the update dialog will be blank and not show the current progress (like Docker pulling the new image, etc.) In the console, the following error is logged:


    11:00:27.506 Uncaught TypeError: progress_span[data[1]] is null
        progress_dots[data[1]]< https://dipper:1443/Docker:1494
        setInterval handler* https://dipper:1443/Docker:1494
        emit https://dipper:1443/webGui/javascript/dynamix.js?v=1700087630:15
        onmessage https://dipper:1443/webGui/javascript/dynamix.js?v=1700087630:15
        listen https://dipper:1443/webGui/javascript/dynamix.js?v=1700087630:15
        start https://dipper:1443/webGui/javascript/dynamix.js?v=1700087630:15
        openDocker https://dipper:1443/Docker:252
        updateContainer https://dipper:1443/plugins/dynamix.docker.manager/javascript/docker.js?v=1700087630:108
        i https://dipper:1443/webGui/javascript/dynamix.js?v=1700087630:51
        h https://dipper:1443/webGui/javascript/dynamix.js?v=1700087630:51
        t https://dipper:1443/webGui/javascript/dynamix.js?v=1700087630:51
        u https://dipper:1443/webGui/javascript/dynamix.js?v=1700087630:51
        updateContainer https://dipper:1443/plugins/dynamix.docker.manager/javascript/docker.js?v=1700087630:105
        action https://dipper:1443/plugins/dynamix.docker.manager/javascript/docker.js?v=1700087630:12
        dispatch https://dipper:1443/webGui/javascript/dynamix.js?v=1700087630:5
        handle https://dipper:1443/webGui/javascript/dynamix.js?v=1700087630:5
    4 Docker:1494:59



    Sometimes (like 1 out of 30 attempts), the update dialog will function normally, but I can't tell what the trigger is. I can't test more because I only have a chance to reproduce whenever Docker images have a new update.


    This is reproducible from the version in the original post (6.12.3) up to 6.12.5. I haven't updated to 6.12.6 yet, but I'm pretty sure the issue is there as well because the .6 release only updates ZFS if I'm understanding the changelog correctly. I will edit this comment once I update and check.

    User Feedback

    Recommended Comments

    There are no comments to display.

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...