Jump to content
  • Downgraded back to 6.6.7 due to Sqlite corruption


    limetech
    • Urgent

    This is continuation of this original issue report.

     

    There is some conflicting information in that topic and, therefore, with your help, we want to try and get to the bottom of this.  We have several test servers running trying to reproduce this problem, so far hasn't happened.

     

    The first thing we want to definitively establish is whether the problem is isolated to only those cases where /config inside the container is mapped to:

    /mnt/user/appdata

    vs.

    /mnt/cache/appdata

    or

    /mnt/diskN/appdata

     

    Note: it does not matter what the "Default appdata storage location" is set to on Settings/Docker page.  Of interest is the actual path used by an individual container.

     

    What I'd like to ask is this:  For those of you who have seen this DB corruption occur after updating from Unraid 6.6.x to 6.7.x, please note the placement of your 'appdata' folder and how it's mapped to your problematic container.  Then update to 6.7.2 and run normally until you see corruption.  At that point, please capture diagnostics and report how appdata is being mapped.  If this is a huge PITA for you, then bow out of this testing - we are not trying to cause big disruptions for you.

     

    Finally I want to make clear: we are not "blaming" this issue on any other component, h/w or s/w, and also not "admitting" this is our problem.  We have not changed any code we're responsible for that would account for this, which doesn't mean we don't have a bug somewhere - probably we do, and a change in the kernel or some other component might simply be exposing some long hidden issue.  We are only interested in identifying and fixing the problem.



    User Feedback

    Recommended Comments



    48 minutes ago, isrdude said:

    I'm nervouse that this could only be a band-aid if Plex alters some of their coding

    Probably not Plex since other apps that use sqlite also experience corruption.

     

    Let's please retire this topic and switch to new one:

     

    Share this comment


    Link to comment
    Share on other sites

    I did, I copy pasted it over to your new thread

    Share this comment


    Link to comment
    Share on other sites

    I moved this to the new thread:

     

    Just a hint:

    I moved my appdata-directories (the ones who are using sqlite) to an external drive using the "Unassigned Devices"-plugin. Normally appdata is on /mnt/disk1/.

    Upgraded from 6.6.7 to 6.7.2 and have no database corruption since. I do not have a cache drive. I think the database corruption must be something to do with array-functionality.

     

    I will downgrade tonight and move the appadata-directories back to /mnt/disk1 and then upgrade to 6.7.3-rc2.

    Edited by hpaar
    • Like 1

    Share this comment


    Link to comment
    Share on other sites

    Hi,

    I'm still getting the database corruption every 5 minutes ... my appdata is set to /mnt/user/appdata including ALL disks and use cache disk set to "prefer".

    I'm also running version 6.7.2 of UNRAID. 

    Any info on this? Thanks!

    Share this comment


    Link to comment
    Share on other sites

    As stated earlier, new and current info is available at the active thread:

     

     

    Share this comment


    Link to comment
    Share on other sites

    Any update for this problem? I have database corrupt every few days.

    Unraid version 6.7.2

    appdata is \mnt\user\appdata

    Share this comment


    Link to comment
    Share on other sites

    New user (trial install) with a single disk, using plex-unRAID container with default appdata location. DB corrupted within the first few hours of usage while media was being added by Plex.

    Share this comment


    Link to comment
    Share on other sites

    Exactly which release were you running?    Since you only have a single disk I assume that means that appdata is on an array drive?

    Share this comment


    Link to comment
    Share on other sites

    I am still seeing issues similar to what has been described here, I was running 6.7.2 and seeing Plex and Sonarr issues but then I downgraded to 6.6.7 and am still having the same issues. With Plex I was having issues with metadata in my TV library not loading anymore even when it had been loaded in the past (posters, background images, etc) and I could not get any TV shows to play. My Movies library played fine for some reason though. Sonarr was just stuck on the loading page no matter what I tried. All these problems were originally found on 6.7.2 and remained when I downgraded to 6.6.7. Any ideas on a fix? 

     

    Any help here would be greatly appreciated. 

    Thank you 

     

    glacier-diagnostics-20191010-0004.zip

    Share this comment


    Link to comment
    Share on other sites

    As stated earlier, new and current info is available at the active thread:

     

    Share this comment


    Link to comment
    Share on other sites

    Thanks @BRiT ill follow that, I wasn't sure if it was the same thing since I don't know if I am seeing the same corruptions or something different than causes only one library in Plex to fail. 

    Share this comment


    Link to comment
    Share on other sites



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.