• local boot gui mode not working with Intel GPU


    Chris Mot
    • Solved

    Hello to @ich777 and the unraid community.


    I am new to unraid and just recently built a NAS with an Intel i5-11500 (LGA1200) with UHD Graphics 750. An HDMI monitor is connected to I/O motherboard panel. I run unraid 6.9.2 and start in UEFI mode.
    Everything runs fine with the "remote web GUI" and using "My unraid server".

     

    I'd like to use the boot GUI mode directly on the NAS to obtain a token to link rclone to my cloud.


    I have gone on the forum through several topics related to failing GUI boot with a blinking cursor on a blank screen.
    It's a lot of reading and testing.
    I tried: 
    - regular GUI mode
    - safe GUI mode
    - the option with Ctrl - Alt - F1 / modprobe i915 / /etc/rc.d/rc.4 
    - the options with or without Intel GPU top application
    - also with or without additon of nomodeset  or   i915.modeset=0 in the flash syslinux config
    - also the option the console: if [ ! -d /boot/config/modprobe.d ]; then
        mkdir -p /boot/config/modprobe.d
        fi
        touch /boot/config/modprobe.d/i915.conf


    Unfortunately no boot GUI available after these attempts.


    I run no VM, and does not use any additional graphic card. Docker autostart is disabled, and array autostart is disabled as well.

     

    English is not my native language, hope my explanations are clear, otherwise, please ask precisions.

     

    Here enclosed is my latest dagnostic file.

     

    Thanks in advance for your help

    uranus-diagnostics-20210610-1824.zip




    User Feedback

    Recommended Comments

    @Chris Mot please remove the file: /boot/config/modprobe.d/i915.conf and add this to your boot config: 'i915.force_probe=4c8a' and install the Intel-GPU-TOP plugin and reboot.

     

    EDIT:

    Quote

    I'd like to use the boot GUI mode directly on the NAS to obtain a token to link rclone to my cloud.

    Isn't this possible through a remote terminal?

    Link to comment

    @ich777 I followed your suggestions (- i915.conf + i915.force_probe=4c8a and Intel-GPU-TOP install) that worked in regular GUI boot mode right away. 

     

    Huge thanks.

    2 hours ago, ich777 said:

    Isn't this possible through a remote terminal?

    I am just at the first steps to install rclone, and it seems that one must ask for the token to link the cloud service from a machine running rclone too while running a web browser to obtain the token, and then paste it to the unraid rclone config.

     

    During my readings about failing boot GUI mode, I saw somebody else which wanted to install rclone too. I understood, this might be a mandatory step, or easier one.

     

    Thanks again.

     

    How can I "switch" the subject title to [SOLVED] ? 

    Link to comment
    7 hours ago, Chris Mot said:

    How can I "switch" the subject title to [SOLVED] ? 

    Click on Edit on the first post and at the bottom you can change the status.

     

    7 hours ago, Chris Mot said:

    i915.force_probe=4c8a

    This is only mecessary because your CPU is new and the i915 module doesn't know the new device ID's.

    So you have to manually tell the module that it should try this device ID if it can start the driver with it.

    This shouldn't be necessary in upcoming versions of Unraid so if 6.10.x+ is released you can remove that from your sylinux.cfg

     

    Hope that makes sense to you.

    Also this is a little simplificated answer...

    Link to comment
    1 hour ago, ich777 said:

    This is only mecessary because your CPU is new and the i915 module doesn't know the new device ID's.

    So you have to manually tell the module that it should try this device ID if it can start the driver with it.

    This shouldn't be necessary in upcoming versions of Unraid so if 6.10.x+ is released you can remove that from your sylinux.cfg

    You mean when a new version of unraid (6.9.3 likely) , or a new version of the Intel GPU TOP plugin (coded later than 2021.05.04)?

     

    Anyway, I will try the removal with any of the first occurence.

     

    By the way, regular GUI boot works while safe GUI boot doesn't; I assume because Intel GPU TOP is not loaded in this later option, but regular one is the only I need to do what I want.

    Link to comment
    2 hours ago, Chris Mot said:

    You mean when a new version of unraid (6.9.3 likely) , or a new version of the Intel GPU TOP plugin (coded later than 2021.05.04)?

    A new version of Unraid 6.10.x and up (I think 6.10.x will drop before 6.9.3). ;)

     

    Unraid, Intel-GPU-TOP enables only the driver and installs the necessary application to install GPU Statistics to see the utilization in your Unraid Dashboard.

     

    2 hours ago, Chris Mot said:

    By the way, regular GUI boot works while safe GUI boot doesn't; I assume because Intel GPU TOP is not loaded in this later option, but regular one is the only I need to do what I want.

    Exactly in Safe mode are no plugins loaded and the modules is not loaded, if you really need it then you have to create the file: /boot/config/modprobe.d/i915.conf again, but this is very unlikely that you need safe mode anyways.

    Link to comment
    1 minute ago, ChatNoir said:

    Changed Status to Solved

    Changed Priority to Other

    Voilà, c'est fait.

    Done

    • Haha 1
    Link to comment

    @Chris Mot & @ChatNoir I've updated the Intel-GPU-TOP plugin yesterday so that no modification to the syslinux.cfg is necessary anymore.

     

    Please make sure that you are on the latest version from Intel-GPU-TOP (2021-06-15), remove the added parameter to the syslinux.cfg (i915.force_probe=4c8a) and reboot.

     

    Everything should now be enabled automatically. :)

     

    Please leave me a short message here if everything worked fine.

    • Like 1
    Link to comment

    Hi,

    I have a transfer ongoing. 
    I will update the app and syslinux.cfg later today and let you know asap. 
    Cheers. 

    Link to comment
    17 hours ago, ich777 said:

    @Chris Mot & @ChatNoir I've updated the Intel-GPU-TOP plugin yesterday so that no modification to the syslinux.cfg is necessary anymore.

     

    Please make sure that you are on the latest version from Intel-GPU-TOP (2021-06-15), remove the added parameter to the syslinux.cfg (i915.force_probe=4c8a) and reboot.

     

    Everything should now be enabled automatically. :)

     

    It is now working correctly once I did according to your recommendation.

    Thanks again for your help. :)

    • Like 1
    Link to comment


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.