• mounting iso9660 doesn't preserve full names

    • Annoyance

    Steps to reproduce:
    - sudo mount myiso.iso -t iso9660 test

    - ls test/Photos




    Same is on unraid side:

    - mount /mnt/disk4/test/myiso.iso -t iso9660 /mnt/disks/test/
    - ls test/photos  (no uppercase 'P')



    also used GUI for that (Add iso file share).

    How I should mount it properly - i want to preserve long names of files?


    EDIT: I'm using unraid 6.9.2

    User Feedback

    Recommended Comments

    From the mount(8) man page:



    Normal iso9660 filenames appear in a 8.3 format (i.e., DOS-like restrictions on filename length), and in addition all characters are in upper case. Also there is no field for file ownership, protection, number of links, provision for block/character devices, etc.


    Rock Ridge is an extension to iso9660 that provides all of these unix like features. Basically there are extensions to each directory record that supply all of the additional information, and when Rock Ridge is in use, the filesystem is indistinguishable from a normal UNIX filesystem (except that it is read-only, of course).


    What is the origin of your .iso file? Is it Rock Ridge compatible? Using a standard Kubuntu installation image, it works fine for me:


    root@Pusok:~# mkdir t
    root@Pusok:~# mount -t iso9660 /mnt/user/isos/kubuntu-20.10-desktop-amd64.iso t
    mount: /root/t: WARNING: source write-protected, mounted read-only.
    root@Pusok:~# ls t
    EFI/                boot/         casper/  install/    pics/  preseed/
    README.diskdefines  boot.catalog  dists/   md5sum.txt  pool/  ubuntu@
    root@Pusok:~# ls t/casper
    filesystem.manifest                 filesystem.size          initrd
    filesystem.manifest-minimal-remove  filesystem.squashfs      vmlinuz
    filesystem.manifest-remove          filesystem.squashfs.gpg
    root@Pusok:~# umount t
    root@Pusok:~# rmdir t


    I suggest you try the same (or similar) standard file.


    • Thanks 1
    Link to comment



    isoinfo -R -d -i GBC_V17_01.iso 
    CD-ROM is in ISO 9660 format
    System id: SYSTEMID
    Volume id: GBC_V17_01
    Volume set id: GBC_V17_01
    Publisher id: 
    Data preparer id: STARBURN SDK
    Application id: 
    Copyright File id: 
    Abstract File id: 
    Bibliographic File id: 
    Volume set size is: 1
    Volume set sequence number is: 1
    Logical block size is: 2048
    Volume size is: 699073
    Joliet with UCS level 3 found
    NO Rock Ridge present

    No Rock Ridge... so how ubuntu does it and shows filles with long names?

    Unraid even has newer version of mount:


    mount from util-linux 2.36 (libmount 2.36.0: btrfs, mtab, namespaces, assert, debug)

    vs ubuntu:


    mount from util-linux 2.34 (libmount 2.34.0: selinux, smack, btrfs, namespaces, assert, debug)


    My iso: https://mega.nz/file/BVlnTCha#zYhZeS-vRYFBD1dbWiJie6KW6ZmzNuHeOjxdblWmDhQ

    Link to comment
    7 minutes ago, Pawel said:

    No Rock Ridge... so how ubuntu does it and shows filles with long names?


    Standards are so good that everyone wants their own, so that's what Microsoft did:


    7 minutes ago, Pawel said:

    Joliet with UCS level 3 found


    See here: https://tldp.org/HOWTO/CDROM-HOWTO/x1186.html#AEN1328


    Perhaps Joliet support is not included in the Unraid kernel but it is in the Ubuntu kernel. That would make sense because Unraid is not a general purpose Linux and has a lot of unnecessary options removed. If that's the case then your options would be:

    • re-create your .iso with Rock Ridge enabled;
    • use a different image file format that supports long filenames and mixed case natively;
    • use an Ubuntu VM to mount the .iso file;
    • make a feature request for Joliet support to be included in a future release;
    • investigate the possibility of compiling your own kernel with Joliet support included.


    • Thanks 1
    Link to comment

    Unraid is not a general purpose Linux and has a lot of unnecessary options removed. 

    Thats makes sense. Thak You for clarifying this issue. And give me a lot ways to fix it. 

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.