• Terminal Window turns 'white' after 20 seconds


    ds679
    • Annoyance

    When using the GUI to open a terminal window - after about 20 seconds the window turns white (and non-responsive - I've tried 'clear' and 'exit' - with no response).  I can 'F5/Reload' the window and it works (for another 20 seconds).
    Repeatable

     

    Thanks in advance - dave

     

    P.S.  Do items reported via the GUI 'Feedback -> Bug Reports' automagically show up here?  Posted this earlier via that method and didn't see it show up...please ignore if repeated.  Thx

    tower3-diagnostics-20191211-1755.zip



    User Feedback

    Recommended Comments



    Quote

    P.S.  Do items reported via the GUI 'Feedback -> Bug Reports' automagically show up here? 

    No.  That's emailed directly to LT

    • Like 1
    Link to comment
    Share on other sites

    I've cleared site cookies (using Chrome Version 78.0.3904.108 (Official Build) (64-bit)....made sure of the Whitelist exception in AdBlock.

    Tried in Microsoft Edge....the terminal window opens IN White (not even a chance to have a terminal like Chrome)

    Is nobody else experiencing this?

    Link to comment
    Share on other sites

    Howdy - I listed the Chrome version in a response....but thought it worth trying in others.  IE & Edge - didn't work.  But why not Chrome?  Worked great pre-6.8.0?


    Appreciate all the hard/good work!

    =dave

    Link to comment
    Share on other sites

    @ds679Have you tried in incognito mode (i.e., without extensions running)?

     

    Here's why I ask: I use Brave, a Chromium-based browser, and web-based terminals worked fine in 6.7.9. With 6.8, they started opening blank. I had to disable Brave's "shields" for my unraid site, and everything started displaying correctly again.

    Link to comment
    Share on other sites

    Ahhh....good idea...and...drumroll...IT WORKS!  I'm in the terminal window and no blanking/whiting out!

    Were you able to go 'one by one' and see which one (or was it the whole 'shields' part) was causing the problem?

     

    Thanks for the idea!

    =dave

    Link to comment
    Share on other sites

    Brave "Shields" are essentially an ad blocker with some other cookie blocking stuff built in. If you've got an adblock extension installed, maybe try disabling it for your unraid domain?

    Edited by DBJordan
    Link to comment
    Share on other sites

    Thanks for the thoughts/info.  Both the IP and the DNS name of my server are whitelisted.

     

    What is strange is that it worked pre-update; so it has to be some implemented changed.  The only other thing is that it is contacting some AD server (and my Pi-Hole is catching it).  I've also white-listed the server there - why would it be contacting some AD service?

     

    Still searching for clarity,

     

    =dave

    Link to comment
    Share on other sites

    Good luck, mate. You've monitored what's on the wire much closer than I have -- I'm new to unraid, so perhaps my suggestion was beginner's luck. I hope you find the answer!

    Link to comment
    Share on other sites

    I had this challenge as well, and wanted to share my experience in case it helps others.  My issue turned out to be the extension Ghostery. White listing the unraid server was not enough.  The white screens wouldn't stop until I paused or disabled the add-in entirely.  

    • Thanks 1
    Link to comment
    Share on other sites

    I appreciate all of the help - but this issue still is persistent & repeatable....and has not occurred with other releases.  There is still an issue with the current codebase.

     

    =-dave

    Edited by ds679
    Link to comment
    Share on other sites
    On 12/15/2019 at 4:10 PM, ds679 said:

    Ahhh....good idea...and...drumroll...IT WORKS!  I'm in the terminal window and no blanking/whiting out!

    Were you able to go 'one by one' and see which one (or was it the whole 'shields' part) was causing the problem?

     

    Thanks for the idea!

    =dave

     

    On 1/2/2020 at 8:24 PM, ds679 said:

    I appreciate all of the help - but this issue still is persistent & repeatable....and has not occurred with other releases.  There is still an issue with the current codebase.

     

    =-dave

    Earlier you said you figured out the issue.

    Link to comment
    Share on other sites

    I guess I would consider that more of a 'hack work-around'...but there is still something different/new in this release that is a 'bug'

    Link to comment
    Share on other sites

    Ad blocking browsers and extensions actively modify the website's code. Pi-Hole actively blocks network connections that the code expects to be there. 

     

    I use similar services too, but when something goes wrong it is not the fault of the website you are visiting, it is the fault of the ad blocking software that is modifying/blocking portions of the website. If you want to view the website as the author intended, you need to whitelist it. That is not a hack on the part of the website, it is a hack to get around bugs/false positives in the ad blocking software.
     

    Link to comment
    Share on other sites

    Hi LJM42,

     

    Thanks for the follow-up...and I understand what you're saying but that isn't the issue.  All earlier versions worked on this same setup/extensions/pi-hole setups/etc.....once this new version came along; the issue began.
    An earlier post narrowed it down to Grammerly and while even white-listing the site - it still occurs.  The only 'hack workarounds' are to open incognito (which requires a new log-in)...or totally remove the extension (which worked fine in all previous versions).

    Link to comment
    Share on other sites

    OK that sounds like the same issue though. A browser extension you installed is modifying the code of a website in a way that you don't like. It isn't up to the website to work around what the extension is doing, it is up to the extension to not modify the website incorrectly.

     

    It looks like Grammerly has a whitelist, perhaps you can use that to keep it from modifying the Unraid webgui?
      https://support.grammarly.com/hc/en-us/articles/115000091612-Disable-the-Grammarly-extension-on-one-or-more-websites
     

    Link to comment
    Share on other sites
    10 minutes ago, ds679 said:

    narrowed it down to Grammerly and while even white-listing the site - it (the original issue of 'whiting out' after 10 seconds) still occurs.  

     

    Link to comment
    Share on other sites

    So you're saying there is a bug in the Grammerly extension that causes it to modify the Unraid webgui even when it is whitelisted? That doesn't seem like an Unraid issue...

    Link to comment
    Share on other sites
    7 minutes ago, ljm42 said:

    So you're saying there is a bug in the Grammerly extension that causes it to modify the Unraid webgui even when it is whitelisted? That doesn't seem like an Unraid issue...

    No...because the exact same extension worked BEFORE the update and all previous updates....

    Say it with me:

    Old Code worked....ok
    New Code breaks on same setup.....that's a bug in the code-change

    What is so hard about that?

    Link to comment
    Share on other sites
    On 1/5/2020 at 12:19 AM, ds679 said:

    No...because the exact same extension worked BEFORE the update and all previous updates....

    Sure, but this doesn't mean it's an unraid bug. New code can reveal bugs in third party extensions, and this is what seems to happen, just my 2 cents.

    Link to comment
    Share on other sites
    On 1/4/2020 at 3:19 PM, ds679 said:

    Say it with me:

    Old Code worked....ok
    New Code breaks on same setup.....that's a bug in the code-change

    What is so hard about that?

    I can hear your frustration, but please let's keep the dialog friendly 😎

     

    The current codebase we're using for ttyd is from 2019.10.25 and as you can see there have been several commits since then.  I'll update to their latest commit in next release.

    Link to comment
    Share on other sites



    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.