• Unraid 6.8.3 Nested VM Windows 10 VM

    • Minor

    Hi, while i was trying to test the new WSL2 feature it seems nester VM feature is not working anymore.


    Unraid 6 8 3

    VM Windows 10 pro


    what have i done


    disabled all VMs, disabled VM Manager, unraid shell

    modprobe -r kvm_intel

    modprobe kvm_intel nested=1

    edited VM xml template with the following entry under <cpu> section

        <feature policy='require' name='vmx'/>


    tried starting VM Manager, no way, always ended in <LIBVrt service failed to start>

    after some digging and results only showed check pathes (which where correct), i rebooted, VM Manager is back up and running, so went further.


    followed guide to enable nested VM by adding <kvm_intel.nested=1> to the boot append line, rebooted


    now, when i enable the feature in the Win 10 VM

    dism.exe /online /enable-feature /featurename:VirtualMachinePlatform /all /norestart

    and reboot, Win10 system crashes, have to restart in safe mode, changes are reverting and VM boots up normally but of course without virt possibility.


    after some further tests and some more searches i gave up now, when i read i see there is also a open issue


    which is pretty similar, so its probably still not solved ?


    For an Info thanks ahead


    attached diags


    ps. as WSL2 is coming now, i guess alot more will like to try the new features which demands nested virt ...


    • Like 3

    User Feedback

    Recommended Comments


    I also use nested virtualization,''kvm_intel nested=1''  is also display that turned on in the unraid system

    But it doesn't seem to work,6.7.2 version is not issue. 

    In virtualmachine proxmox ve ,nested virtualization a Windows 10,but it always display the launch icon

    6.8version nested virtualization command maybe do not work


    Link to comment

    I had this same thing happen to me, following the same set of steps also on 6.8.3. After enabling the options, and editing the XML, I booted the VM and turned on Hyper V features in windows. When it attempted to reboot, and on all subsequent boot attempts, the VM would not boot and was stuck on the Tiano Core screen. After going through a ton of posts on the forums, and none of the solutions working, I found this open report [6.8.2] NESTED HYPER-V NOT WORKING, which seems incredibly similar. I decided to try and downgrade to 6.7.2 but got as far as 6.8.2 and the GUI provided no option to downgrade again. So, I decided to boot the VM just to see what it did on 6.8.2. To my extreme surprise, the VM booted just fine into windows and everything is working. I unfortunately do not have any diagnostic information, but wanted to report another occurrence of this issue.

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.