Jump to content
  • Unraid unable to create shares in existing pre-6.12 ZFS pool from GUI. Works fine with newly created pool.


    wildfire305
    • Annoyance

    There is something about this pre-existing zpool that makes unriad unable to create new shares on it from the GUI. I am easily able to create new datasets from the command line and then unraid creates a share (it improperly assigns the dataset generated share primary storage to the array) with the dataset name. Previously in another bug report a user mentioned that behavior (wrong storage assignment) when manually creating datasets from CLI - so that behavior is expected since that isn't the recommended method.

     

    ZFS attributes pasted below and error from syslog when attempting to create a share. I did notice that a few attributes do not match my other newly created post-6.12 zpool that adding shares to works fine on.

     

    root@CVG02:~# zfs get all snapshot
    NAME      PROPERTY              VALUE                  SOURCE
    snapshot  type                  filesystem             -
    snapshot  creation              Fri Nov 11  2:47 2022  -
    snapshot  used                  12.8T                  -
    snapshot  available             1.18T                  -
    snapshot  referenced            41.5K                  -
    snapshot  compressratio         1.02x                  -
    snapshot  mounted               yes                    -
    snapshot  quota                 none                   default
    snapshot  reservation           none                   default
    snapshot  recordsize            128K                   default
    snapshot  mountpoint            /mnt/snapshot          local
    snapshot  sharenfs              off                    default
    snapshot  checksum              on                     default
    snapshot  compression           off                    local
    snapshot  atime                 off                    local
    snapshot  devices               on                     default
    snapshot  exec                  on                     default
    snapshot  setuid                on                     default
    snapshot  readonly              off                    default
    snapshot  zoned                 off                    default
    snapshot  snapdir               hidden                 default
    snapshot  aclmode               discard                default
    snapshot  aclinherit            restricted             default
    snapshot  createtxg             1                      -
    snapshot  canmount              on                     default
    snapshot  xattr                 on                     default
    snapshot  copies                1                      default
    snapshot  version               5                      -
    snapshot  utf8only              off                    -
    snapshot  normalization         none                   -
    snapshot  casesensitivity       sensitive              -
    snapshot  vscan                 off                    default
    snapshot  nbmand                off                    default
    snapshot  sharesmb              off                    default
    snapshot  refquota              none                   default
    snapshot  refreservation        none                   default
    snapshot  guid                  8916430419615625548    -
    snapshot  primarycache          all                    default
    snapshot  secondarycache        all                    default
    snapshot  usedbysnapshots       0B                     -
    snapshot  usedbydataset         41.5K                  -
    snapshot  usedbychildren        12.8T                  -
    snapshot  usedbyrefreservation  0B                     -
    snapshot  logbias               latency                default
    snapshot  objsetid              54                     -
    snapshot  dedup                 off                    local
    snapshot  mlslabel              none                   default
    snapshot  sync                  standard               default
    snapshot  dnodesize             legacy                 default
    snapshot  refcompressratio      1.00x                  -
    snapshot  written               41.5K                  -
    snapshot  logicalused           13.1T                  -
    snapshot  logicalreferenced     13.5K                  -
    snapshot  volmode               default                default
    snapshot  filesystem_limit      none                   default
    snapshot  snapshot_limit        none                   default
    snapshot  filesystem_count      none                   default
    snapshot  snapshot_count        none                   default
    snapshot  snapdev               hidden                 default
    snapshot  acltype               off                    default
    snapshot  context               none                   default
    snapshot  fscontext             none                   default
    snapshot  defcontext            none                   default
    snapshot  rootcontext           none                   default
    snapshot  relatime              off                    default
    snapshot  redundant_metadata    all                    default
    snapshot  overlay               on                     default
    snapshot  encryption            off                    default
    snapshot  keylocation           none                   default
    snapshot  keyformat             none                   default
    snapshot  pbkdf2iters           0                      default
    snapshot  special_small_blocks  0                      default
    root@CVG02:~# zpool status snapshot
      pool: snapshot
     state: ONLINE
      scan: scrub canceled on Sat Jul  1 10:11:14 2023
    config:
    
            NAME        STATE     READ WRITE CKSUM
            snapshot    ONLINE       0     0     0
              raidz1-0  ONLINE       0     0     0
                sdk     ONLINE       0     0     0
                sdi     ONLINE       0     0     0
                sdj     ONLINE       0     0     0
                sdg     ONLINE       0     0     0
                sdl     ONLINE       0     0     0
                sdf     ONLINE       0     0     0
    
    errors: No known data errors

     

    Yes, the scrub was cancelled on purpose because I didn't realize I had it as a scheduled cron task AND unraid can now run it on ZFS pools on a schedule. It had just ran a few days prior. I just pasted that so you could see what kind of pool it is - made out of 10yo 3tb Hitachis.

     

    Error in syslog when trying to create a share on the zpool named "snapshot".

     

    Jul  3 08:27:24 CVG02 shfs: share cache full
    Jul  3 08:27:24 CVG02 emhttpd: error: shfs_mk_share, 6451: No space left on device (28): ioctl: /newshare
    Jul  3 08:27:24 CVG02 emhttpd: shcmd (405): rm '/boot/config/shares/newshare.cfg'
    Jul  3 08:27:24 CVG02 emhttpd: Starting services...
    Jul  3 08:27:25 CVG02 emhttpd: shcmd (408): /etc/rc.d/rc.samba restart

     

    This error makes it sounds like it cannot identify the FS properly as it runs shfs_mk_share rather than zfs create.

     

    For comparison - successful share creation on the other newly create zpool:

     

    Jul  3 08:33:56 CVG02 shfs: /usr/sbin/zfs create 'cache/newsharenewpool'
    Jul  3 08:33:56 CVG02 emhttpd: Starting services...
    Jul  3 08:33:56 CVG02 emhttpd: shcmd (421): chmod 0777 '/mnt/user/newsharenewpool'
    Jul  3 08:33:56 CVG02 emhttpd: shcmd (422): chown 'nobody':'users' '/mnt/user/newsharenewpool'
    Jul  3 08:33:56 CVG02 emhttpd: shcmd (423): /etc/rc.d/rc.samba restart

    Diagnostics attached for posterity. In summary I'm trying to figure out why unraid can't create the datasets on this particular zpool, and if it can be resolved.

     

    cvg02-diagnostics-20230703-0829.zip




    User Feedback

    Recommended Comments

    I receive the following running Unraid 6.12.6:

     

    Dec 12 10:30:05 Unraid emhttpd: error: shfs_mk_share, 6459: No medium found (123): ioctl: /NewShare

     

     

    Link to comment


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.

×
×
  • Create New...