Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 12/31/18 in all areas

  1. 1 point
    Note: To view the application lists before installing unRaid, click HERE Community Applications (aka CA) This thread is rather long (and is mostly all off-topic), and it is NOT necessary to read it in order to utilize Community Applications (CA) Just install the plugin, go to the apps tab and enjoy the freedom. If you find an issue with CA, then don't bother searching for answers in this thread as all issues (when they have surfaced) are fixed generally the same day that they are found... (But at least read the preceding post or two on the last page of the thread) - This is without question, the best supported plugin / addon in the universe - on any platform. Simple interface and easy to use, you will be able to find and install any of the unRaid docker or plugin applications, and also optionally gain access to the entire library of applications available on dockerHub (~1.8 million) INSTALLATION To install this plugin, paste the following URL into the Plugins / Install PlugIn section: https://raw.githubusercontent.com/Squidly271/community.applications/master/plugins/community.applications.plg After installation, a new tab called "Apps" will appear on your unRaid webGUI. To see what the various icons do, simply press Help or the (?) on unRaid's Tab Bar. Note All screenshots in this post are subject to change as Community Applications continues to evolve Easily search or browse applications Get full details on the application Easily reinstall previously installed applications And much, much more (including the ability to search for and install any of the containers available on dockerHub (1,000,000+) USING CA CA also has a dedicated Settings section (click Settings) which will let you fine tune certain aspects of its operation. NOTE: The following video was made previously to the current user interface, so the video will look significantly different than the plugin itself. But it's still worth a watch. Buy Andrew A Beer! Note that CA is always (and always will be) compatible with the latest Stable version of unRaid, and the Latest/Next version of unRaid. Intermediate versions of various Release Candidates may or may not be compatible (though they usually are - But, if you have made the decision to run unRaid Next, then you should also ensure that all plugins and unRaid itself (not just CA) are always up to date). Additionally, every attempt is made to keep CA compatible with older versions of unRaid. As of this writing, CA is compatible with all versions of unRaid from 6.4 onward. Cookie Note: CA utilizes cookies in its regular operation. Some features of CA may not be available if cookies are not enabled in your browser. No personally identifiable information is ever collected, no cookies related to any software or media stored on your server are ever collected, and none of the cookies are ever transmitted anywhere. Cookies related to the "Look & Feel" of Community Applications will expire after a year. Any other cookies related to the operation of Community Applications that are used are automatically deleted after they are used (usually within a minute or two) Note: Some features (in particular installations from a dockerHub search) may require popups to be enabled on your browser (different browsers enforce this requirement differently). You should whitelist your server to allow popups within your browser if this becomes an issue.
  2. 1 point
    Personally if I were using Krusader, I would just map /mnt to /mnt and just find things at their expected paths instead of remapping to /media. A lot less confusing for everyone concerned I would think. And if you are going to have to map the disks anyway it isn't really any safer to map to /media.
  3. 1 point
    The last time I checked, most of the SCSI changes were implemented in 4.19. I haven't done a full 4.19 vs 4.20 breakdown in the SCSI and FS areas/modules to see what additional changes were implemented. If 6.7 drops with 4.19, we "should" be good. If 6.7 comes with a Slackware re-baseline, even better, as there are several updated packages that would compliment the improvements. The other aspect I have been becoming familiar with is UNMAP. Similar to FSTRIM, it provides instructions to the PCI bus to perform certain actions. Again, learning as time permits. Nevertheless, it seems the SCSI community acknowledged the collapse of several modules and programming language/library optimization has effected several functionalities in the HBA world. I'm really hoping it all comes to bed at 4.19 or 4.20. Again, fingers crossed.
  4. 1 point
    @slimshizn I've been patiently trying not to post anything ETA-like verbiage on here. But I'm pretty sure a good Unraid system re-baseline, with the newly released 4.20 linux kernel, should provide the improvements/fixes we'd expect (fingers crossed).
  5. 1 point
    While it is a good idea to convert to XFS, that is a totally separate thing and doesn't really impact your shares strategy, so it is probably better discussed separately just to keep things focused. Most people have multiple user shares instead of putting everything under one user share. It is a lot more flexible that way since it lets you configure different user shares differently for different purposes. User shares just appear as folders on the network. Why do you think you want everything in one user share? And why do you not want disks 7,8 in user shares? You can keep them separate very easily just by making the appropriate user share settings. It is also possible to exclude certain disks from ANY user shares in Global Share Settings, but I really think it is better to just go with user shares and no disks. You shouldn't specify both include and exclude. Just do one or the other. Include means ONLY those disk, Exclude means EXCEPT for those disks. So there is no reason to specify both. Also, all user share settings only control how new files are written. Unraid won't move anything between array disks just because you change which disks a user share should use.
  6. 1 point
  7. 1 point
    Just the speed of the disk and link. UD doesn't crash. It is a WebUI to manage the mounting and unmounting of the drives and run scripts. This is an issue with USB and/or Linux. UD uses Linux to mount and manage the disk. In general, a USB connection is not the best for the disk load you are describing. You should use a sata or nvme disk.
  8. 1 point
    Worked like a charm! Thanks a bunch. There are those of us who really do appreciate all you guys do to support the community! Happy New Year my friend!
  9. 1 point
    yep thats your issue, so looks like krusder was initially installed as user 'root', group 'root' (or restored?) but your PUID is specifying user 'nobody' (id 99) and PGID is specifying group 'users' (id 100). so best thing to do is stop the container, then delete the file '/mnt/cache/appdata/binhex-krusader/perms.txt' then start the container, this will then set permissions correctly for the defined PUID and PGID you specified.
  10. 1 point
    For this to have any meaning you need to disable compression for the pool before testing, zeros are highly compressible.
  11. 1 point
    You will not be able to use RDP if you have the VM set to use virbr0 as that is NAT style that blocks incoming connections. The solution is typically to change to using a bridged connection (typically br0) so that the VM is visible on the local LAN. You do have to have enabled bridged networking under the Unraid network settings to have such a bridge available.
  12. 1 point
    This Solved the same issue i had ! thank you ! i have been racking my brain over this for hours sifting through config files. And here it was. One silly little line. Thanks. The weird part for me was that if i loaded something through the browser, the 10MB limit did not apply, i could upload any size i wanted. But, the IOS app and windows sync application would be spit of 413 errors for files larger than 10MB. Very odd that the browser ignored this limit. Maybe someone more versed in this can shed some light on that. Thought i'd share.
  13. 1 point
    I just wanted to update everyone on 1.0.0. I've taken some time over my holiday break to work on updating my Guacamole Docker with RC1. Thanks to the Guacamole team I've got a better build process. It looks like I'm going to be able to shave off about 120MB from the image size. I've also implemented a service manager and as a result I'm also able to not start the MariaDB service if you so choose. I'll also have an option to load just the MySQL extension so that you can use an external MySQL/MariaDB instance without the extra memory overhead in the current implementation. I have a few things to iron out but I think I should have 1.0.0-RC1 available for anyone to test in the next week or so.
  14. 1 point
    If you are confident that all your current drives are perfectly healthy, there is no reason not to set a new config and assign all the drives to the slots you want. As long as you don't accidentally assign a drive with data to a parity slot, all data will be preserved. When you start the array for the first time after assigning all the drives, unraid will prompt you to format all the blank drives. REVIEW THAT LIST CAREFULLY. If there are any of the drives that should have existing data on that list, DON'T SELECT THE FORMAT CHECKBOX. Post back here for further instructions.
  15. 1 point
  16. 1 point
    As you've found out, putting the backup onto the drive that you're backing up imposes a risk.
  17. 1 point
    I use a VPN, but I do not trust any commercial or private company. I build my own VPN servers on a VPS & as always if compared to the highly priced low quality commercial providers mine are very fast & reliable. The VPS I'm using has gigabit uplink, 2GB ram & 2 cores for the high price of 2.5 USD a month, while connected though my pfsense I also forward some ports.
  18. 1 point
    After it crosses the 2TB line it will speed up a lot. Probably be done in 18 hours or so.
  19. 1 point
    Are you saying it works now? via USB3.0 Flash device? Also motherboard/bios is important. Here's what's different in 6.4+ releases and why it might say module 'bonding' not available. In order to reduce the RAM footprint of the OS, we put all of the loadable modules (mainly drivers) used by the kernel into a 'squashfs' file system image file (vdisk) named 'bzmodules'. Early in system startup we loopback-mount this image file onto /lib/modules and this is where kernel looks for loadable modules it might need depending on h/w config. If the USB boot device does not get mounted, then the kernel cannot find loadable modules ('bonding' being one of them) and thus you see these kinds of errors.
  20. 1 point
    Solved File Upload Size Limitation I had been fiddling with the LSIO's letsencrypt container to make it work as a reverse proxy for LSIO's Nextcloud. The reverse proxy works, but file uploads are limited to 10MB. The solution is to edit the file proxy.conf which for me resides in /mnt/cache/appdata/letsencrypt_lsio/nginx. The first line in that file is: client_max_body_size 10m; Change to: client_max_body_size 0; #This turns off checking and everything works.