Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 01/17/19 in all areas

  1. 2 points
    Maybe 6.7.0 addresses the issue of impossible updates.
  2. 1 point
    Pulseway is a great tool that allows you to remotely monitor servers from iOS, Android, and the web. I mainly use it on iOS for the notifications about loss of network, high CPU usage or my server being shutdown. It was one of the few things I missed when I switched my server to unRAID. Luckily, I figured out how to get it installed and working. Here's the steps I took: 1. Download the Pulseway Agent for Slackware from Pulseway's website 2. Copy the pulseway_x64.txz to /boot/extra (this is also the flash smb share so flash/extra) 3. Create a new folder,pulseway, in the /boot directory 4. Reboot unRAID 5. SSH into server and copy config.xml.sample to config.xml: cp /etc/pulseway/config.xml.sample /etc/pulseway/config.xml 6. Edit the config.xml file you just copied, you'll need to add your Pulseway username/password and setup any notifications you want to receive (change the Enabled flag from False to True). I enabled Network interface monitoring (change interface name to br0) as well as WhenOffline, HighCpuUsage and MemoryLow notifications. 7. Pulseway needs to be run to verify your config file works and to generate an id file. The Pulseway service looks for version 0.9.8 of libssl and libcrypto, unRAID includes version 1.0.0 so we need to create symlinks to the 1.0.0 files to trick Pulseway into using those: ln -s /lib64/libssl.so.1.0.0 /usr/lib64/libssl.so.0.9.8 ln -s /lib64/libcrypto.so.1.0.0 /usr/lib64/libcrypto.so.0.9.8 8. Start Pulseway service: /etc/rc.d/rc.pulseway start 9. Copy the id file generated by Pulseway to the /boot/pulseway directory (if you don't do this, the server will show up as a new machine in Pulseway every time unRAID boots): cp /var/pulseway/pulseway.id /boot/pulseway/pulseway.id 10. Copy your config file to /boot/pulseway cp /etc/pulseway/config.xml /boot/pulseway/config.xml 11. Add the following lines to /boot/config/go cp /boot/pulseway/config.xml /etc/pulseway/config.xml cp /boot/pulseway/pulseway.id /var/pulseway/pulseway.id ln -s /lib64/libssl.so.1.0.0 /usr/lib64/libssl.so.0.9.8 ln -s /lib64/libcrypto.so.1.0.0 /usr/lib64/libcrypto.so.0.9.8 # As of version 6.6, you also need one for libidn ln -s /usr/lib64/libidn.so.12 /usr/lib64/libidn.so.11 /etc/rc.d/rc.pulseway start 12. Reboot unRAID and make sure everything works! Explanation: unRAID's OS is stored in RAM so any changes you make do not persist after a reboot/shutdown. That's why we need to move everything to the /boot drive (the flash drive unRAID boots from). On startup, we're installing Pulseway, creating symlinks to libraries it needs, copying the config and id files to their respective locations and then starting the service. EDIT (9/26/2018): As of version 6.6, you also need to create a symlink for libidn like so: ln -s /usr/lib64/libidn.so.12 /usr/lib64/libidn.so.11
  3. 1 point
    Hi, I've been a user since version 3 or 4, a convert from windows home server. I currently have an i7 with 16gb ram sitting in an asus z170. 9207-8i controller running 6 x WD Red 6tb data drives Twin SSD's on the MB Controller as btrfs cache Twin WD Red 6tb Parity drives on the MB controller - average parity check speed is 109mb/s Intel i350-T2 NIC all sitting in a 4u rackmount with hot swap bays etc I am really happy with this, it's been rock solid. But my question is, if I was going to upgrade it to get better raw transfer performance - would the next level be enterprise class drives? WD Gold's? Or would I need to goto full enterprise level sas drives and better controllers? This is just for my planning, I started out with an old celeron with Samsung F1 750gb's and have been slowly upgrading as parts died - I am really impressed with how well unraid handles motherboard changes etc thanks for taking the time to read.
  4. 1 point
    You need to install the dynamix Schedules plugin to be able to adjust the Daily/Weekly/Monthly times
  5. 1 point
    The built-in schedules can be seen and adjusted at Settings - Scheduler - Fixed Schedules
  6. 1 point
    Have you tried signing out of plex and signing in again? That usually works for me.
  7. 1 point
    I found and fixed the unRAID SMBv1 access issue via this article: https://www.techcrumble.net/2018/03/you-cant-access-this-shared-folder-because-your-organizations-security-policies-block-unauthenticated-guest-access/ I had followed BobPhoenix's enable "SMB 1.0/CIFS File Sharing Support", also updated my hosts file per your earlier suggestion, the step in the linked article was the last step I needed. It's a Win 10 "rookie mistake" by me. (I'm new to Win 10.) Thanks for your help Frank and LT team!
  8. 1 point
    I had a BTRFS error on my cache pool so i hade to format. I backed up my app data with this guide but something went wrong and I was not able to save the docker images. I set up my docker when I installed Unraid a long time ago and managed to set the docker image to rest on a share that i named "Docker". This (at least i think) resulted in the docker programs acting up. Radarr isn't finding any media, can't Unifi Controller loses it's config. Reading the guide for setting up Docker and of course, the recommendation is to set the Docker image directly to the Cache device. Can I move the Docker image to the cache drive with midnight commander or some other way without loosing the docker apps?
  9. 1 point
  10. 1 point
    simple, you shutdown the container running privoxy, then go to jackett web ui, click on the "test all" button, if any pass then jackett does not honour the proxy being set, if they all fail then all is good :-).
  11. 1 point
    So that was the issue! Now you can see proper connection! Awesome! now the fun begins to change all my stuff over to the custom docker network which I am not even sure some of the stuff I run behind proxy can be set to a custom bridge that it must stay as a host! but at least I know what the fix is! I've actually had the custom docker network setup before but must have never fully implemented it! Now I understand about the proper dns resolution between the containers. Never realized by default the bridge didn't do it. Thank You for pointing me in the right direction!
  12. 1 point
    interesting!, so i can confirm the built in proxy configuration for jackett (as in through the web ui) works for me when pointing at privoxy, HOWEVER i have never attempted having an indexer (such as radarr) targeting privoxy AND also having jackett pointing at privoxy so that may well be problematic. it would be interesting to see if pointing the container at privoxy (as per your suggestion @tjb_altf4 ) does indeed fix this scenario, although i wouldn't be overly keen including this in the template, as its more of a generic 'fix' that could be applied to any/all images, but i def would include it in the faq if found to work.
  13. 1 point
    I don't personally use ZFS, but I'm going to put these links here as some of you guys might be interested. Greg KH has given a statement on ZFS in the v5 kernels which I suspect (although have no absolute proof) is what Unraid v6.7.0 will be using. https://www.phoronix.com/scan.php?page=news_item&px=ZFS-On-Linux-5.0-Problem https://github.com/zfsonlinux/zfs/issues/8259
  14. 1 point
  15. 1 point
    It definitely works. Probably a bit slower due to the need to download the file, but I do my syncs in the background so I never notice and the biggest delay for me is copying to my tablet. I've gone almost all in this month and I'm uploading all my non-4k content and a good chunk of the 4k as well. It's been working well for me for over six months and after seeing some absolutely massive plex libraries setup like this, I'm not worried.
  16. 1 point
    I rclone everything i want to gdrive (unlimited storage for ~8€ a month) Currently i have 4,1TB uploaded. I use these scripts, more or less, slightly changed:
  17. 1 point
  18. 1 point
    For my own notes for when i look back at this:- The above turned out to be somewhat not exactly true 🙂 the issue had now become trying to connect to an endpoint that didnt support port forwarding with STRICT_PORT_FORWARD set to 'yes', im sure the inital issue WAS authentication though.
  19. 1 point
    ETA? Because you know, we are OCD and that 'Update available' button does tend to bother us...
  20. 1 point
    The price of Pro is so cheap I'm surprised anyone purchases less.
  21. 1 point
    Add another digit to that and maybe viable. Interesting idea... thanks!
  22. 1 point
    Apache Guacamole 1.0.0 is finalized. New images are pushed out. New image for a version without MariaDB (jasonbean/guacamole:latest-nomariadb). See first post for details.
  23. 1 point
    Wow, This was a great read. Just wanted to say thank you for the info provided from everyone.
  24. 1 point
    I have one server that, although it isn't encrypted, may be an example of a work around for you. You will need: Dynamic DNS for the router (or know the WAN IP). This can be done in the router (usually). A local user (other than root) on the server setup with SSH access. (I recommend the SSH and denyhosts plugins by docgyver) Setup port forwarding on the router to forward SSH to the unRaid server. Using SSH tunnels and port forwarding on the router, I run ssh mysuser@mydynamic.host.com -CL 8080:localhost:80 -p 2020 from my remote location. Breaking this down: I have the router forward the external port 2020 to the internal port 22 of the unRaid server's IP. In the example above, mydynamic.host.com is a Dynamic DNS name of the router so outside machines can talk to the router. It could also be the WAN IP of the router. 'C' tells ssh to use compression (why not). 'L' tells ssh to tunnel the local machines port 8080 to localhost (from the point of view of the unRiad server) on port 80. You would need to change this port to the HTTPS port if you have a SSL cert setup. Once the connection is working, on my computer I open a browser to localhost and port 8080 (https://localhost:8080 if using SSL on the unRaid server.) Then I can start the array as usual in the browser. NB: the localhost you put in the local browser is from the point of view of your machine you are connecting from. I won't go into ssh tunnels here; there's plenty of info about that on the internet. You also may be interested in this video (https://www.youtube.com/watch?v=TSlHEBR1yfY ) showing how to automatically download the password file for the encrypted disks. I haven't tried it.
  25. 1 point
    WiFi is quite often fast enough, which is why lots of media players can be run over WiFi. And it allows a backup server to be placed in a room that doesn't have wired networking. The important thing is that different users have different usage cases and different needs.