Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 03/26/19 in all areas

  1. 2 points
    PSA. It seems openvpn pushed another broken bin, tagged 2.7.3 I get the same error with it as I did with the previously pulled 2.7.2 While they/us try to figure it out, you can change your image to "linuxserver/openvpn-as:2.6.1-ls11" and it should work
  2. 1 point
    Plugin Name: Unraid Nvidia Github: https://github.com/linuxserver/Unraid-Nvidia-Plugin This plugin from LinuxServer.io allows you to easily install a modified Unraid version with Nvidia drivers compiled and the docker system modified to use an nvidia container runtime, meaning you can use your GPU in any container you wish. Any posts discussing circumvention of any Nvidia restrictions we will be asking mods to remove. We have worked hard to bring this work to you, and we don't want to upset Nvidia. If they were to threaten us with any legal action, all our source code and this plugin will be removed. Remember we are all volunteers, with regular jobs and families to support. Please if you see anyone else mentioning anything that contravenes this rule, flag it up to the mods. People that discuss this here could potentially ruin it for all of you. EDIT: 25/5/19 OK everyone, the Plex script seems to be causing more issues than the Unraid Nvidia build as far as I can tell. From this point on, to reduce the unnecessary noise and confusion on this thread, I'm going to request whoever is looking after, documenting or willing to support the Plex scripts spins off their own thread. We will only be answering any support questions on people not using the script. If your post is regarding Plex and you do not EXPLICITLY state that you are not using the Plex script then it will be ignored. I know some of you may think this is unreasonable but it's creating a lot of additional work/time commitments for something I never intended to support and something I don't use (Not being a Plex user) May I suggest respectfully, that one of you steps forward to create a thread, document it, and support it in it's own support place. I think we need to decouple issues with the work we've done versus issues with a currently unsupported script. Thanks.
  3. 1 point
    On boot the plugin runs this command. nvidia-smi --query-gpu=gpu_name,gpu_bus_id,gpu_uuid --format=csv,noheader | sed -e s/00000000://g | sed 's/\,\ /\n/g' > /tmp/nvidia and outputs to a file /tmp/nvidia When you go to the plugin page it reads the contents of that file to get the GPU info. cat /tmp/nvidia I can't tell you why your copy of that file is getting deleted, but that's what I would bet is causing it. Try running the above command and see what the output is, both from a fresh boot and after the problem occurs. My guess is you have some cleanup script or process that is deleting stuff from /tmp
  4. 1 point
    RC6 has samba 4.9.5 Problem should be solved.
  5. 1 point
    https://twitter.com/JustinAiken is following you.
  6. 1 point
    You have a new follower, me, @hpka on Twitter
  7. 1 point
    yep see Q12 from the following link:- https://forums.unraid.net/topic/44108-support-binhex-general/?do=FindComment&comment=433612
  8. 1 point
    now complete, new image is built which should now alter an existing nginx.conf and add in the basic auth to the /rpc2 location, if its already secure it will skip this, new users will get this set by default.
  9. 1 point
    I have actually considered building a 16 core Threadripper for my unraid server. I am still maxing out my CPU. I am running a i7 4790k with 4 cores with HyperThreading. In side my house I have a TheaterRoom with 4k UHD Setup. All my action and Marvell movies I have in full 4K content at about 60gb per mkv. Most of these I can direct stream with the Nvidia Shield. However I have all of my family and friends that stream from me as well. My kids aren't with me half of the time and when they are away they stream from me. During a busy time I can have 4-6 people outside of my house streaming from my Plex server. Most of the content is transcoded as most of them don't have great clients and don't support direct play. Also I use a HomeRun TV box setup in my plex server that does live TV and DVR service. So my Unraid server runs all these Dockers for me. I have assigned each docker to CPU's so that Plex is on it's own CPU cores. I don't think the problem is with my NIC's anylong. As long as the data is being written to the Cache drive first everything is smooth. As soon as the Cache drive starts moving data to the array is when everthing stops. Hope that makes sense. I have attached a new diag file. medianas-diagnostics-20190326-1425.zip
  10. 1 point
    Yes, with the caveat that if it wears thin and allows contact either by insertion friction or vibration you may end up with a non-spinning drive at a very awkward time. Also, if the coating is too thick, you may end up damaging the SATA power cable or port. Kapton is the clear winner, as it's practically designed for this type of application. Other insulating solutions would work, but you need to be mindful of the downsides. Another alternative is to disconnect the pad from the trace, but that's risky if you aren't super careful with your abrasive method. Clipping the pin out of the SATA power cable is another risky method. Any solution that keeps power off of that pin will technically work, your choice.
  11. 1 point
    If the BIOS doesn't see the drive, there is no way unRAID will see it. Do you have any other drives attached to the controller? I have several 8TB drives shucked from Easystore enclosures and they are attached to a Dell H310 in IT mode. All show up fine in unRAID. Is it by chance a white label drive? If so, it could be the SATA 3.3v reset issue that is causing it to not be recognized. Recent white label drives tend to have that "feature." All of my shucked drives work fine in my server because my hot-swap drive cages are powered by molex connectors which bypass the SATA reset problem. USB connections will do the same. If you only have the problem when they are connected with SATA power, this may be your problem. Some strategically placed Kapton tape on the drive SATA power connector will solve the problem if this is the issue. See here for details.
  12. 1 point
    You just need to boot with a dos flashdrive (or use any Windows PC if more convenient), copy the LSI firmware package, and run: sas2flsh -o -e 5 for dos sas2flash -o -e 5 for Windows
  13. 1 point
    Hello, Last night everything was working perfectly fine, however since this morning I seem to be unable to login. I am running Ombi behind a reverse proxy and am using a DuckDNS domain to access it. As mentioned, everything was working flawlessly before this morning. I am unaware of any changes performed on the container (currently not at my place and I do not have access to the unRAID webUI). Maybe Ombi updated itself causing this issue? Anyhow, I can still access the domain, and when I enter an incorrect username/password I get an error. However, upon entering correct credentials nothing happens. I looked through console and found that token/ seems to be causing an error: " SQLite Error 5: 'database is locked' ". Plex is still accessible through duckDNS domains btw. Any tips on fixing this?
  14. 1 point
    It was just pure deduction. All of the reporting tools were saying it was fine. But it kept having issues which meant I had to look into it further. In the end, it was manually testing the device that allowed me to narrow it down to a point I could make the ssd fail 100% of the time under one of my test conditions. At that point it doesn't matter what the SMART says, I can reproduce a failure at will with something that within it's specs, proving the device was faulty. Hardware failure can be tricky. Not everything is going to be easily visible as a concrete red line somewhere. There will be times you have to just test for things yourself to try and figure it out.
  15. 1 point
    Read this first 1. Any posts discussing circumvention of any Nvidia restrictions we will be asking mods to remove. We have worked hard to bring this work to you, and we don't want to upset Nvidia. If they were to threaten us with any legal action, all our source code and this plugin will be removed. Remember we are all volunteers, with regular jobs and families to support. Please if you see anyone else mentioning anything that contravenes this rule, flag it up to the mods. People that discuss this here could potentially ruin it for all of you! 2. If you attempt to start a VM passing through a GPU that is actively transcoding, you will hard lock your server and it will need an unclean shutdown. 3. If you use Unraid in GUI mode and have only a single GPU in your server and you use that GPU in a virtual machine, trying to start that VM will crash libvirt. 4. You can passthrough a GPU that is being passed through to a docker container as long as when you start that VM there is no active transcode processes happening, the docker container will fallback to software transcoding. Check the webui of the docker container to check if transcoding is occurring before starting the VM, or if your GPU supports it, you can use watch nvidia-smi to check for transcoding processes. 5. To be 100% safe, we recommend a dedicated GPU for transcoding that is not being used for any virtual machines, if you decide to ignore this, then you're on your own, we are not responsible for any problems that ensue. 6. We will produce one Nvidia build per Unraid release, we will not be updating the drivers multiple times for each Unraid version, unless there is a critical bug that demands this. So please don't ask. 7. We are reliant on a lot of upstream projects here, we don't have any control over them, so we can't guarantee this will work for every release. 8. We will look at a DVB solution in the future. Once we know this is stable and working. Background Unraid Nvidia is a way of leveraging a Nvidia graphics card in your Unraid server to offload transcoding from the CPU to your GPU. Although people have long been asking for Nvidia drivers on Unraid, there seems to have been a lack of understanding that this wouldn't solve a fundamental problem. It would mean that only processes run on the host would be able to use them, they wouldn't be useful within docker containers unless the same drivers were then installed within each container, which is both inefficient and requires a special build of every container you wish to use Nvidia within. We began to look at a possible solution about 5 months ago and it has required a number of different steps to get this working. 1. Installing Nvidia drivers and kernel modules into Unraid utilising upstream SlackBuild packages, namely nvidia-kernel, nvidia-driver, google-go-lang, libseccomp & runc. Modifying a part of the nvidia-driver due to the lack of a desktop environment on Unraid. 2. Modifying the docker runtime to a version that can use an Nvidia wrapper to enable any docker container on your system to use the Nvidia graphics card using the Nvidia docker project. 3. Rolling all this together and completely repackaging Unraid to implement all these changes, only bzroot-gui is left unaltered. 4. Development of a plugin to enable easy downloading of the modified Nvidia release of Unraid. All in all, not a simple task. Initial attempts by @CHBMB were hindered by segfaults, at which point, his real life commitments took over and the project hit a hiatus, @bass_rock then forked the work and hit the same issue. After reaching out bass_rock we invited him to join the LinuxServer.io team to collaborate and to try one final strategy we had in mind to get this working, but hadn't got around to. This strategy was instead of installing the drivers at boot time from a custom built Slackware package, taking the approach at build time of unpackaging bzroot and installing the drivers directly there, removing the need for an install at boot time and to our delight solving the segfault issue. Enthusiastically bass_rock implemented this and also made the original scripts nothing short of a work of art, adding shine and polish.
  16. 1 point
    Since not one else has jumped in, I will try to get you started. First thing, is how old is this UPS. (APC model numbers are virtually useless as when I google using one, I always get several obviously different units from a physical package standpoint!) I seem to recall that both older and newer APC UPS's have separate issues. Not all models, but enough to make life really difficult in solving problems. If you look in the upper right hand corner of the screen capture, you will find a link to the Online Manual. Be sure to use it. A quick glance at it showed that there are two settings that you could try in the "UPS type" 'dropdown' box--- 'APCsmart' and 'ModBus' . The 'ModBus' one is for some of the newer units. Be sure to click the "Help' on in the GUI as it will provide a lot of help in what each setting does!!! Remember that Google is often your best friend in these types of problems. If you use unraid as one of the terms in the search bar, you will find that it will do a much better job of searching this forum than the built-in search engine.