Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 05/14/19 in all areas

  1. 2 points
    Yes we're watching this and waiting for the microcode release. Interesting comment from Greg K-H: Doesn't exactly give you the "warm and fuzzies" right? Then again, could be worse: think of the headaches over at Intel 🤣
  2. 1 point
    Plugin Name: Unraid Nvidia Github: https://github.com/linuxserver/Unraid-Nvidia-Plugin This plugin from LinuxServer.io allows you to easily install a modified Unraid version with Nvidia drivers compiled and the docker system modified to use an nvidia container runtime, meaning you can use your GPU in any container you wish. Any posts discussing circumvention of any Nvidia restrictions we will be asking mods to remove. We have worked hard to bring this work to you, and we don't want to upset Nvidia. If they were to threaten us with any legal action, all our source code and this plugin will be removed. Remember we are all volunteers, with regular jobs and families to support. Please if you see anyone else mentioning anything that contravenes this rule, flag it up to the mods. People that discuss this here could potentially ruin it for all of you. EDIT: 25/5/19 OK everyone, the Plex script seems to be causing more issues than the Unraid Nvidia build as far as I can tell. From this point on, to reduce the unnecessary noise and confusion on this thread, I'm going to request whoever is looking after, documenting or willing to support the Plex scripts spins off their own thread. We will only be answering any support questions on people not using the script. If your post is regarding Plex and you do not EXPLICITLY state that you are not using the Plex script then it will be ignored. I know some of you may think this is unreasonable but it's creating a lot of additional work/time commitments for something I never intended to support and something I don't use (Not being a Plex user) May I suggest respectfully, that one of you steps forward to create a thread, document it, and support it in it's own support place. I think we need to decouple issues with the work we've done versus issues with a currently unsupported script. Thanks.
  3. 1 point
    Summary: Support Thread for ich777 Gameserver Dockers (CounterStrike: Source & ConterStrike: GO, TeamFortress 2, ArmA III,... - complete list in the second post) Application: SteamCMD DockerHub: https://hub.docker.com/r/ich777/steamcmd All dockers are easy to set up and are highly customizable, all dockers are tested with the standard configuration (port forwarding,...) if the are reachable and show up in the server list form the "outside". The standard password for the gameservers if enabled is: Docker Please read the discription of each docker and the variables that you install (some dockers need special variables to run).
  4. 1 point
    To upgrade: If you are running any 6.4 or later release, click 'Check for Updates' on the Tools/Update OS page. If you are running a pre-6.4 release, click 'Check for Updates' on the Plugins page. If the above doesn't work, navigate to Plugins/Install Plugin, select/copy/paste this plugin URL and click Install: https://s3.amazonaws.com/dnld.lime-technology.com/stable/unRAIDServer.plg Refer also to @ljm42 excellent 6.4 Update Notes which are helpful especially if you are upgrading from a pre-6.4 release. Bugs: If you discover a bug or other issue in this release, please open a Stable Releases Bug Report. New in Unraid OS 6.7 release: New Dashboard layout, along with new Settings and Tools icons. Designed by user @Mex and implemented in collaboration with @bonienl. We think you will find this is a big step forward. Time Machine support via SMB. To enable this feature it is necessary to first turn on "Enhanced OS X interoperability" on the Settings/SMB page. Next, select a share to Export for Time Machine in the share SMB Security Settings section. Note: AFP is now deprecated and macOS users are encouraged to use SMB only. Enhanced syslog handling. On Settings/Network Services page click on Syslog Server. Here you can designate this server to receive system logs from other Unraid OS servers, or forward this servers syslog to another local or remote server. Parity sync/Data rebuild/Check pause/resume capability. Main functionality in place. Pause/resume not preserved across system restarts yet however. Linux kernel 4.19. This is the latest Long Term Support kernel. Here are some other kernel-related updates: Added TCP "BBR Congestion control" and made it the default. This should improve network throughput but probably not too many users will notice anything different. Added Bluetooth support in the Linux kernel. We did not add the user-space tools so this will be mostly useful to support Bluetooth in docker containers. AMD firmware update for Threadripper. Ignore case in validating user share names. If there are multiple top-level directories which differ only in case, then we use the first such share name encountered, checking in order: cache, disk1, disk2, ..., diskN. Additional top-level directories encountered will be ignored. For example, suppose we have: /mnt/cache/ashare /mnt/disk1/Ashare /mnt/disk2/ashare The name of the exported share will be 'ashare' and will consist of a union of /mnt/cache/ashare and /mnt/disk2/ashare. The contents of /mnt/disk1/Ashare will not appear in /mnt/user/ashare. If you then delete the contents of /mnt/user/ashare followed by deleting the 'ashare' share itself, this will result in share 'Ashare' becoming visible. Similar, if you delete the contents of /mnt/cache/ashare (or gets moved), then you will now see share 'Ashare' appear, and it will look like the contents of 'ashare' are missing! Thankfully very few (if any) users should be affected by this, but handles a corner case in both the presentation of shares in windows networking and storage of share config data on the USB flash boot device. New vfio-bind method. Since it appears that the xen-pciback/pciback kernel options no longer work, we introduced an alternate method of binding, by ID, selected PCI devices to the vfio-pci driver. This is accomplished by specifying the PCI ID(s) of devices to bind to vfio-pci in the file 'config/vfio-pci.cfg' on the USB flash boot device. This file should contain a single line that defines the devices: BIND=<device> <device> ... Where <device> is a Domain:Bus:Device.Function string, for example, BIND=02:00.0 Multiple device should be separated with spaces. The script /usr/local/sbin/vfio-pci is called very early in system start-up, right after the USB flash boot device is mounted but before any kernel modules (drivers) have been loaded. The function of the script is to bind each specified device to the vfio-pci driver, which makes them available for assignment to a virtual machine, and also prevents the Linux kernel from automatically binding them to any present host driver. In addition, and importantly, this script will bind not only the specified device(s), but all other devices in the same IOMMU group as well. For example, suppose there is an NVIDIA GPU which defines both a VGA device at 02:00.0 and an audio device at 02.00.1. Specifying a single device (either one) on the BIND line is sufficient to bind both device to vfio-pci. The implication is that either all devices of an IOMMU group are bound to vfio-pci or none of them are. Other highlights: Added the '--allow-discards' option to LUKS open. This should only have any effect when using encrypted Cache device/pool with SSD devices. It allows a file system to notice if underlying device supports TRIM and if so, passes TRIM commands down. Added 'telegram' notification agent support - thank you @realies Updated several base packages, including move to Samba 4.9 and docker 18.09. Fixed a number of minor bugs. Finally: as always, a big "Thank You!" to everyone who contributed and helped with testing. Version 6.7.0 2019-05-08 Base distro: aaa_elflibs: version 15.0 (rev 3) acpid: version 2.0.31 adwaita-icon-theme: version 3.32.0 at-spi2-atk: version 2.32.0 at-spi2-core: version 2.32.1 at: version 3.1.23 atk: version 2.32.0 bash: version 5.0.007 bin: version 11.1 (rev 3) bluez: version 4.101 bridge-utils: version 1.6 btrfs-progs: version v4.19.1 ca-certificates: version 20190308 cairo: version 1.16.0 cifs-utils: version 6.9 coreutils: version 8.31 curl: version 7.64.1 (CVE-2019-8907, CVE-2019-3822, CVE-2019-3823) cyrus-sasl: version 2.1.27 dbus: version 1.12.12 dhcpcd: version 7.2.0 diffutils: version 3.7 dmidecode: version 3.2 dnsmasq: version 2.80 docker: version 18.09.5 (CVE-2019-5736) e2fsprogs: version 1.45.0 etc: version 15.0 (rev 9) ethtool: version 5.0 file: version 5.36 (CVE-2019-8906, CVE-2019-8907) findutils: version 4.6.0 freetype: version 2.10.0 fribidi: version 1.0.5 gdbm: version 1.18.1 gdk-pixbuf2: version 2.38.0 git: version 2.21.0 glib2: version 2.60.1 glibc-solibs: version 2.29 glibc-zoneinfo: version 2019a glibc: version 2.29 gnutls: version 3.6.7 (CVE-2018-16868) gptfdisk: version 1.0.4 graphite2: version 1.3.13 grep: version 3.3 gtk+3: version 3.24.8 gzip: version 1.10 harfbuzz: version 2.4.0 haveged: version 1.9.4 hdparm: version 9.58 hostname: version 3.21 hwloc: version 1.11.11 icu4c: version 64.2 infozip: version 6.0 (CVE-2014-8139, CVE-2014-8140, CVE-2014-8141, CVE-2016-9844, CVE-2018-18384, CVE-2018-1000035) inotify-tools: version 3.20.1 intel-microcode: version 20180807a iproute2: version 5.0.0 iptables: version 1.8.2 iputils: version 20190324 irqbalance: version 1.5.0 jansson: version 2.12 jemalloc: version 4.5.0 jq: version 1.6 (rev2) kernel-firmware: version 20190424_4b6cf2b keyutils: version 1.6 kmod: version 26 libSM: version 1.2.3 libX11: version 1.6.7 libXcomposite: version 0.4.5 libXcursor: version 1.2.0 libXdamage: version 1.1.5 libXdmcp: version 1.1.3 libXext: version 1.3.4 libXft: version 2.3.3 libXmu: version 1.1.3 libXrandr: version 1.5.2 libXxf86dga: version 1.1.5 libaio: version 0.3.112 libarchive: version 3.3.3 libcap-ng: version 0.7.9 libcap: version 2.27 libcroco: version 0.6.13 libdrm: version 2.4.98 libedit: version 20190324_3.1 libepoxy: version 1.5.3 libestr: version 0.1.11 libevdev: version 1.6.0 libgcrypt: version 1.8.4 libgpg-error: version 1.36 libjpeg-turbo: version 2.0.2 libnftnl: version 1.1.2 libpcap: version 1.9.0 libpng: version 1.6.37 (CVE-2018-14048 CVE-2018-14550 CVE-2019-7317) libpsl: version 0.21.0 libpthread-stubs: version 0.4 (rev 3) librsvg: version 2.44.11 libssh2: version 1.8.2 (CVE-2019-3855, CVE-2019-3856, CVE-2019-3857, CVE-2019-3858, CVE-2019-3859, CVE-2019-3860, CVE-2019-3861, CVE-2019-3862, CVE-2019-3863) libtirpc: version 1.1.4 libvirt: version 5.1.0 libwebp: version 1.0.2 libwebsockets: version 3.1.0 libxcb: version 1.13.1 libxkbfile: version 1.1.0 libxml2: version 2.9.9 libxslt: version 1.1.33 libzip: version 1.5.2 lm_sensors: version 3.5.0 logrotate: version 3.15.0 lsscsi: version 0.30 lvm2: version 2.03.02 lz4: version 1.8.3 lzip: version 1.21 mc: version 4.8.22 mcelog: version 162 mesa: version 18.3.0 miniupnpc version: 2.1 mkfontscale: version 1.2.1 mozilla-firefox: version 66.0 (CVE-2018-18500, CVE-2018-18504, CVE-2018-18505, CVE-2018-18503, CVE-2018-18506, CVE-2018-18502, CVE-2018-18501, CVE-2018-18356, CVE-2019-5785, CVE-2018-18511, CVE-2019-9790, CVE-2019-9791, CVE-2019-9792, CVE-2019-9793, CVE-2019-9794, CVE-2019-9795, CVE-2019-9796, CVE-2019-9797, CVE-2019-9798, CVE-2019-9799, CVE-2019-9801, CVE-2019-9802, CVE-2019-9803, CVE-2019-9804, CVE-2019-9805, CVE-2019-9806, CVE-2019-9807, CVE-2019-9809, CVE-2019-9808, CVE-2019-9789, CVE-2019-9788) mpfr: version 4.0.2 nano: version 4.2 ncompress: version 4.2.4.5 ncurses: version 6.1_20190420 netatalk: version 3.1.12 (CVE-2018-1160) nettle: version 3.4.1 (CVE-2018-16869) nghttp2: version 1.38.0 nginx: version 1.14.2 (+ nchan 1.2.3) (CVE-2018-16843, CVE-2018-16844, CVE-2018-16845) ntp: version 4.2.8p13 (CVE-2019-8936) oniguruma: version 6.9.1 (CVE-2017-9224, CVE-2017-9225, CVE-2017-9226, CVE-2017-9227, CVE-2017-9228, CVE-2017-9229) openldap-client: version 2.4.47 openssh: version 8.0p1 openssl-solibs: version 1.1.1b (CVE-2019-1559) openssl: version 1.1.1b (CVE-2019-1559) p11-kit: version 0.23.15 pciutils: version 3.6.2 pcre2: version 10.33 pcre: version 8.43 php: version 7.2.18 (CVE-2019-11034, CVE-2019-11035, CVE-2019-11036) pixman: version 0.38.4 pkgtools: version 15.0 (rev 23) pv: version 1.6.6 qemu: version 3.1.0 (rev 2) patched pcie link speed and width support rpcbind: version 1.2.5 rsyslog: version 8.40.0 samba: version 4.9.7 (CVE-2018-14629, CVE-2018-16841, CVE-2018-16851, CVE-2018-16852, CVE-2018-16853, CVE-2018-16857) sdparm: version 1.10 sed: version 4.7 sg3_utils: version 1.44 shadow: version 4.6 shared-mime-info: version 1.12 smartmontools: version 7.0 spice-protocol: version 0.12.14 spice: version 0.14.1 sqlite: version 3.28.0 sudo: version 1.8.27 sysvinit-scripts: version 2.1 (rev 26) sysvinit: version 2.94 talloc: version 2.2.0 tar: version 1.32 tdb: version 1.4.0 tevent: version 0.10.0 tree: version 1.8.0 ttyd: version 1.4.2 ttyd: version 20190223 util-linux: version 2.33.2 wget: version 1.20.3 (CVE-2019-5953) xauth: version 1.0.10 (rev 3) xfsprogs: version 4.20.0 xkeyboard-config: version 2.25 xprop: version 1.2.4 xterm: version 341 xtrans: version 1.4.0 zstd: version 1.4.0 Linux kernel: version: 4.19.41 added drivers: CONFIG_USB_SERIAL_CH341: USB Winchiphead CH341 Single Port Serial Driver CONFIG_X86_MCELOG_LEGACY: Support for deprecated /dev/mcelog character device added TCP BBR congestion control kernel support and set as default: CONFIG_NET_KEY: PF_KEY sockets CONFIG_TCP_CONG_BBR: BBR TCP CONFIG_NET_SCH_FQ: Fair Queue CONFIG_NET_SCH_FQ_CODEL: Fair Queue Controlled Delay AQM (FQ_CODEL) added Bluetooth kernel support: CONFIG_BT: Bluetooth subsystem support CONFIG_BT_BREDR: Bluetooth Classic (BR/EDR) features CONFIG_BT_RFCOMM: RFCOMM protocol support CONFIG_BT_RFCOMM_TTY: RFCOMM TTY support CONFIG_BT_BNEP: BNEP protocol support CONFIG_BT_BNEP_MC_FILTER: Multicast filter support CONFIG_BT_BNEP_PROTO_FILTER: Protocol filter support CONFIG_BT_HIDP: HIDP protocol support CONFIG_BT_HS: Bluetooth High Speed (HS) features CONFIG_BT_LE: Bluetooth Low Energy (LE) features CONFIG_BT_HCIBTUSB: HCI USB driver CONFIG_BT_HCIBTUSB_AUTOSUSPEND: Enable USB autosuspend for Bluetooth USB devices by default CONFIG_BT_HCIBTUSB_BCM: Broadcom protocol support CONFIG_BT_HCIBTUSB_RTL: Realtek protocol support CONFIG_BT_HCIUART: HCI UART driver CONFIG_BT_HCIUART_H4: UART (H4) protocol support CONFIG_BT_HCIUART_BCSP: BCSP protocol support CONFIG_BT_HCIUART_ATH3K: Atheros AR300x serial support CONFIG_BT_HCIUART_AG6XX: Intel AG6XX protocol support CONFIG_BT_HCIUART_MRVL: Marvell protocol support CONFIG_BT_HCIBCM203X: HCI BCM203x USB driver CONFIG_BT_HCIBPA10X: HCI BPA10x USB driver CONFIG_BT_HCIVHCI: HCI VHCI (Virtual HCI device) driver CONFIG_BT_MRVL: Marvell Bluetooth driver support CONFIG_BT_ATH3K: Atheros firmware download driver firmware: added BCM20702A0-0a5c-21e8.hcd added BCM20702A1-0a5c-21e8.hcd md/unraid: version 2.9.7: setup queue properties correctly support sync pause/resume fix: kernel BUG if read phase of read/modify/write with FUA flag set fails on stripe with multiple read failures OOT Intel 10Gbps network driver: ixgbe: version 5.5.5 OOT Tehuti 10Gbps network driver: tn40xx: version 0.3.6.17 patch: support Mozart 395S chip patch: hpsa: change scsi_host_template.max_sectors from 2048 to 1024 per request Management: add early vfio-bind utility restore PHP E_WARNING in /etc/php/php.ini support Apple Time Machine via SMB acpi: silence undefined ACPI event logging docker: preserve container fixed IPv4 and IPv6 addresses across reboot/docker restart emhttp: bug fix: cache-only/cache-prefer share not initially created on cache emhttp: ignore *.key files that begin with "._" emhttp: properly dismiss "Restarting services" message emhttp: use mkfs.btrfs defaults for metadata and SSD support emhttpd: Add --allow-discard luksOpen option emhttpd: Increase number of queued inotify IN_MOVED_TO events from 16 to 1024 for /var/local/emhttp directory. fix: docker log rotation fix: inconsistent share name case fix: terminal instances limited to 8 (now lifted) fstab: mount USB flash boot device with 'flush' keyword networking: pass user-specified MAC address through to bridge rc.nginx: eliminate unnecessary 10 sec delays rc.nginx: implement better status wait loop - thanks ljm42 rc.sshd: only copy new key files to USB flash boot device smartmontools: update drivedb and hwdata/{pci.ids,usb.ids,oui.txt,manuf.txt} smb: when Enhanced OS X interoperability set, include "fruit:nfs_aces = no" to be compatible with Unraid security model smb: disable samba auto-register with avahi for now webgui: Add GameServers to category for docker containers webgui: Add log-size and log-file options to docker run command webgui: Added new font icons webgui: Added parity pause/resume button webgui: Added syslog server functionality webgui: Allow optional notifications on background docker update checks webgui: Allow plugins to use font awesome for icon webgui: Dashboard: add settings shortcuts webgui: Dashboard: added control buttons webgui: Dashboard: create more space for Dokcer/VM names (3 columns) webgui: Dashboard: cut off long container and VM names webgui: Dashboard: fix color consistency webgui: Dashboard: fix incorrect memory type webgui: Dashboard: fixed display of Wattage in UPS load webgui: Dashboard: fixed hanging when no share exports are defined webgui: Dashboard: fixed wrapping of long lines webgui: Dashboard: fixed wrong display of memory size webgui: Dashboard: include links to settings webgui: Dashboard: replace inline style statements for style section webgui: Dashboard: table adjustment in three columns view webgui: Dashboard: table right adjustment in two columns view webgui: Dashboard: use disk thresholds for utlization bars webgui: Dashboard: wrap long descriptions webgui: Diagnostics: dynamic file name creation webgui: Do not capitalize path names in title of themes Azure and Gray webgui: Docker: single column for CPU/Memory load webgui: Docker: Add More Info link (docker registry) to context menus webgui: Docker: textual update webgui: Docker: usage memory usage in advanced view webgui: Escape quotes on a containers template webgui: File browser: force download of files webgui: Fix Background color when installing container webgui: Fixed share/disk size calculation when names include space webgui: Fixed version display in system information webgui: Fixed: slots selection always disabled after "New Config" webgui: Keep status visible for paused array operations webgui: Main: make disk identification mono-spaced font webgui: Minor textual changes webgui: Move "Management Access" directly under Settings webgui: New icon reference webgui: OS update: style correction webgui: Open link under Unraid logo in new window webgui: Per Device Font Size Setting webgui: Permit configuration of parity device(s) spinup group. webgui: Plugin manager: add .png option to Icon tag webgui: Plugin manager: align icon size with rest of the GUI webgui: Plugin manager: enlarge readmore height webgui: Plugin manager: table style update webgui: Position context menu always left + below icon webgui: Prevent update notification if plugin is not compatible webgui: Replace string "OS X" with "macOS" webgui: Replaced orb png icons by font-awesome webgui: Revamped dashboard page webgui: Share settings: fixed exclude "All" from write function webgui: Suppress PHP warnings from corrupted XML files webgui: Switch button: use blue color in ON state webgui: Switch plugins to a compressed download webgui: Syslinux config: replace checkbox with radio button webgui: Syslog: add '' entry in local folder selection webgui: Syslog: added log rotation settings webgui: Syslog: added viewer webgui: Syslog: included rsyslog.d conf files and chmod 0666 webgui: Syslog: sort logs webgui: Updated Unraid icons webgui: Updated icons and cases webgui: Updated jquery cookie script from 1.3.1 to 1.4.1 webgui: Use cookie for display setting font size webgui: VM manager: remove and rebuild USB controllers webgui: VM page: allow long VM names webgui: added new case icons webgui: other GUI enhancements webgui: prevent dashboard bar animations from queuing up on inactive browser tab webgui: sort notification agents alphabetically, add telegram notifications webgui: syslog icon update webgui: telegram notification agent bug fixes
  5. 1 point
    In a recent reply to a post by another forum member (archedraft), I provided this guide to help him assign one of his NIC devices to a virtual machine, leaving the other for host networking (unRAID OS). I didn't see much point in this because with KVM and VirtIO, we can create virtual network interfaces that offer little to no overhead over a physical NIC, but after testing with pfSense, archedraft confirmed for me that he saw a dramatic performance increase. The reason? In this particular instance, pfSense was acting as a firewall and is based on FreeBSD. The FreeBSD kernel used by pfSense, while having support for VirtIO, appears to be out of date and was not allowing full 1gbps LAN throughput as it does with Linux or Windows VMs. Passing through a physical Ethernet controller to his pfSense VM in this instance resolved his issue. So we have found at least one use case thus far to consider such a method, but in the future, we may find more. And since the question comes up from time to time, I thought it prudent to post this here as an advanced guide for those that want to try it. WARNING: If you do not have multiple NICs in your system, doing this will result in your server losing all network connectivity. IMPORTANT: Regarding VM to Host Networking Performance When VMs utilize VirtIO, their is another distinct advantage in that networking between the host and guest can take place without traversing the copper wire. This allows for much faster throughput than the physical NIC hardware even supports at the port level. As an example, in mounting an SMB share to my SSD-based cache pool from inside my Windows VM, I was able to see IO throughput to the share exceed 250MB/s (that's megabytes, not bits). When a VM is assigned a physical network controller, this advantage disappears as the VM will communicate with the host as if it was a separate physical machine, going out the one NIC, down to your router/switching infrastructure, and then back in. This will limit your network throughput to that of the physical hardware. In my previous Windows VM / SMB example, I would be limited to 1gbps or 125MB/s. Guide 1 - Login to your server via ssh. 2 - Type the following command: lspci You will get a list like this: 00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06) 00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06) 00:01.1 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x8 Controller (rev 06) 00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06) 00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06) 00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 04) 00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04) 00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-V (rev 04) 00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04) 00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d4) 00:1c.3 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #4 (rev d4) 00:1f.0 ISA bridge: Intel Corporation Z87 Express LPC Controller (rev 04) 00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 04) 00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 04) 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] 01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300 Series] 02:00.0 VGA compatible controller: NVIDIA Corporation GK110 [GeForce GTX 780] (rev a1) 02:00.1 Audio device: NVIDIA Corporation GK110 HDMI Audio (rev a1) 04:00.0 Multimedia video controller: Device 1a0a:6202 (rev 01) Identify the Ethernet controller you wish to assign. Note the PCI address for the device (from my list, it would be 00:19.0). From my list, I only have one network card, so I shouldn't do this, but if you have multiple, either one SHOULD be fine to select. 3 - Type the following command: lspci -n 00:00.0 0600: 8086:0c00 (rev 06) 00:01.0 0604: 8086:0c01 (rev 06) 00:01.1 0604: 8086:0c05 (rev 06) 00:02.0 0300: 8086:0412 (rev 06) 00:03.0 0403: 8086:0c0c (rev 06) 00:14.0 0c03: 8086:8c31 (rev 04) 00:16.0 0780: 8086:8c3a (rev 04) 00:19.0 0200: 8086:153b (rev 04) 00:1b.0 0403: 8086:8c20 (rev 04) 00:1c.0 0604: 8086:8c10 (rev d4) 00:1c.3 0604: 8086:8c16 (rev d4) 00:1f.0 0601: 8086:8c44 (rev 04) 00:1f.2 0106: 8086:8c02 (rev 04) 00:1f.3 0c05: 8086:8c22 (rev 04) 01:00.0 0300: 1002:68f9 01:00.1 0403: 1002:aa68 02:00.0 0300: 10de:1004 (rev a1) 02:00.1 0403: 10de:0e1a (rev a1) 04:00.0 0400: 1a0a:6202 (rev 01) 4 - Identify your network card by PCI address (first column of results). 5 - Obtain the vendor/product ID for that device from the last column. 00:19.0 from my example is 8086:153b. 6 - Edit your syslinux.cfg file and add the following after the append but before initrd=/bzroot. pci-stub.ids=8086:153b REPLACE THE VENDOR/PRODUCT ID FROM MY EXAMPLE ABOVE WITH THE ONE YOU OBTAINED IN STEP 5. 7 - Reboot your system. 8 - Edit your VM using the XML editor mode. 9 - Add the following between the <devices> and </devices> tags. <hostdev mode='subsystem' type='pci' managed='yes'> <driver name='vfio'/> <source> <address domain='0x0000' bus='0x00' slot='0x19' function='0x0'/> </source> </hostdev> Modify the address line entering in the two digit bus, slot, and function from your ID. So 00:19.0 translates to what I have above. Save the XML and start your VM. All should be right as rain! NOTE: If you get an error, it could be because your NIC is in an IOMMU group with another in-use PCI device (either assigned to the host or to another VM). In this instance, you can attempt to use the PCIE ACS Override option under the VM Manager settings page, but use of this toggle is considered experimental.
  6. 1 point
    Hey, just a small QoL thing. Wouldnt it be a good idea to put a "Reboot now" button/link, next to "Reboot required to apply Unraid OS update". I think it would make sense. Many programs works like this.
  7. 1 point
    @sizo try what @Stupifier mentioned above. "Update: Figured out how to access UnRAID GUI. Did NOT figure out how to be assigned a local address on my primary WiFi subnet though. In Admin Page ----> VPN Settings go to Routing section and add a line for the subnet you want your clients to have access to (for example, I added 192.168.1.0/24 which is my primary WiFi subnet and where I can access my UnRAID GUI locally)"
  8. 1 point
    Right, interesting corner case: no encrypted disks exist, no new disks exist, and default file system type set to one of the encrypted forms - the fact it wants a passphrase is a bug. Providing one does no harm (one workaround), setting default file system type to an unencrypted form is another workaround. Thanks for reporting, we'll look into it.
  9. 1 point
    Sorry, I misread your earlier answer and thought it was applied to a single disk. Since you opened a bug report, it is the more appropriate topic to continue there.
  10. 1 point
    Definitely a typo. Is set to 6000000. Comes out to roughly 6.29TB ish....
  11. 1 point
    Set your shares to specific disks, then use the unbalance plugin to move the split shares to the correct disk
  12. 1 point
    The /root location will not be visible acros the network so not easily accessible. If you can log in as root then the permissions are irrelevant.
  13. 1 point
    Should be easy enough Steps are basically: stop the VM copy any vdisks to their new location on the Unassigned Device Edit the VM settings (easiest in XML view) to adjust the paths for the vdisks you have just moved to point to their new location on the UD drive start the VM that should be it i suggested copying the vdisks rather than moving them to give you an easy fall-back position. After you are happy the moved VM is working as expected you can then delete the copies from the cache disk.
  14. 1 point
    Rebuild on top of the old disk (or to a new one if you want to play it safer)
  15. 1 point
    Click on disk15 and make sure it is set to spin down.
  16. 1 point
    Yes, but I would still recommend user scripts since there's a large chance you forget about adding it in the future, if it's no longer needed, though in this case it shouldn't cause any issues.
  17. 1 point
    most def smarter to run in separate docker containers, if you run it all in one large vm and that vm goes bang (bad update, whatever) then you lost the lot, sure you can restore the vm's vdisk from backup but its going to take time to do. The other thing to keep in mind is bad application releases, this does happen and sometimes you want to roll back the application, this is harder to do in a vm environment and not always 100% clean rollback is possible. if you have it all as separate docker containers, if one goes bang you loose one app and only one app, and you can recover from this within minutes, delete container, re-create container, you're up and running!, sure you may get into situations where config data is corrupt, that can happen, but its not common and a restore of the config data (significantly smaller than a vm restore!) and you are back!. if you have a bad application release and you want to roll back then you simply stop the container, delete the container, pull the image with the version you want , re-create the container and you are done, no risky uninstall reinstall or downgrade, its a clean install every time!.
  18. 1 point
    Can't see how, but there might be another explanation. No, that's the allocated size, used is
  19. 1 point
    I was able to purchase a PRO key just now. It seems to be working fine now. Thank you!
  20. 1 point
    Sounds like a duplicate IP conflict
  21. 1 point
    My testing was less comprehensive (I hadn't noticed modification dates) but came to same conclusion. I'm not longer using AFP. I'm happy with unRAID SMB setting "Enhanced OS X interoperability" set to "Yes" and macOS Finder connections to unRAID using SMB (Connect to Server smb://sam@192.168.30.40/Media) 🙂
  22. 1 point
    Update: Enhanced OS X interoperability solved my issues, I get tags, get info file descriptions, etc... Creation dates still get screwed, but I also discovered that if I put a file over AFP into a share and access it over SMB either from a Mac or from Windows that date is getting screwed either way... so... since I want to rely less on my Mac anyways and use Windows primarily in the future I guess there simply is no way to keep creation dates intact whatsoever no matter the route you take. Guess I'll have to pull this tooth already and be done with it. Sucks, but so be it. At least SMB transferred files retain their tags in macOS when touched by Windows. (BIG ASTERISK: e.g. an rtf doc opened and saved again in Word that you created in TextEdit on Mac is saved as a new file so to say (this will get rid of any extended proprietary macOS metadata)... Meanwhile a .txt stays unchanged as far as that metadata is concerned. At least if I remember correctly. I did some random testing like that same night I last posted, bottom line is: SMB, Enhanced interoperability activated and then completely forgetting AFP exists is the way to go if you want to work with the files on both macOS and Windows. Otherwise only use AFP at all times, iirc that got a little speedier too after upgrading to unRAID 6.7)
  23. 1 point
    I did try 6.7-rc5 with the latest BIOS when I was was originally having the issue and no luck- same error. They were both using Linux Kernel 4.19. I am holding out hope that the NEXT UnRaid version will include Linux Kernel 5 and because kernel 5.2 (I think) will have Zen 2 support, we will see a fix for our problems with this stuff. This is a good idea @John_M! I will find all the model numbers listed in this thread and make an edit to the OP to include them there. I am curious on what is the root cause. At one point I contemplated buying a new high-end x470 mobo, but then I saw posts from other folks here with the same issues on other manufacturers.
  24. 1 point
    Upgraded from 6.6.7 without any major issues and only one minor one. The upgrade took all my services offline but then never rebooted. I was able to ssh in and manually reboot and everything came back up fine (so far.)
  25. 1 point
    Haven't tested these so far, just wanted to say thank you for providing all of these! Let it be known that I very much appreciate the prospect of letting my unRAID practically take care of anything. Makes me wonder: do I even need a desktop computer anymore? *snickers* (well strong yes, but between this and being able to run games on the server itself with some catchy PCIe pass-through... Latter of which I don't intend on implementing for a while though)
  26. 1 point
    ASMedia ASM1061 or ASM1062 based SATA cards work well with Linux and with SSDs.
  27. 1 point
    Script running at boot time is the only way to do this.
  28. 1 point
    @JonMikeIV I also upgraded from 6.6.7 to 6.7.0 but had no hanging issue. I'm not sure if this makes a difference but I always do this before starting the unRAID OS upgrade and have never had it hang: Stop VMs and Dockers Stop Array, confirming it stops sucessfully Then upgrade OS Then reboot I know this doesn't really help your current situation but just wondered if it might explain the hanging.
  29. 1 point
    I just downloaded an older BIOS on their website and I was able to install it as you would a newer version. Apparently my motherboard didn't bother downgrading.
  30. 1 point
    I like shiny new things and haven't had any major issues with updates in the past so decided to try 6.6.7 -> 6.7.0 even though I'm not near the box right now.... Oops. 🙂 30 minutes later I'm still at the "System is rebooting" page and while the device replies to pings it won't accept (actively rejects?) connection requests to the GUI. I have SFTP access and one of my remotely visible auto-start Dockers is running but another isn't and my auto-start VMs aren't. I have remote access to other machines on that network and the Unraid SMB shares do seem to be visible. I'm fine waiting until I have physical access to the device but if people have suggestions for remotely (via SSH) debugging I could poke around a bit. 🙂 Edit: Thanks @moose, apparently it just got stuck shutting down - once I physically power cycled it everything (including the expected loss-of-power parity check) was fine - hello 6.7.0! 🙂
  31. 1 point
    Total sarcasm in my previous post. But there is no need to throw the baby out with the bathwater as you suggest. The above is is your view/opinion on user experience and not necessarily indicative of total user behavior. If you're using icons only as a metric and determining factor for what system information is available "underneath", then the icons we have as descriptors fail miserably in that job. Nerdpack uses a dropbox icon. Stats settings has the same icon as stats in the tabs. Backup/Restore is a shield but not antivirus. And why? These aren't stop signs or traffic lights, these are visual enhancements made to make the web GUI look nicer, which I think they do. These are not apps on your phone. Want further proof? Take the text away from the tabs and leave icons only. The settings icon takes a bit to understand, as well as plugins. Docker is fine, but what is that calendar icon? Oh, it's the apps... On the settings page, both the scheduler and auto update applications are refresh/reload circles, but which one is bolder? Can you tell me without looking? And why is the scheduler not a calendar (like the apps store icon is.) See. It's not about app icons like on your phone. It's all about the text with a little graphic element beside it only for the purpose of differentiation, not identification. And that is where your beef comes from (imo) not understanding the functions of the icons. This is not a swipe at all the UI icon changes or work that goes into it, I actually have no problem with the choices however much a stretch they are (or how colorful or lack of colorful they are) because they are essentially eye candy for the text descriptors. And we know this because I'm 100% certain you haven't memorized all the icons and their meanings and settings they link to, like the apps on your phone. To offer a contrasting user experience, I never look at the icons as a guide to settings/functions. I either scan the page visually or in a pinch, use control/command F and search for the text on the page of what I want. (I don't know why I wrote so much on this, I don't really care that much as long as the interface works. But looking nice is a bonus and I am appreciative of the work that goes into it. Regardless of your response, I won't be continuing this discussion further as I'm sure you will disagree with me 100%, and that's fine too I guess.)
  32. 1 point
    Within Sonarr's advanced settings, you can have it set file / folder permissions. Set them to be 0777
  33. 1 point
    Rather than requesting an icon for a specific case, I would prefer to have the ability to import any appropriate graphics file.
  34. 1 point
    I had the exact same problem using a 1600X, a 1660Ti and an Aorus X470 Ultra Gaming until I downgraded the BIOS To version F6. I think the update to a newer AGESA version to support the upcoming CPUs on AMD platform is breaking the passthrough capabilities. I've seen posts of people complaining about this exact issue with other motherboard and a downgrade seems to fix it in most cases.
  35. 1 point
    Overview: Support for Docker image arch-krusader in the binhex repo. Application: Deluge - https://krusader.org/ Docker Hub: https://hub.docker.com/r/binhex/arch-krusader/ GitHub: https://github.com/binhex/arch-krusader Documentation: https://github.com/binhex/documentation If you appreciate my work, then please consider buying me a beer For other Docker support threads and requests, news and Docker template support for the binhex repository please use the "General" thread here
  36. 1 point
    As an aside, the Fix Common problems plugin has been issuing warnings about marvel controllees for quite awhile now. Sent via telekinesis
  37. 1 point
    Doesn't mean we won't add it
  38. 1 point
    The current caching system has a few bugs with the way it is set up, especially when it comes to windows updates. We are working on a completely new system that should fix this. However, in the meantime, you should be able to just disable windows updates from caching. I don't understand why this doesn't work. @mlebjerg are you able to shed any light on this? Also, sorry for taking ages to reply 😝
  39. 1 point
    Putting this here because probably the most people will set it. Due to the crisis in the computing industry over Meltdown, Spectre, and the like, operating system developers have been working diligently with academia, CPU developers and hardware manufacturers to provide solutions. Some of these solutions require both hardware changes in the form of CPU microcode and software changes in the form of operating system and other subsystem mitigations. Despite what might be reported in the press, this work is ongoing. Probably everyone is familiar with the warning from motherboard providers: "Do not update your bios unless you are experiencing a problem." However some changes in the latest OS releases require corresponding bios updates. AMD is particularly affected because they don't typically provide "early microcode update" as part of OS start up like Intel does. Case in point: Everyone has to decide for themselves whether to attempt bios update, and take responsibility if something fails and you brick your motherboard. But particularly if using Virtual Machines, we highly recommend keeping your bios updated, especially for AMD platforms.
  40. 1 point
    I'm having this issue over the past week or so also. No changes to the unRAID system, and Radarr is working fine.
  41. 1 point
    2 Factor authentication via youbikey or google authenticator would also be nice.
  42. 1 point
    Yes, if you have existing data on the disk(s) it can take a while to move the data to the subvolume since it's like a disk to disk copy, it can't be moved directly, but there's a way around that, this is what I did to quickly convert a share to a subvolume: Rename current share to a temp name: mv /mnt/disk1/YourShare /mnt/disk1/temp Create a new subvolume with old share name: btrfs sub create /mnt/disk1/YourShare use btrfs COW to do an instant (or almost instant, it can take a few seconds) copy of the data to the new subvolume cp -aT --reflink=always /mnt/disk1/temp /mnt/disk1/YourShare Delete temp folder rm -r /mnt/disk1/temp Done, repeat this for all disks and shares You should also create a folder (or more if there are various shares on each disk) for the snapshots, this can be a regular folder, e.g.: mkdir /mnt/disk1/snaps Then I use the user scripts plugins to create the snapshots, at regular intervals for my always on server, and at first array start for cold storage/backup servers, I use a script like this: #!/bin/bash nd=$(date +%Y-%m-%d-%H%M) for i in {1..28} ; do btrfs sub snap -r /mnt/disk$i/TV /mnt/disk$i/snaps/TV_$nd done beep -f 500 ; beep -f 500 ; beep -f 500 On line 3 specify the correct number of disks where the share is, e.g., for disks 1 to 5 it would be for i in {1..5} ; do and adjust the paths as necessary, beeps I use on my backup servers so I know when the snapshots are done and the server is ready to receive new data.