Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 06/27/19 in all areas

  1. 2 points
    It's sad that people have now made this awesome hard work become a post worthy of: https://old.reddit.com/r/ChoosingBeggars/ Please remember before this came out, we had to buy expensive large core processors AND use more power to do what we are doing today. Thank you again for all your hard work. Without it we are back to what we had before which is nothing. *I hope your family member is doing well. No amount of software/Computer work is worth not having those memories of said family members.*
  2. 2 points
    I think I've sorted this.. I'd not added my WHS smb shares as a "remote smb". I'd simply added the WHS smb in Krusader using "New net connection" Having added the remote smb using "Add Remote SMB/NFS Share" and mounting it, I'm seeing 100MB/s + transfer speeds. Thanks to all for your support and apologies for my noobishnes :)
  3. 1 point
    To upgrade: If you are running any 6.4 or later release, click 'Check for Updates' on the Tools/Update OS page. If you are running a pre-6.4 release, click 'Check for Updates' on the Plugins page. If the above doesn't work, navigate to Plugins/Install Plugin, select/copy/paste this plugin URL and click Install: https://s3.amazonaws.com/dnld.lime-technology.com/stable/unRAIDServer.plg Refer also to @ljm42 excellent 6.4 Update Notes which are helpful especially if you are upgrading from a pre-6.4 release. Bugs: If you discover a bug or other issue in this release, please open a Stable Releases Bug Report. We restored PHP/SQLite support and updated the kernel-firmware package. We are also still trying to track down the source of SQLite Database corruption. It will also be very helpful for those affected by this issue to also upgrade to this release. If you have issues with SQLite DB corruption, please post in this separate Bug Report. Version 6.7.2 2019-06-25 Base distro: kernel-firmware: version 20190620_7ae3a09 php version: 7.2.19 (restore sqlite support) sqlite version: 3.28.0 Linux kernel: version: 4.19.56
  4. 1 point
    Hi guys This product has been on my radar for some time. I've not had the available funds/time to get my old dirty setup into this unRaid which was something a few friends recommended. I've been putting off going ahead because of the overheads I have with getting this up and running. I know the cost curve is high then looks like it is VERY maintainable. I think my first thought was, okay I need the biggest and baddest HDD/SSDs I can find so that everything is there, but obviously, that was going to be some serious money so I dialled it back, way back! I settled for 2 parity HDDs at just 4TB each but then realised that the best deals where in this size so this might actually be the standard size HDD I use in my array (array being the right term right?). So I shifted to 6TB. Then the calculated overheads began looking too expensive. The other overhead which is obviously necessary is the unRaid software licence itself (I'm not complaining here btw). So in an effort to actually get started I wanted to maybe take a more tactical approach which has only crossed my mind now. I currently have a stock of; Hardware (nothing to write home about here but it's what I have spare) i7-960 (first gen i7) Asus P6X58D-E mobo (supports VT-d) Manual Link below 12GB Corsair Vengeance DDR3 NVidia 560Ti GTX Cooler Masters HAF case (6 HDD bays + 6 optical drive bays) 4 Port Nic (5 ports in total) 80Mbps Fibre Broadband (unlimited) Tested@ 73.6Mbps download | 17.5Mbps upload Asus P6X58D-E mobo Manual Link Parity HDD (going to use 2 parity HDDs) None None SSD (my unRaid Cache disks) 256 GB - Crucial MX300 (label says this is 270GB) 256 GB - Crucial MX500 (label says this is 250GB) Future: I could possibly replace these two for larger cache SSDs but it is probably unlikely HDD (will be used for storage) 4 TB - Western Digital (Blue) 2 TB - Western Digital (Green) 1 TB - Western Digital (Blue) 500GB - Western Digital (Blue) 500GB - Seagate (Generic white label) Future: HDD will probably be something like 3TB or 4TB Barracuda or Iron Wolf Intended Use for my unRaid system I currently have a system that has 500GB of storage, 4GB RAM and is running on Intel Quad Q9550 CPU. I currently and has successfully ran VMware ESXi with 2 instances. PFSense (for my home router) and a Lubuntu which runs my Plex server. It has been running non-stop without issue for over a 1.5years PFSense looks after itself, I haven't needed to touch it after setting it up and it has enough resources. Lubuntu is only there to run Plex which serves my Movie, Picture and Music streaming internally and externally to a few devices (i.e. my mobile or my work pc) There is never any more than 1 person streaming although there may be up to 3 or 4 eventually but only at odd times). For my new unRaid setup I would to setup my PFSense and Plex again with the possibility of running another couple of desktop images (that will probably be spun up and down as and when needed) and an Ubuntu (for Apache) web server for low amounts of web traffic. My questions: 1. For my Parity HDDs, could I buy 2x 4TB, use them as Parity Drives but then at a later stage buy the 2x 6TB drives and move the old ones into my array as data drives? If so, is there anything I need to know i.e. long rebuild times etc? 2. If I start on the basic plan to keep costs down then got Pro is there any limitations on features other than the number of drives I can attach? 3. Is there anything obvious about my existing parts list (or future intended buys) that send up warning flags with anyone? 4. On VMware ESXi I have an option to (forgive me, I can't remember what it was called)... Since ESXi loaded PFSense which supplied DHCP there was an option in ESXi to delay trying to communicate with DHCP until it had loaded the PFSense instance. Can unRaid do the same thing? Many thanks
  5. 1 point
    Update: The answers to these questions can be found in our new blog For an upcoming blog, we’ll be publishing a Q&A with Tom Mortensen, the Founder and CEO of Lime Technology and creator of Unraid. This is where you, the Unraid community come in: For the coming weeks, we’re opening up the floor to you all to ask Tom (@limetech) a question. Anything and everything is fair game-- just drop your question into this forum thread and he’ll do his best to get as many answered as possible (can't guarantee every question will be answered). The floor is yours! Here’s a little more info about Tom from our website: Tom began his career in enterprise-storage at a start-up company called Maxstrat. Maxstrat was one of the first companies to offer disk array products and was ultimately purchased by Sun Microsystems in 1999. After the Sun Microsystems acquisition, Tom worked in their Network Storage Division as a system architect, and later for other start-up companies before starting Lime Technology. With his passion for electronic media and background in storage, he knew there had to be a better way to store and stream media content throughout his home, so in 2005 he invented Unraid to protect and manage his media files. Unraid was a new twist on an older technology that didn’t require all the devices in an array to be continually spun up, thereby reducing power consumption, and increasing the lives of the drives. Tom is very excited about what the future holds for Lime Technology as we continue to be on the forefront of digital media storage innovation. On a more personal note, one of Tom’s favorite hobbies is brewing beer.
  6. 1 point
    Is your ISP blocking port 80? You can try to install the nginx container and see if you get the default webpage to check if port 80 is blocked or not.
  7. 1 point
  8. 1 point
    I remember seeing a notification when the 6.7.1 Unraid Nvidia build was released? Maybe I'm misremembering. Either way, I have Unraid update and plugin notifications disable and enabled, respectively, so we'll see if a notification comes through when 6.7.2 Unraid Nvidia is released.
  9. 1 point
    So I had auto-updates turned on and saw that it updated Deluge to 2.0. Unfortunately, some of my private trackers do not have that whitelisted, so I went ahead and downgraded with the following build. binhex/arch-delugevpn:1.3.15_18_ge050905b2-1-04 When I did that, it booted up just fine, except it lost all of my torrents (All my settings seem to be good). I had over 200 torrents. is there a simple way to re-add all of my torrents? I have them all moving to a completed folder when they finish, so I didn't think I could just re-add the torrent files because I thought it would just re-download them all unless I pointed over to the completed folder, which is not something I'd really want to do at this point. I tried to restore from a previous CA Backup / Restore Appdata from a few days ago, but after I copied over the files it still booted up with zero torrents in the program. I've attached a picture of my completed torrent folders to show where they download and move to. (I also have labels set up to auto move completed to folders based on those labels. Any help would be appreciated, thanks!
  10. 1 point
    Oh dear. My prayers for you and your family, mate.
  11. 1 point
    I was able to get a 9400-16i to work earlier this week. It has a SAS3416 controller. There are several threads talking about the 9305-24i.
  12. 1 point
    I do understand the structure of the NFL. The NFL non-profit status - and I'm paraphrasing Roger Goodell - was a tax-distributing mechanism to allow the teams to pay for their applicable level of taxes (which differ depending on where the teams are located). By that fact alone, the NFL does not qualify as a non-profit because it distributes its income back to its members so they can pay taxes elsewhere. The NFL owners simply exploit a US tax loophole that somehow allows "professional football leagues" to be exempted (but not professional basketball leagues e.g. the NBA, which has never been tax-exempt). LE, in contrast, issues free certificates to the public. There is no income to distribute because LE's product is free and thus generates no income. I can even flip your point back and ask "what will LE members do if LE is hacked and its reputation damaged to smithereens"? Most likely they will simply sell "Pro" tier product that is more secured than LE. Want to sue LE for compensation? Hey LE cert was free, remember? Want to sue LE members? Have you heard of "limited liability"? In short, associated products that can be sold in connection with a main product cannot be used to explain away the need for accountability on such main product. Anyhow, back to my main point, that the writer's (valid) main point was ignored and overshadowed by 1 section that was taken out of context. If anyone wants the TL;DR, read the "Three Takeaways" section at the end.
  13. 1 point
    just go pro, one time fee and updates are free!
  14. 1 point
    you're such a hooch 😂
  15. 1 point
    I understand your frustration. However, when you use a 3rd party plugin/application that is not part of the base OS and thus not maintained by that base OS development team, these things can and will happen from time to time. It's just part of the knowledge you must have when you use a 3rd party plugin like this. I realize that doesn't take away your frustration, but your post comes off to the LSIO team (and mainly @CHBMB) as you diminishing the fact that he is spending his free time to do this work. If you really don't want to be in this kind of situation again, you should configure your server in a way that will not require the use of 3rd party supported tools (ie. use a CPU with iGPU or just don't use HW transcoding at all in Unraid).
  16. 1 point
    It's a Linux kernel problem. People are already trying to help to find workarounds but if it's not fixed in the kernel, there is no guarantee whatsoever that these workarounds would work for everyone. Don't blame the tires when the engine breaks. You can't possibly expect everyone on the forum to drop everything to give you (free) bespoke advice on an on-demand basis. Such expectation is also not acceptable. Best course of action for you is to use the last Unraid version that works.
  17. 1 point
    Any LSI with a SAS2008/2308/3008 chipset in IT mode, e.g., 9201-8i, 9211-8i, 9207-8i, 9300-8i, 9400-8i, etc
  18. 1 point
    Squid's CA FAQ says the refresh time should be about two hours. If I don't see it tomorrow, after work, I'll poke around some more.
  19. 1 point
    thanks for the command, but when I use this command the problem stay showing that "This site can’t be reached"
  20. 1 point
    Telnet is essentially a legacy system. I suppose a basic analogy would be kind of an unencrypted SSH.
  21. 1 point
    the implication that because it is a not for profit organization, and therefore can fail with "no accountability" is laughably absurd. The NFL was a non profit until 2015, and they seemed to have accountability before that time.
  22. 1 point
    I do not think we should add anything messing with the update check for unraid. That is just asking for trouble.
  23. 1 point
    So you haven't changed anything in the BIOS? I should have clarified that I also had to change a number of settings in the BIOS and unraid to achieve stability with my 1700x. Including: 1. Disable global c-states 2. I forget what the actual setting is but its a power setting and the best option is "typical device idle" or something like that. 3. Editing the syslinux configuration to include rcu_nocbs=0-15 (0-7 for you given its a 4-core processor) after "append". 4. Editing the go file to include "/usr/local/sbin/zenstates --c6-disable" as the first line (not sure if this is necessary given global disabling but I added it anyway.
  24. 1 point
    Sounds like you are attending a meeting. Stay strong.
  25. 1 point
    The following sequence will work: Stop the array Unassign parity2 Start the array. This step is necessary to get Unraid to 'forget' the current parity2 assignment Stop the array Assign the old parity2 disk as a data disk start the array The above is a generalized solution that keeps parity1 valid (and thus the array protected) throughout.. in this case probably a faster solution is the New Config route but it invalidate all parity so parity has to be rebuilt before the array is protected again.
  26. 1 point
    Tools->New Config Will do it for you. But first note all your disks, their serials and where you want them to go. This will allow you to put anything anywhere, so be careful. Sent from my chisel, carved into granite
  27. 1 point
    I did it manually and it's working, config:
  28. 1 point
    If you are talking about a separate NAS on your network, and NOT the Unraid server, then NO your NAS does not count, as it is not part of the Unraid setup. An attached NAS over the LAN would not be part of the Unraid Array, NOR an unassigned drive in the Unraid installation (internal or external). The NAS would be a separate device on the network, and would not count toward, or against any drive allowances in your Unraid system. You CAN however map any other network drives via the unassigned drives plug-in, to be used with unraid as a drive resource OUTSIDE of the protected array. These mapping still DO NOT count toward or against your drive allowances, but they will consume additional resources on your Unraid server, including additional RAM needs. If you are talking about installing Unraid ON your NAS, then each drive in the NAS WOULD be counted in the drive allowances for the server since they would then be part of the Unraid installation. Each drive could be either configured as part of the array, or outside of the array as needed. Hope that helps. Feel free to ask anything else, and please provide a little more detail on how you are planning to use your unraid and your NAS in releation to each other if I was unable to answer your question properly. Also please look at this; https://unraid.net/pricing and the older page https://lime-technology.com/wp/pricing/ which also has this; What are “attached storage devices”? They refer to the total number of storage devices physically attached to the server before you start the array. This number is in addition to your USB flash device used to boot unRAID (e.g. 4 HDDs + 2 SSDs + unRAID boot device = 6 attached devices). Non-storage devices such as GPUs do not count against this limit.
  29. 1 point
    For anyone trying to set up zfs-auto-snapshot to use Previous Versions on Windows clients: I placed the zfs-auto-snapshot.sh file from https://github.com/zfsonlinux/zfs-auto-snapshot/blob/master/src/zfs-auto-snapshot.sh in /boot/scripts/zfs-auto-snapshot.sh and made executable with chmod +x zfs-auto-snapshot.sh I found that no matter which way I set the 'localtime' setting in smb.conf, the snapshots were not adjusting to local time and were shown in UTC time. To fix this, I removed the --utc parameter on line 537 of zfs-auto-snapshot.sh to read: DATE=$(date +%F-%H%M) I then created cron entries by creating /boot/config/plugins/custom_cron/zfs-auto-snapshot.cron with the following contents: # zfs-auto-snapshot.sh quarter hourly */15 * * * * /boot/scripts/zfs-auto-snapshot.sh -q -g --label=04 --keep=4 // # zfs-auto-snapshot.sh hourly @hourly ID=zfs-auto-snapshot-hourly /boot/scripts/zfs-auto-snapshot.sh --quiet --syslog --label=00 --keep=24 // # zfs-auto-snapshot.sh daily @daily ID=zfs-auto-snapshot-daily /boot/scripts/zfs-auto-snapshot.sh --quiet --syslog --label=01 --keep=31 // # zfs-auto-snapshot.sh weekly @weekly ID=zfs-auto-snapshot-weekly /boot/scripts/zfs-auto-snapshot.sh --quiet --syslog --label=02 --keep=8 // # zfs-auto-snapshot.sh monthly @monthly ID=zfs-auto-snapshot-monthly /boot/scripts/zfs-auto-snapshot.sh --quiet --syslog --label=03 --keep=12 // Edit: I switched the cron entries to use specific times of day, days of the week, etc. primarily due to the effect of reboots on unRAID's cron handling. I would get inconsistently spaced apart snapshots with the above cron configuration. # zfs-auto-snapshot.sh quarter hourly */15 * * * * /boot/config/scripts/zfs-auto-snapshot.sh -q -g --label=04 --keep=4 // # zfs-auto-snapshot.sh hourly 0 * * * * ID=zfs-auto-snapshot-hourly /boot/config/scripts/zfs-auto-snapshot.sh --quiet --syslog --label=00 --keep=24 // # zfs-auto-snapshot.sh daily 0 0 * * * ID=zfs-auto-snapshot-daily /boot/config/scripts/zfs-auto-snapshot.sh --quiet --syslog --label=01 --keep=31 // # zfs-auto-snapshot.sh weekly 0 0 * * 0 ID=zfs-auto-snapshot-weekly /boot/config/scripts/zfs-auto-snapshot.sh --quiet --syslog --label=02 --keep=8 // # zfs-auto-snapshot.sh monthly 0 0 1 * * ID=zfs-auto-snapshot-monthly /boot/config/scripts/zfs-auto-snapshot.sh --quiet --syslog --label=03 --keep=12 // Run 'update_cron' to immediately enable the custom cron entries. The labels differ from the zfs-auto-snapshot default labels for better compatibility with Samba. For the Samba shares, I placed the below in /boot/config/smb-extra.conf: [data] path = /mnt/zfs/data browseable = yes guest ok = yes writeable = yes read only = no create mask = 0775 directory mask = 0775 vfs objects = shadow_copy2 shadow: snapdir = .zfs/snapshot shadow: sort = desc shadow: format = zfs-auto-snap_%S-%Y-%m-%d-%H%M shadow: localtime = yes Run 'samba reload' to refresh your Samba config. After the first scheduled snapshot is taken, you should now be able to see the snapshots in the Previous Versions dialog on a connected Windows client. You'll need to modify this with your desired snapshot intervals, retention, and path names. This configuration is working well for me. I hope this helps anyone else out there trying to get ZFS snapshots working with shadow copy for Windows clients.
  30. 1 point
    The new version of unMENU now has the ability to use .css skins. Its appearance has been updated thanks to the work of some very talented unMENU users, and one specifically ( mvzdwaan ) who took on the task of adding the ability to read style sheets. Major change 1. New .css skinning capability and two new skins in addition to the "Classic" skin. (need to thank mvzdwaan for his .css skills) 2. Three new buttons on user-scripts page to change between skins. Minor changes in a few commands 1. On System-Info screen, "Memory Info" presents output of "free -l" instead of "free" 2. On System-Info screen, "Open Files" presents output of "lsof" instead of "lsof /dev/md*" 3. On Network and Disk performance screens, formatting fixed to deal with higher performance data rates. 4. On syslog view, newer definition file to prevent "sas: ata[0-9].*dev error handler" from being marked as an error. 5. On syslog view, newer definition added to prevent media file name in syslog with "*terror" in name from being flagged as an error. 6. PERL package has option added to NOT load MP3 library every time it starts from CPAN If you already have unMENU installed, you may use the "check for updates" button on the 'User-Scripts' page to download the new version. You will have to Re-Start unMENU for the updates to take effect, so you'll want to also press the 'restart unMENU' button. If you do not have unMENU installed, follow the instructions on the google.code page here: http://code.google.com/p/unraid-unmenu/ A huge thanks to mvzdwaan for his skills in adding the capability to "skin" unMENU and vastly upgrade its appearance. In fact, there are three new user-script buttons to allow you to switch between unMENU classic, and new horizontal and vertical menu skinned formats. The currently used "skin" is in /boot/unmenu/images/stock/unmenu.css You may edit that file as you desire if you have css skills. The new skin is effective on all the screens EXCEPT the file-browser. It has not been upgraded as of this post. It works differently than the others so it will take a bit more effort. It will simply have the classic appearance for now. Have fun... To me, it looks really great for an "awk" script.... Joe L. This is the new unMENU 1.6 main screen with the "horizontal' skin: Joe L.