Jump to content


Popular Content

Showing content with the highest reputation on 07/18/19 in Posts

  1. 1 point
    Hey everyone! After months of testing and learning, I finally managed to have 2 of my 4 1080TIs run in SLI. The information on how to do this has actually been online for a while but a bit scattered about (at least that was my experience). Overview of Steps 1) Achieve GPU pass-through 2) Mod the Nvidia Drivers to allow SLI in our VM 3) Use Nvidia Profile Inspector to get much better performance Edit Update After utilizing a few other VM optimizations, specifically CPU pinning, my SLI performance DRASTICALLY improved. My FPS in SLI went from the mid 40s to 70+ (I used a few different benchmarks such as the unigine benchmarks and also from personal experience playing ESO). When I started trying to get SLI to work in Unraid, I noticed that just passing through 2 GPUs to a single VM already resulted in very noticeable gain in performance. I am still tinkering with Nvidia Profile Inspector, so things might change. If they do, I will post an update. GPU pass-through My VM options: Bios: OVMF Machine: Q35.1 Sata for ISO drivers and VirtIO for Primary vDisk Follow the instructions in this Spaceinvader One video. Afterwards, pass through your 2 GPUs and they should appear in windows. Nvidia Drivers Mod Note: If you have any difficulties with this next part, you are better off asking for help here on the DifferentSLIAuto forum thread. So to my understanding motherboard manufactures must license the right to allow SLI on their boards from Nvidia. The reason we haven't been able to achieve SLI in Unraid is due to the fact that our VM's "motherboard" info simply not qualifying as a Nvidia approved motherboard for SLI. Luckily there has been a hack available for a while that allows SLI to be enabled for not only any motherboard but also any GPUs (aka, the GPUs don't even need to be the same model). This is what worked for me: I used Nvidia Driver version 430.86. If you use the same version, then these instructions SHOULD work for you. Install Nvidia Drivers The original method/program used by DifferentSLIAuto is no longer working for the latest versions of Nvidia drivers (driver versions 4xx and on). We have two choices, we can go with the old method and use an older driver or we can mod newer drivers manually. This is what I did, and what I'll be describing: Download DifferentSLIAuto version 1.7.1 Download a Hex Editor (I used HxD) Copy nvlddmkm.sys from C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_b49751b9038af669 to your DifferentSLIAuto folder (NOTE: if you are not using driver version 430.86, then the nvlddmkm.sys file you must modify will be located some where else and you must find it yourself by going to Device Manager > Display adapters > YOUR CARD). Mod the copied nvlddmkm.sys file by opening it in a Hex Editor. Here are the changes for driver 430.86: Address: [OLD VALUE] [NEW CHANGED VALUE] 000000000027E86D: 84 C7 000000000027E86E: C0 43 000000000027E86F: 75 24 000000000027E870: 05 00 000000000027E871: 0F 00 000000000027E872: BA 00 000000000027E873: 6B 00 Save and exit Hex Editor In your DifferentSLIAuto folder, right click and edit install.cmd. Replace all instances of "nv_dispi.inf_amd64_7209bde3180ef5f7" with the location of where our original nvlddmkm.sys file was in our case this is "nv_dispi.inf_amd64_b49751b9038af669". The install.cmd file will modify the copy we added to the folder and replace the original one found at the location we specify here. Use this video for reference but please note that in the video the driver version is different then ours and they replace nv_dispi.inf_amd64_7209bde3180ef5f7, with nv_dispi.inf_amd64_9ab613610b40aa98 instead of nv_dispi.inf_amd64_b49751b9038af669. Move your DifferentSLIAuto Folder to the root of your C:\ drive. Set UAC to the lowest setting (OFF) in Control Panel\All Control Panel Items\Security and Maintenance. Run cmd.exe as admin and enter: bcdedit.exe /set loadoptions DISABLE_INTEGRITY_CHECKS bcdedit.exe /set NOINTEGRITYCHECKS ON bcdedit.exe /set TESTSIGNING ON Restart you computer into safe mode + network enabled (Video showing how to do it quickly using Shift + Restart) Within the DifferentSLIAuto folder located at "C:\", run install.cmd as admin. After only a few seconds the CMD window text should all be green indicating that all is well! Open up your Nvidia Control Panel and under 3d Settings it should now say "Configure SLI, Surround, PhysX". Click that option, and under SLI Configuration Select Maximize 3d performance and that's it! Nvidia Profile Inspector The default settings in the Nvidia Control Panel really suck. After FINALLY getting SLI to work I was getting only 40 FPS in SLI when before I was getting 100+ FPS prior to enabling SLI. I was about ready to give up when I came across Nvidia Profile Inspector! By changing a few settings with Nvidia Profile Inspector, I was able to finally get great SLI results (70 FPS). Keep in mind that I only changing settings in profile inspector for only a few hours, so I'm sure there are many optimizations to be made, so hopefully we can figure it out as a community. Run Nvidia Profile Inspector. I recommend the following settings for now for the _GLOBAL_DRIVER_PROFILE (Base Profile). Nvidia Profile Inspector Settings: 1 - Compatibility - SLI compatibility bits: 0x02C00005 SLI compatibility bits (DX10 + DX11): 0x080000F5 5 - Common - Power management mode: Prefer maximum performance Thread optimization: On 6 - SLI - NVIDIA predefined number of GPUs to use on SLI rendering mode: 0x00000002 SLI_PREDEFINED_GPU_COUNT_TWO NVIDIA predefined number of GPUs to use on SLI rendering mode (on DirectX 10): 0x00000002 SLI_PREDEFINED_GPU_COUNT_TWO NVIDIA predefined SLI mode: PLAY WITH BOTH: 0x00000002 SLI_PREDEFINED_MODE_FORCE_AFR & 0x00000003 SLI_PREDEFINED_MODE_FORCE_AFR2 NVIDIA predefined SLI mode on DirectX 10: PLAY WITH BOTH: 0x00000002 SLI_PREDEFINED_MODE_FORCE_AFR & 0x00000003 SLI_PREDEFINED_MODE_FORCE_AFR2 SLI rendering mode: Try: 0x00000000 SLI_RENDERING_MODE_AUTOSELECT, 0x00000002 SLI_RENDERING_MODE_FORCE_AFR. 0x00000003 SLI_RENDERING_MODE_FORCE_AFR2 MAKE SURE TO HIT APPLY CHANGES ON TOP RIGHT HAND CORNER Next we will make some changes in Control Panel > Nvidia Control Panel Nvidia Control Panel Manage 3D Settings > Global Settings Power management mode: Prefer maximum performance SLI rendering mode: start by leaving this alone, and then make it match your Nvidia Profile Inspector settings (so if you are trying 0x00000002 AFR, set this to Force alternate frame rendering 1, and if your are trying 0x00000003 AFR2, set this to alternate frame rendering 2) And that's it! Now keep in mind the settings above are far from the best, and are only a starting point for us. It is probably best to find individual game profiles for each title and go from there. I will be googling "Nvidia Profile Inspector <insert game here>" for a while and trying different settings out. Make sure you change the "NVIDIA predined number of GPUs" settings to TWO if you change profiles because in my experience it was defaulting to FOUR (this may be because I do have 4 physical cards installed on the motherboard, so if someone else gets different results please let me know). SOME CLOSING THOUGHTS I did some additional research which lead me to open up my motherboard manual. I discovered that in my case, my mother board PCIe slots change speed depending on a wide number of factors (for example, if I have a 28 lane CPU, some of my PCIe 3.0 slots (PCIE1/PCIE3/PCI5) STOP functioning in x16 and instead run at x16/x8/x4. If that wasn't a big enough kick in the nuts, since I have an m.2 SSD in my m.2 slot, my PCIE5 slot doesn't function at all). All in all, this was fun adventure for me, and I really hope this information helps people who are interested in trying SLI via VMs!
  2. 1 point
    They need to be updated by whoever the 3rd party developer is for the plugin from python v2 to python v3. Of course anyone can update them and then submit a pull request on github. Quite a few Deluge plugins are still waiting for their individual developers to update them. You might want to check the github pages for those plugins. In some cases pull request are pending but haven’t been merged. I know this is true for AutoRemovePlus.
  3. 1 point
    Hey everyone, Happy Prime Day! Amazon has some good deals on cheap storage: WD 10TB Elements Drive for $159.49 And for those of you who don't want to shuck the drive and want the additional warranty, you can also get an 8TB Red for $156.99: WD Red 8TB Drive for $156.99 Note you may have to click "View Deals" when logged in to your Prime account. Enjoy the new storage!
  4. 1 point
    Direct quote from this page. https://unraid.net/pricing "All Basic/Plus/Pro registration keys are eligible to run new releases of Unraid OS at no additional cost." So, a key purchased today will be valid going forward. If Limetech decides to change their policy in the future, only keys purchased after that point would be treated differently.
  5. 1 point
    The main purpose of the server would be NAS, in my current server I use 2 x 8 TB hard drives in a mirrored mode. I also have a thumb drive as the boot device. - Make sure you double check that your thumb drive has non-zero GUID (just boot a trial copy of Unraid, it should be obvious). A long time ago, I forgot to check this and had to wait a few days for a replacement USB stick that has GUID. It wouldn't be anything crippling (just a new USB stick), just troublesome to request trial extension and stuff like that. Would it possible to host a website (Wordpress self host for example) and also host a Telegram bot at the same time? - Yes. 2 main options are docker and VM. Docker depends on what is available in Community Applications ("CA") - if it's not on CA, you might need a tiny bit of coding skill to adapt a docker from dockerhub to work with Unraid. VM, especially in your case which sounds like you don't need PCIe passthrough, is pretty straight-forward but can be hardware dependent. What kind of hardware would that require? - "It depends" is the answer. What are you running FreeNAS on? Is it possible for the bot and website to use media and files from the NAS portion? - Yes, why not?
  6. 1 point
    I'm seeing the same problem. When I reload the page the scan starts again, does that mean no problems were found? I've included log and diagnostics files just in case. athena-diagnostics-20190718-1054.zip athena-syslog-20190718-1056.zip
  7. 1 point
    Indeed, I have been using deluge v2 for just over a week, and it is running just fine. The thin client is working well - but I do run Linux for my desktop. I like all the new features - a welcome upgrade! I also use the CouchPotato docker and have it set to use Black hole to upload torrent/magnet files to deluge - it does everything I need.
  8. 1 point
    Indeed, but only in the case where there is a major issue, i.e. ip leakage, for now using the tags is the best way of switching back to v1.x. Just to be clear deluge v2.x DOES work, however you will need to update all plugins to v2.x compatible and make sure your deluge thin client is updated (if you use that). If you dont use the deluge thin client and you dont need third party plugins then you should be good - see post #3 in this thread for more details regards current limitations.
  9. 1 point
    1--- Get a screen print or screen capture of the Drive assignments. You should not need this but having it handy will assure that you don't. 2-- Make a copy of the flash drive. Main >>> Boot Device and click on 'Flash' under the 'DEVICE' column. Under 'Flash Device Settings' section/tab, click on the "FLASH BACKUP" button. 3-- Go to Settings >>> Disk Settings and set 'Enable auto start:' to "No". The reason for doing is strictly a precaution. It allows you to verify that all the disks are correctly assigned before you start the array. It should only take a few minutes once you have removed the old controller and installed the new one. You might have to replace the SATA data cables if your Marvel controller did not use the SFF-8087 connector on the card end. 4-- You start the server and check on the main tab to see that all of your drives are correctly assigned. If they are start the array and you will be back running. Any problems or questions, post back...
  10. 1 point
    Can tell exact share names, but these exists on the cache drive, even though use cache is no B-----s domains Set those to be use cache: yes, run mover (stop the VM service first via Settings - VM), after its done, reset the shares to be se cache no.
  11. 1 point
    Hi I have been running ZM for ages and decided to try get the hooks going so I can have object notifications and not a whole lot from lighting changes. The steps I have followed are: I have the notifications running fine. I edited the zmeventnotification.ini to uncomment hook_script = '/usr/bin/detect_wrapper.sh' I have then added the hooks and face detection variables as per attached image. I then downloaded the hook folder from "https://github.com/pliablepixels/zmeventnotification" I put this in my /appdata/Zoneminder/hook folder I edited the general section of objectconfig.ini with my server IP and user name and password Then rebooted ZM docker hoping it would all fire into life. So far nothing. Notifications come in but no object identifications Im guessing there is something simple I have missed? **Update, I am seeing the error below coming up in the logs Traceback (most recent call last): File "/usr/bin/detect.py", line 8, in <module> import cv2 ImportError: No module named 'cv2' Tried re running the command - sudo pip install -r /config/hook/requirements.txt but still no luck
  12. 1 point
    You would have to give it the full path to the reboot command Sent from my NSA monitored device
  13. 1 point
    If you install the plugin it is simple enough Got to Settings->User Scripts use the option to add a new script and give it a name hover the mouse over the list of scripts and select the option to edit the script Enter the commands you want. In this case I think it is simply the ‘reboot’ command save the script set the schedule for when it is to run.
  14. 1 point
    Seems BHPhoto matched the offering, WD 10TB Elements Desktop USB 3.0 External Hard Drive
  15. 1 point
    The time zone is set from your Unraid server when the docker is started. What time do you see that is off?
  16. 1 point
    Post the entire diangnostics zip file Sent via telekinesis