Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 09/02/19 in all areas

  1. 5 points
    Thanks for the fix @bluemonster ! Here is a bash file that will automatically implement the fix in 6.7.2 (and probably earlier, although I'm not sure how much earlier): https://gist.github.com/ljm42/74800562e59639f0fe1b8d9c317e07ab It is meant to be run using the User Scripts plugin, although that isn't required. Note that you need to re-run the script after every reboot. Remember to uninstall the script after you upgrade to Unraid 6.8 More details in the script comments.
  2. 2 points
    It's not written to any permanent storage, it's written to a file in the root file system which is in RAM. Your "secret password" is only to decrypt the drives - even if the password were leaked somehow they still need the physical drives to make use of it. You'll first have to teach her to hack your root login password in order to get into your server. As @bonienl mentioned in above post we have made some changes so that casual user doesn't accidentally leave a keyfile laying around. These will appear in Unraid OS 6.8 release. In meantime, click that 'Delete' button after Starting array and, I'm done talking with you.
  3. 2 points
    It appears that the docker images --digests --no-trunc command is showing, for whatever reason, the digest of the manifest list rather than the manifest itself for containers pushed as part of a manifest list (https://docs.docker.com/engine/reference/commandline/manifest/#create-and-push-a-manifest-list). I'm not sure if that's always been the case, or is the result of some recent change on the Docker hub API. Also not sure if it's intentional or a bug. This causes an issue since in DockerClient.php (/usr/local/emhttp/plugins/dynamix.docker.manager/include), the request made to get the comparison digest is /** * Step 4: Get Docker-Content-Digest header from manifest file */ $ch = getCurlHandle($manifestURL, 'HEAD'); curl_setopt( $ch, CURLOPT_HTTPHEADER, [ 'Accept: application/vnd.docker.distribution.manifest.v2+json', 'Authorization: Bearer ' . $token ]); which retrieves information about the manifest itself, not the manifest list. So it ends up comparing the list digest as reported by the local docker commands to the individual manifest digests as retrieved from docker hub, which of course do not match. Changing the Accept header to the list mime type: 'application/vnd.docker.distribution.manifest.list.v2+json' causes it to no longer consistently report updates available for these containers. Doing this however reports updates for all containers that do not use manifest lists, since the call now falls back to a v1 manifest if the list is not available and the digest for the v1 manifest doesn't match the digest for the v2 manifest. If the Accept header is instead changed to 'application/vnd.docker.distribution.manifest.list.v2+json,application/vnd.docker.distribution.manifest.v2+json' docker hub will fallback correctly to the v2 manifest, and the digests now match the local output for both containers using straight manifests and those using manifest lists. Until docker hub inevitably makes another change. /** * Step 4: Get Docker-Content-Digest header from manifest file */ $ch = getCurlHandle($manifestURL, 'HEAD'); curl_setopt( $ch, CURLOPT_HTTPHEADER, [ 'Accept: application/vnd.docker.distribution.manifest.list.v2+json,application/vnd.docker.distribution.manifest.v2+json', 'Authorization: Bearer ' . $token ]);
  4. 1 point
    Since I can remember Unraid has never been great at simultaneous array disk performance, but it was pretty acceptable, since v6.7 there have been various users complaining for example of very poor performance when running the mover and trying to stream a movie. I noticed this myself yesterday when I couldn't even start watching an SD video using Kodi just because there were writes going on to a different array disk, and this server doesn't even have a parity drive, so did a quick test on my test server and the problem is easily reproducible and started with the first v6.7 release candidate, rc1. How to reproduce: -Server just needs 2 assigned array data devices (no parity needed, but same happens with parity) and one cache device, no encryption, all devices are btrfs formatted -Used cp to copy a few video files from cache to disk2 -While cp is going on tried to stream a movie from disk1, took a long time to start and would keep stalling/buffering Tried to copy one file from disk1 (still while cp is going one on disk2), with V6.6.7: with v6.7rc1: A few times transfer will go higher for a couple of seconds but most times it's at a few KB/s or completely stalled. Also tried with all unencrypted xfs formatted devices and it was the same: Server where problem was detected and test server have no hardware in common, one is based on X11 Supermicro board, test server is X9 series, server using HDDs, test server using SSDs so very unlikely to be hardware related.
  5. 1 point
    I'm trying to think of a way to power on a specific VM using a power button. I want to get it as close operating a normal PC as possible. Either wake it from the attached mouse/keyboard or some kind on custom made button or something that powers it on. Maybe it sends a WOL packet. I know sending a WOL packet from my phone is an option but that's not quite what I'm looking for. Any ideas? Anyone know what options there are? Maybe even something like a hacked Amazon Dash button or Raspberry Pi Zero or something? Or something less complicated.
  6. 1 point
    On a server, stability is paramount and any overclocking introduces instability. Sent from my NSA monitored device
  7. 1 point
    Actually, I think you just get from living long enough... 🤣 😈
  8. 1 point
    Don't overclock RAM with Ryzen as it's known to corrupt data in some cases, respect the max freq depending on config.
  9. 1 point
    Try this, fix is there, too: https://forums.unraid.net/bug-reports/stable-releases/dockers-wanting-to-update-but-dont-in-the-end-r618/page/2/?tab=comments#comment-5270 Sent from my SM-G975U using Tapatalk
  10. 1 point
    BTW, fix for the ACPI error is in this thread, under ACPI: https://forums.unraid.net/topic/59375-hp-proliant-workstation-unraid-information-thread/
  11. 1 point
    Thanks @bluemonster and @ljm42 That fix and User Script worked to fix my Unraid 6.7.2 Docker Update issue
  12. 1 point
    @binhex, consider adding this information to the first post. It will help new users decide which docker to use.
  13. 1 point
  14. 1 point
    no, you cannot with only one GPU, you need 2 GPU
  15. 1 point
    Suggestion for v3 -- I had a file get corrupted in my Radarr docker appdata, and had to retrieve it, and extracting the 2mb .xml file took forever because my .tar.gz backup file is huge. Can you add a setting to back up each docker container to individual .tar.gz files, rather than one enormous file?
  16. 1 point
    Thanks great work 👍 @bluemonster & @ljm42
  17. 1 point
    Thank You for the fix bluemonster Thanks for the script ljm42
  18. 1 point
    did you do this one: https://forums.unraid.net/topic/53172-windows-issues-with-unraid/page/3/?tab=comments#comment-715689 and this one https://forums.unraid.net/topic/53172-windows-issues-with-unraid/page/3/?tab=comments#comment-713069 Here is another tool called LanScan, you can use that will show what your computer is 'finding' on the SMB network and which computer is the Local Master: https://scottiestech.info/downloads/ This is a link directly to the developer's website. Please realize that this a piece of software from the general internet. Treat it as you would any other downloaded software. I have been using it for several years without a problem and recently download it again when I shifted from WIN7 to WIN10. You really want your server to be the Local Master!!!! By the way, always Google any Windows error messages that you get. Windows error messages are virtually worthless at their best and usually misleading. If you use the following terms, you will get pages of messages about this error--- (0x80070035) Win10 1903
  19. 1 point
    By manually doing this fix now do we POTENTIALLY create side effect issues when issue is officially updated and pushed as a update to Unraid? Any known reason this wouldn't be advisable to immediately do? The change does not persist through reboots, so it won't cause any lasting harm. Once unraid gets updated we'll reboot and everything will be back to normal.
  20. 1 point
    By manually doing this fix now do we POTENTIALLY create side effect issues when issue is officially updated and pushed as a update to Unraid? Any known reason this wouldn't be advisable to immediately do? Edit: once I make changes above what do I type or do to get terminal to save file? Sorry for silly questions... i follow what needs changed and kind of why but... facepalm lol
  21. 1 point
    I am from Europe. It seems to be more reliable today, the timeout now happens once I reach AWS in Seattle, which I presume is their firewall.
  22. 1 point
    I would have thought /tmp would work, but /tmp/plex would at least make sure that plex would not interfere with anything under /tmp. If you do not have enough RAM to handle these transcodes then you will have to give up on using RAM for this purpose and map it to a physical drive (probably something like /mnt/cache/appdata/plex/transcode).
  23. 1 point
    I think the LSIO ones tend to get rebuilt automatically on Friday.
  24. 1 point
    I see the same. It is reported in various threads here and one over at linuxservers forum.
  25. 1 point
    linuxserver.io I am having this same problem only with your dockers. Keeps saying there is update on all the linuxserver.io dockers I have and when I update 0kb pulled because they are up to date. It keeps doing it over and over. I tried to see if I could install a linuxserver.io docker that I don't have installed already and installs just fine. Dockers from others are not having this problem. What could be causing this?
  26. 1 point
    Same issue here (see attached). Seems someone on the LinuxServer.io forums has same issue (dunno if they're using unraid or not): https://discourse.linuxserver.io/t/dockers-say-update-ready-but-wont-update/593
  27. 1 point
    @btrcp2000 Add a second dummy vdisk let's say only 1G as Virtio. Boot your Windows and install the driver for that 1GB Harddrive. This way you can now remove the dummy file and switch your main vdisk to virtio and Windows should use the newly installed driver.
  28. 1 point
    Why does it only effect LSIO containers? Did unraid blacklist you?🤣
  29. 1 point
    TEST BUILDS FOR NVIDIA/DVB COMBINED People have asked if I'll produce a combined Nvidia/DVB build. Here's the thing, I have no intention of producing separate and combined builds, the workload is just too much for something I have no need of. It would need 8 builds on top of the Nvidia build to do so. I will however produce a combined build, depending on two conditions. 1. People don't mind an increased download size. 2. It works reliably. However I no longer have any DVB hardware so I can't test. So I've produced some combination builds for people to try out. I am only doing this for v6.7.1rc2, so if nobody tests each build then it's not going to happen. So if you want it, YOU need to test it. HOW TO USE 1. Install the Nvidia Plugin 2. Download the Nvidia build of v6.7.2 (Important - Do not use any other version and NOT the DVB version) 3. Once the build has downloaded and the window indicating the copying to flash has happened and before you reboot, download one of the attached zip files depending on which DVB build you use, unpack it and copy across the bzmodules and bzfirmware files to your flash disk. 3. Reboot I know that the Nvidia Plugin will not report the correct version number, that's an easy fix in the future if this works. Once you've rebooted I need to know two things for each build. 1. Does the Nvidia hardware encoding work with Plex/Emby/Jellyfin? 2. Does the DVB hardware work? Note: TBS-OS currently won't compile. Nothing I can do about that. https://github.com/linuxserver/Unraid-DVB/tree/master/DVB-Nvidia-Test
  30. 1 point
    I'm sticking to WinDirStat Works great!! Sent from my SM-N960U using Tapatalk
  31. 1 point
    I was able to get ZeroTier working via this Docker image relatively painlessly and am able to connect up with my phone and laptop to my array's SMB shares. However, I'm not able to access the web interface. It redirects to my unraid.net subdomain, but cannot connect to it. Is there a way I can access that remotely? I read through the thread but didn't notice any definitive steps. PS. I'm very thankful for this work. My father is terminally ill and I wanted to be at his side, but still needed access to some important resources on my array from my laptop. Being able to get this work on short notice made a huge difference for us.
  32. 1 point
    I use this script to swicth VM from the desktop. I put the switchvm.sh file at the root of my flash drive, then, I use a .bat file to call putty : "C:\Program Files (x86)\PuTTY\plink.exe" -ssh -pw password root@tower "/boot/switchvm.sh VM-1 VM-2 > /dev/null &" You just need to change the user/password and the VM-1 VM-2 parameters switchvm.sh The script shuts down the first VM, waits for it to actually shut down, and the start the second VM.
  33. 1 point
    Note to self: info here: https://packaging.python.org/tutorials/installing-packages/#ensure-you-can-run-pip-from-the-command-line pip does not work from scratch, first run: python -m ensurepip --default-pip Then optionally upgrade pip using: pip install --upgrade pip And then just install the package from https://pypi.org/project/requests/ using: pip install requests