Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 09/11/19 in all areas

  1. 1 point
    Hi guys I'm new and don't have any experience with unraid but have come across it in discussions and was wondering if anyone could help me. I am building my first server for home use, going to use a AMD Ryzen 3400G, and using the system as a NAS, plex server (only 1 transcode stream at worse case) and a Minecraft server with a max of 4 players 3 outside of my local network. I'm wondering if a Linux server or unraid would be the right way to go. Any information/advice is greatly appreciated. Thanks in advance
  2. 1 point
    Known firmware issue with that specific series (MX500) of Crucial drive. How worried? In isolation, it's fine. However, it is dangerous in the sense that you will either need to set the system to no longer alert you to the issue, or get bombarded with false alerts. Either way, it's the boy who cried wolf. If the drive actually starts having issues you won't notice as readily. I don't know of a fix that doesn't involve ignoring the error.
  3. 1 point
    Dual parity for a total of four drives is a bit overkill IMHO. Regardless of the size of the drives.
  4. 1 point
    FAQ #1 https://github.com/binhex/documentation/blob/master/docker/faq/rtorrentvpn.md
  5. 1 point
    Post arguments in the template (advanced view)
  6. 1 point
    While I understand your logic - a 10TB parity drive for a 10TB data drive and a 4TB parity drive for a 1TB data drive - that's just not how unRAID works. It's not a bug, it's by design. If you desire, you could add both the 4TB and the 1TB drive to the array and have 15 TB total data capacity all of which would be protected by the single 10TB parity drive.
  7. 1 point
    I got a WD My Book 8 TB (WDBBGB0080HBK-EESN) and after some testing it looks like a non-SMR drive. See CDM screenshot attached (the disk was 99.999% full, to make it "sweat", the test with 0% full is almost the same except the SEQ values being 199MB/s). Also test with FIO as per this post suggests it is not SMR. The summary: TEST: (groupid=0, jobs=1): err= 0: pid=4768: Tue Sep 10 22:24:49 2019 write: IOPS=7, BW=73.2MiB/s (76.8MB/s)(85.8GiB/1200024msec) slat (usec): min=353, max=4294.0k, avg=2579.76, stdev=71064.79 clat (usec): min=2, max=9319.4k, avg=69451.95, stdev=100307.35 lat (msec): min=35, max=402895, avg=136.54, stdev=4401.42 clat percentiles (msec): | 1.00th=[ 41], 5.00th=[ 47], 10.00th=[ 51], 20.00th=[ 57], | 30.00th=[ 61], 40.00th=[ 64], 50.00th=[ 67], 60.00th=[ 70], | 70.00th=[ 74], 80.00th=[ 80], 90.00th=[ 87], 95.00th=[ 93], | 99.00th=[ 114], 99.50th=[ 188], 99.90th=[ 234], 99.95th=[ 239], | 99.99th=[ 9329] bw ( KiB/s): min=19922, max=183585, per=100.00%, avg=144614.45, stdev=17834.58, samples=1226 iops : min= 1, max= 17, avg=13.38, stdev= 1.78, samples=1226 lat (usec) : 4=0.02%, 20=0.02%, 50=0.05%, 100=0.01% lat (msec) : 50=9.84%, 100=87.85%, 250=2.17%, 500=0.02% cpu : usr=0.33%, sys=0.42%, ctx=0, majf=0, minf=0 IO depths : 1=100.0%, 2=0.0%, 4=0.0%, 8=0.0%, 16=0.0%, 32=0.0%, >=64=0.0% submit : 0=0.0%, 4=100.0%, 8=0.0%, 16=0.0%, 32=0.0%, 64=0.0%, >=64=0.0% complete : 0=0.0%, 4=100.0%, 8=0.0%, 16=0.0%, 32=0.0%, 64=0.0%, >=64=0.0% issued rwts: total=0,8788,0,0 short=0,0,0,0 dropped=0,0,0,0 latency : target=0, window=0, percentile=100.00%, depth=1 Run status group 0 (all jobs): WRITE: bw=73.2MiB/s (76.8MB/s), 73.2MiB/s-73.2MiB/s (76.8MB/s-76.8MB/s), io=85.8GiB (92.1GB), run=1200024-1200024msec
  8. 1 point
    A GTX 960 should work, so there might be something else at play.
  9. 1 point
    And the different slot may mean in a whole different motherboard. IOMMU groups are dictated by the motherboard design. That's the primary reason for searching out someone who is currently running what you are trying to achieve, and copying their build exactly.
  10. 1 point
    Use the GUI to create the networks. See Settings -> Docker (Docker service must be stopped to make changes)
  11. 1 point
    On a server, stability is paramount and any overclocking introduces instability. Sent from my NSA monitored device
  12. 1 point
    Don't overclock RAM with Ryzen as it's known to corrupt data in some cases, respect the max freq depending on config.
  13. 1 point
    I would start with running MemTest from the bootmenu, ideally for 24 hours, but at the very least 2 passes
  14. 1 point
    hi, iam using the DVB-C (Cable) version of the Hauppauge WinTV Dual-HD and its working with TBS (CrazyCat) DVB-S(2) & DVB-T(2) and the tvheadend linuxserver docker container (you need to pass the device /dev/dvb)
  15. 1 point
    Happy Birthday Unraid! I started w/2 Synology NAS and after a few years, the Atom processors just weren't cutting it for what I wanted to do. So I sold them and built 2x i7 servers, one onsite and on offsite (at my brother's house) for all of my photo & video production work. I run a few Dockers and VMs and sometimes use the server as a secondary PC for video compression batching (to offload my workstation). I just got back from vacation and wished I had a "travel" server while I was on the road for 2 weeks, so I just built one out repurposing an Intel NUC i5 w/16 GB RAM and 2x 1TB SSD. Now I'll have a mini Unraid server in my hotel that can copy my work from my laptops and continuously sync back to my other 2 nodes while I'm out of the hotel room. A friend was asking me about my servers and now it looks like I'm about to help him build one out. Keep up the good work, and happy birthday!
  16. 1 point
    I made this guide for installing archlinux as VM.
  17. 1 point
    Hello. Here is my commands which i've now used 2 times to install archlinux as VM inside Unraid with EFI. I'm using latest unraid version: 6.7.2 and it's intel system. Tell me if there is any problems with it. I've used archlinux-2019.04.01-x86_64.iso Add VM --> Select Arch Machine: i440fx-3.1 BIOS: OVMF Primary vDisk Size: 20G CREATE Connect to VM ls /usr/share/kbd/keymaps/**/*.map.gz #lists all keymaps loadkeys fi #your keymap fi/en/swe etc whatever you want ls /sys/firmware/efi/efivars #checks if efi is enabled ping google.com #check that you have connection timedatectl set-ntp true #sets ntp fdisk -l #lists disks fdisk /dev/vda #open fdisk on your virtual drive ------------- fdisk /dev/vda ------------------ n >> enter >> enter >> enter >> +550M #efi partition n >> enter >> enter >> enter >> +18G #linux partition 18G for 20GB vDisk 28G for 30GB vDisk etc n >> enter >> enter >> enter >> enter #swap partition, rest of disk as swap w #writes changes --------------------------------------------------------- mkfs.fat -F32 /dev/vda1 #formats efi partition mkfs.ext4 /dev/vda2 #formats linux parition mkswap /dev/vda3 #formats swap partition swapon /dev/vda3 #sets swap partiton mount /dev/vda2 /mnt #mounts linux partition to /mnt mkdir /mnt/boot #makes boot folder inside /mnt mount /dev/vda1 /mnt/boot #mounts efi partition to /mnt/boot pacstrap /mnt base #installs arch to /mnt genfstab -U /mnt >> /mnt/etc/fstab #generated fstab arch-chroot /mnt #changes root location to /mnt aka where just installed arch timedatectl list-timezones #list available timezones ln -sf /usr/share/zoneinfo/Europe/Helsinki /etc/localtime #set your zone as default hwclock --systohc #sets hardware clock locale-gen #generates locales nano /etc/locale.conf #open/create file --------- /etc/locale.conf -------------- LANG=en_GB.UTF-8 #set your preferred language and press CTRL+X >> y >> enter ---------------------------------------------------- nano /etc/vconsole.conf #open/create file ------- /etc/vconsole.conf ---------- KEYMAP=fi #sets keyboard layout, CTRL+X >> y >> enter --------------------------------------------------- nano /etc/hostname #open/create file -------- /etc/hostname --------------- archlinux #sets hostname for your machine, CTRL+X >> y >> enter -------------------------------------------------- nano /etc/hosts #open/create file ------ /etc/hosts ----------------------- 127.0.0.1 localhost ::1 localhost 127.0.1.1 archlinux.workgroup archlinux #CTRL+X >> y >> enter ------------------------------------------------- mkinitcpio -p linux #makes initframs passwd #sets password for root exit #exits /mnt root back to live grub-install --target=x86_64-efi --efi-directory=/mnt/boot --boot-directory=/mnt/boot --bootloader-id=grub #installs grub arch-chroot /mnt #back to /mnt root pacman -S grub #installs grub package to installation grub-mkconfig -o /boot/grub/grub.cfg #same as update-grub on ubuntu exit #exits /mnt back to live reboot -f #reboots system dhcpcd #if you dont have network this gives it ping google.com #test connection -------------- GUI installation start --------------------- pacman -S lxde #installs lxde (you can install whatever GUI you want) #optional apps pacman -S firefox #installs firefox pacman -S transmission-gtk #installs transmission GUI systemctl enable lxdm #makes service to enable lxdm nano /etc/lxdm/lxdm.conf #opens lxdm config session=/usr/bin/startlxde #edit session to match as following (uncomment it) reboot -f setxkbmap fi #inside gui enviroment sets your keymapping -------------- GUI installation end --------------------- dhcpcd #if you dont have network ip link #look for your network device name eth0 or ens3 in my case systemctl enable dhcpcd@ens3 #creates startup service for ens3 ip link set ens3 up #sets ens3 up pacman -Syy #update package list pacman -Su #install updates #optional: user creation for sudoing useradd -m -s /bin/bash arch #creater new user, arch is username passwd arch #sets password for arch pacman -S sudo #installs sudo package EDITOR=nano visudo #edit sudo config arch ALL=(ALL) ALL #add this line with your username under root ALL=(ALL) ALL and CTRL+X >> y >> enter reboot -f #reboot DONE twiikker
  18. 1 point
    Highlight the file you want to edit, hit F4 or click the F4 Edit button.
  19. 1 point
    Downloaded THIS, placed in the /boot/extra folder & added a script to run after start of array. #!/bin/bash cd /boot/extra installpkg openvpn-2.4.6-x86_64-2.txz I tried just adding it to the extra folder and rebooting, but it still installed the older version requiring me to do an installpkg after.....
  20. 1 point
    I mentioned this in other threads, but this applies here too... I just did a migration of my Plex Server stuff from the Limetech repo to the LinuxServer.io repo. I got tired of waiting for a a version update so I just switched to the LinuxServer.io repo for Plex from the Limetech one since LinuxServer.io keeps theirs up to date. Here are the steps I took: [*]Make note of your container mapped custom media path settings if you have them specifically set for PMS (for instance mine map /Media to /mnt/user/Media) [*]Shutdown the Limetech PMS container, but don't delete it yet [*]Backup your appdata config for PlexMedia Server (mine was in /mnt/cache/appdata/PlexMediaServer) to another folder for safety [*]Add the LinuxServer.io Plex container. It can coexist with the other one temporarily as long as the other one isn't running since they're named differently [*]Add the mapped media path you had in the Limetech container settings if you had it set there. It's not there by default in LinuxServer.io (although you could use the /user mapping that it does come with, I prefer a direct reference for isolation) [*]The LinuxServer.io container will automatically startup after you're done setting it up and saving/apply. Access the server via the webUI and log in. [*]Once the new Plex container is up and running after initial wizards, shut that container down again. [*]With both containers shutdown, copy all the content from /mnt/cache/appdata/PlexMediaServer/Library/Application Support/Plex Media Server to /mnt/cache/appdata/plex/Library/Application Support/Plex Media Server (or whatever old and new Plex paths you have for the appdata stuff) [*]Once you're done copying all the appdata stuff, startup your new Plex container again. [*]Access the new Plex server via WebUI or from the Plex.tv site. Verify all your content, settings, channels, and custom Agents survived the transition, and that you're on the latest 1.0.0.2261 version in the Settings/Server page [*]When you're satisfied everything survived the transition, you can delete the old Plex Media Server container. [*]Update any other container paths that refer to your Plex Media Server install (i.e. the logs path for plexpy) since it will be under a new location in appdata Hope this helps.