Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 07/19/20 in all areas

  1. 2 points
    @TexasUnraid, this is 6.9.0-beta 25 release. There are still the RC releases to go before the final 6.9.0. Since you are new around here, let me share something with you. LimeTech has never released a final version of Unraid if there is a single unresolved problem. (If fact, this is the first time that they have released a beta version as a public release! It was done because a problem which some users were experiencing that could only be addressed by making this beta version available.) It has typically taken six-plus months after the release of the first rc version before the final version is released.
  2. 1 point
    希望版主和官方反馈一下,对翻译的正确度修正一下,例如重新休眠,翻译是降低速度重复,这谁知道是什么意思啊,然后希望应用商城能够对大部分常用的应用说明单独出一份中文翻译。。这样就方便多了。
  3. 1 point
    Just rebooted before responding. All meta data remained in Plex... I think it's working properly and as I mention at the top of the post, I may have been a little anxious while Plex was updating the meta data. The path I created following my favorite mentor on Youtube, "Space Invader". The plex_appdata directory I created on the cache. I should have posted this from the start: Plex AppData Source: /mnt/user/appdata/Plex-Media-Server Move to Cache Plex AppData Destination: /mnt/cache/plex_appdata/ Thanks again @ich777, Looking forward to you assistance in the future.
  4. 1 point
    Danke ... fuer die schnelle Antwort, cache hab ich nee 1tb samsung evo 860 die will ich ehh lassen, nur die Parity brauche ich nicht... Sichere alles wichtige nochmal auf ner Externen HDD .. gruss
  5. 1 point
    You may be the winner of this thread!!!!!
  6. 1 point
    When in safe mode, what's it showing for the appdata folder path?
  7. 1 point
    It might be worth posting your system’s diagnostics zip file (obtained via Tools -> Diagnostics) attached to your next post to see if we can spot anything that springs out.
  8. 1 point
    I've had 4 of the Rosewill cages for at least 5 years. I bought them because of the 120 mm fans and because they were cheap. No issues and still working well. I am careful with them because of all plastic construction, but they've held up fine. More than adequate for the few times a year when I remove the drives for cleaning or replacement. My case has a fan speed switch that I connected all 4 fans through and leave on low setting. It's pretty silent. At full speed the fans aren't really loud, but are audible in a quiet room. In my system, low speed keeps the drives sufficiently cool even during parity checks. My most recent drive purchase (Toshiba) did not sit flush in the drive tray. There are guides on the tray for which there was no corresponding opening in the drive. I just cut off the guide nubbin (an advantage of plastic construction 🙂) that was in the way and all is well. These sit behind a case door in my setup. They're not particularly aesthetically pleasing so if they were always visible I might have gone for a nicer looking cage.
  9. 1 point
    I have not seen anything that does these things exactly as you want them. The problem as I see it is that you want to use one program (like Thunderbird) for day to day use and then disconnect your backed up archive from Thunderbird to another program to view/search as an independent, separate archive. Too complicated! You'd be better off to set up your day to day use of Thunderbird to store messages offline (therefore creating your own backup archive within Thunderbird), and then backing up your entire Thunderbird profile to Unraid (not for viewing, just for backup purposes). This is basically how I have mine set up. Everything still exists within Thunderbird but I have a backup of my data. You can have Thunderbird run your profile directly off of Unraid so that it's always in somewhat of a backed up state (parity), but I've found that having your profile actively running on an SMB share causes Thunderbird to run a bit slower. I'm about to move my profile back to my local drive and only use Unraid for backup. I tried running it this way so that I could access my email data from any computer, not just my main computer running Thunderbird. Another thing I've tried and works generally fine is having Thunderbird running in a docker container and being able to access that instance of Thunderbird. I did not use a specific Thunderbird docker though. I used VNC Web Browser and manually installed Thunderbird on it, and copied in my existing profile data. Then I can access Thunderbird from a web browser. This works fine also but again is not exactly what you are looking to do. I suppose you could configure two instances of Thunderbird to semi-accomplish what you want. You have your day to day Thunderbird on PC and then this docker Thunderbird to keep an archive of your stuff -- but if you were to do that you might as well just keep everything on your PC Thunderbird to begin with. I guess my question is why don't you guys just want to keep everything in your Thunderbird? It really makes everything easier and just works. I'm open to any other thoughts, input, or ideas about this.. I myself am still trying to find what works best for me as far as running Thunderbird and maintaining data archives / accessibility on multiple pcs.
  10. 1 point
    Perhaps VS Code? https://code.visualstudio.com/docs/containers/quickstart-python Not sure if code-server in Community Applications is worth looking at.
  11. 1 point
    Should be good to go. When you start up with the new machine assign your disks to the same locations and there shouldn't be any problems.
  12. 1 point
    It simply does not work on unraid full stop for many people.
  13. 1 point
    I've never tried Jellyfin. I'd have to look into it, but it would be a bit of a longer term fix for me unless I had help. There's a few other features I want to get in. I'll put it on the list. Feel free to make an issue on my github. https://github.com/JasonHHouse/gaps/issues
  14. 1 point
    Thanks for that.... I've just been firmware "hunting", and I think I may have a fairly old bios version. I'm running an Adaptec ASR-5805 (which are old anyway), but the other Unraid box has the latest bios version that that controller has, and I don't seem to having the wrong disk problem. So I will flash the bios at my next opportunity, and I will report back. Cheers
  15. 1 point
    Thanks so much @bastl. Currently, I have so many things to test on my stack that it will cost some time until I have new results and information. But one thing seems to be quite sure: It must be the 10G card. The question now is, whether it can be fixed or has to be swapped out. Jumbo frames are the next thing I will try and after that mounting additional fans only to the card for better cooling. Next post will be, hopefully, results and clarity.
  16. 1 point
    The driver version v450.57 should fix that (that's the new one and also not the beta one, the beta was v450.51).
  17. 1 point
  18. 1 point
    I updated to 6.9.0b25 and I can successfully passthrough [AMD] Starship/Matisse HD Audio Controller without the FLR reboot issue. I have yet to test USB as my motherboard only has 1 USB controller (which just happens to have unraid on it). If anyone can validate USB works as well that would be awesome.
  19. 1 point
    @christopher2007 Found something. Maybe the cards throttling under load because of an cooling issue of the chip. https://forum.level1techs.com/t/asus-xg-c100c-heat-sink-standoffs/130065 Maybe check if the heatsink isn't loose and makes contact to the chip. I also found another thread where a user reported that after short amount of time the speeds for them dropping below 100MB/s.
  20. 1 point
  21. 1 point
    It depends on your hardware config. Typically if your hardware PCIe hardware pass-through and you can live with a VM then a VM would be a lot more convenient. I have been using my daily driver (main workstation) as a VM for years now. Having to reboot to bare metal is just a pain in the backside.
  22. 1 point
  23. 1 point
    Chinese is now available in Community Apps. New language forum is here: https://forums.unraid.net/forum/88-chinese-简体中文/
  24. 1 point
    SSD support in Linux and associated file systems has been in place quite a while and is quite mature at this point. However don't be so quick to discount advances in spinners - that industry is not going away quietly and probably will be several years before we see the last of them. With 6.9 we have introduced "multiple pools". At present this only supports btrfs pools but much of the underlying work has been done to support other types of pools (that is, formatted with a file system other than btrfs). Along with this, it gives us a path to generalize pools further and let you define multiple "unRAID" pools. This work will require changes in the unRAID kernel driver, and is naturally the time to address SSD devices in the unRAID array, as well as a few other improvements. How this work is phased into future releases is T.B.D.
  25. 1 point
    It's not anymore. You can now select some prerequisites from the NERDpack and then use pip3 to handle the install. I've edited to my go (/boot/config/go) file: # Since the NerdPack does not include this anymore we need to download docker-compose outselves. # pip3, python3 and the setuptools are all provided by the nerdpack # See: https://forums.unraid.net/index.php?/topic/35866-unRAID-6-NerdPack---CLI-tools-(iftop,-iotop,-screen,-kbd,-etc.&do=findComment&comment=838361) pip3 install docker-compose I must say that you curl solution looks clean and doesn't require setting up additional dependencies via the NERDpack in advance. Bookmarked in case the pip3 solution might fail later on EDIT: The curl solution seems to have been truncated @juan11perez. I wanted to use this in my Duplicati container but noticed that the second line is missing its end. The docker docs noted the full command: COMPOSE_VERSION=$(curl -s https://api.github.com/repos/docker/compose/releases/latest | grep 'tag_name' | cut -d\" -f4) curl -L https://github.com/docker/compose/releases/download/${COMPOSE_VERSION}/docker-compose-`uname -s`-`uname -m` -o /usr/local/bin/docker-compose chmod +x /usr/local/bin/docker-compose You may want to edit your example in case anyone want to use. Thanks!
  26. 1 point
    It is documented here in the official documentation.
  27. 1 point
    Format the stick with fat32 with default windows dialog and name it UNRAID Download zip from unraid site and unzip to stick. Than execute make bootable in usb folder on stick.
  28. 1 point
    I've written up a somewhat more off-the-wall approach to getting discrete USB to 4x VMs using only a single motherboard slot; https://mediaserver8.blogspot.com/2020/04/unraid-discrete-usb-passthrough-to.html#more
  29. 1 point
    Hi everyone, first of all, let me say hello to everyone. My first posting after nearly 1 year of using Unraid. So far i had no big issues and if there where some smaller ones it was easy to find a fix for it in the forums. I fiddled around with the topic of core assignments when i started with the TR4 platform end of last year. I thought i figured it out after doing some tests back than, which die corresponds to which core shown in the Unraid Gui. First of all my specs: CPU: 1950x locked at 3,9GHz @1.15V Mobo: ASRock Fatal1ty X399 Professional Gaming RAM: 4x16GB TridentZ 3200MHz GPU: EVGA 1050ti Asus Strix 1080ti Storage: Samsung 960 EVO 500GB NVME (Cache Drive) Samsung 850 EVO 1TB SSD (Steam Library) Samsung 960 Pro 512GB NVME (passthrough Win10 Gaming VM) 3x WD Red 3TB (Storage) After reading your post @thenonsense i was kinda confused. So i decided to do some more testing. Here are my results which basically confirmes your findings. I did some benchmarks with Cinebench (3 times in a row) inside a Win10 vm i use since end of last year for gaming and video editing. Also i did some cache and memory benchmarks with Aida64. Specs Win10 VM: 8cores+8threads 16GB RAM Asus Strix 1080ti 960 Pro 512GB NVME Passthrough TEST 1 initial cores assigned: Cinebench Scores: run1: 1564 run2: 1567 run3: 1567 Next i did the exact same tests with the following core assignments you suggested @thenonsense TEST 2 Cinebench Scores: run1: 2226 run2: 2224 run3: 2216 Both the CPU and the memory score was improved. The memory performance almost doubled!! Clearly a sign that on the second test, only one die was used and the performance wasn`t limited by the communication between the dies over the Infinity Fabric as on my old setting. After that i decided to do some more testing. This time with a Windows 7 VM with only 4 cores and 4GB of RAM to check which are the physical cores and which ones are the corresponding SMT threads. first test: assigned cores 4 5 6 7 (physical cores only) Cinebench Scores: run1: 558 run2: 558 run3: 557 second test: assigned cores 12 13 14 15 (SMT cores only) Cinebench Scores: run1: 540 run2: 542 run3: 541 third test: assigned cores 4 5 12 13 (physical + corresponding SMT cores) Cinebench Scores: run1: 561 run2: 563 run3: 560 And again a clear sign your statement is correct @thenonsense. The cores 0-7 are the physical cores and the cores 8-15 are the SMT cores. Test 2 only uses the SMT cores and clearly showes that the performance is worse than using physical cores like in test 1. I'm really sure based on my first tests last year i configured my WIN10 vm to only use the cores from one die and all other vm`s to use the correct corresponding core pairs. Clearly not. Did UNRAID changed something in how the cores are presented in the webgui in one of the last versions? i never checked if something is changed. All my VM`S run smooth without any hickups or freezes but as the tests showed the performance wasn't optimal. @limetech It would be nice if you guys could find a way to recognize the CPU if its a Ryzen/Threadripper based system and present the user the correct core pairing in the webui. Over all, i had no bigger issues over the time i use your product. Let me say thank you for providing us UNRAID Greetings from Germany and sry for my bad english ?
  30. 1 point
    Do you use ssh? I have had issues where I used screen through terminal and screen keeps accessing the array keeping it from being unmounted. Look for things that may be prevent unmounting of the array. Also, disable docker in settings and then try. Just turning them off individually may not be enough and maybe try unmounting array on its own before hitting shutdown.
  31. 1 point
    With Sandybridge or newer you can check the real frequency, with Nehalem it will only show max base frequency (no boost), SSH into your server and type: watch -n 1 grep MHz /proc/cpuinfo
  32. 1 point
    Those are some cool ideas! I'm thinking put a jpg on the root of every file system (call it nude.jpg? financials.jpg? but actually be a pic of a horses back end, or a lime). In the root, it should likely be among the first to be read or opened. Then constantly monitor it (or the first 512 bytes of it?). Any file operation on it at all would trip the alarm, setting a system event (malware_trap_tripped?), and initiating notifications, and either setting unRAID read-only system-wide (any Linux wizard know how to do that?), or looping through all open file systems and remounting as read-only any that aren't already, or just stop the array. One of the first core features we may want to request therefore is a lockdown mode and a way to trigger this, a way to quickly change all file systems to read-only. Then we let ingenious plugin writers think of ways to detect malicious activity and trigger this lockdown feature. There's nothing stopping someone from writing a plugin now that detects bad behavior and raises notifications and calls for an array stop. Anyone?
  33. 1 point
    This is an excellent area to discuss, nice idea ! OK so from my POV I am not so much interested in permissions and teaching users. That is something we have always tried to do and it just wont ever work in a scale big enough to protect enough users. But there are other things we could do: Such as.... We could have trap files that if touched put unRAID into RO mode and alert. We could watch samba logs for file write walking and after some trigger put unRAID into RO mode and alert. We could watch for file becoming encrypted (header) and if we see it put unRAID into RO mode and alert. We could have a proper IDS/Snort option We could have anonmoly usage detection based on times of day None of these are 100% but the advantage is they could ship with defaults that dont need user skills to understand, maintain or enable
  34. 1 point
    SOLVED! Solved solved solved! I can across this post from MHzTweaker: http://lime-technology.com/forum/index.php?topic=28727.msg256252#msg256252. In turn, he had posted this link: http://yannickdekoeijer.blogspot.com/2012/04/modding-dell-perc-6-sas-raidcontroller.html Sure enough, after sticking a piece of electrical tape over pins B5 and B6, the card now boots on all of my systems. Attached is a picture. Once I had flashed the card, literally the electrical tape was the thing to get it to work. I've attached a picture of the card, and below is a link to the zip file I used to flash the card. Instructions are in the file. I'll also update the LSI controller thread. https://www.dropbox.com/s/l4kadyukkh2w497/Flash%20Dell%20PERC%20H310%20for%20unRAID.zip