AndrewT

Members
  • Content Count

    122
  • Joined

  • Last visited

Everything posted by AndrewT

  1. AndrewT

    Case for a DAS?

    Fractal XL like this one has sound deadening for quiet, and if you still aren't happy, swap the fans with some noctua ones like these. I used to have this in my living room and was dead silent with the stock fans. If you also replace 3 of those 5.25-inch drive bays with a 4-in-3 drive bay like this, you'll be able to store (12) 3.5" HDDs in the case. If that's still not enough disks, here is a way to get 20 disks with that case + 4 more with the 4-in-3 above. The case isn't cheap but it's by far the best I ever had.
  2. I lose access to my server once a parity check begins, and when it finishes it remains completely inaccessible. Telnet, WebGUI, network file browsing, docker containers (MariaDB, AirSonic, NZBGet, etc) all fail to connect. USB connected keyboard doesn't respond (plugged it prior to startup) even 1 day after parity completed without error. I never received a parity completion email either, but other smaller and weaker unraid servers do both start and finish emails. This has been happening for a few months, so I attached a monitor in the rack before server startup to view any screen
  3. Thanks, @binhex! I was going through this long discussion where `mono` was described as a potential issue. Later some indicated a proxy nginx config in NZBGet may have been the issue, being unable to pass long content, with a solution here, but I didn't go on to look into that much yet. I am using the Privoxy (port 8118) connection (using binhex-delugevpn), but I don't think that's related to the reverse proxy nginx issue, so it seemed mono was the only thing to test. I haven't used SAB since unraid5 days of Influencer, but I may need to try to move back to that if NZBGet is perhap
  4. Radarr (and Sonarr) lately has been having problems connecting to NZBGet to grab completed downloads. It passes NZB files to it just fine. The settings/downloadclient "Test" connection shows "Testing NZBGet completed". Radarr also connects to Deluge and no errors are logged. I'm using all up-to-date binhex containers. Restarting containers doesn't help despite this being suggested above. The specific message I see is "Unable to connect to NZBGet. HTTP request failed: [502:BadGateway] at [http://<My_IP>:6789/jsonrpc]" where <My_IP> is the static IP address to the server.
  5. Wow, thanks! That installed it quickly and is very useful.
  6. @binhex Could `mediainfo` be added to the install here: https://github.com/binhex/arch-radarr/blob/master/build/root/install.sh#L22 ? The radarr devs continue suggesting its use to debug issues of errors handling completed downloads with messages containing "has a runtime of 0, is it a valid video file?" When I perform `ls -lh <movie>` it returns reasonable sizes, so I'm trying to now test if mediainfo calls within radarr is just having an issue. All mkv and mp4 tested play on VLC Player as well.
  7. https://unraid.net/pricing currently indicates the Pro license has "Unlimited attached storage devices" which I find a bit deceptive if there truly is a hard limit. When I took my array off-line, I see I can go up to 30 slots in the array section, but I'm unsure if the cache disks count against that 30 disk maximum and whether parity disks count against the 30 too.
  8. I never knew the XML files were on the flash drive! I cleaned those up, removing old ones I'll never use again. The new username and password were saved in there as expected. The docker image file was the culprit. OP perfectly explained how to do it, and not too scary even for 16 containers. Seeing all the custom config info saved on the flash drive helped before deleting the img file. Thanks for the help!
  9. @binhex that's what I did to change the username and password. Left click icon -> "Edit" -> change "Key 2" (VPN_USER) and "Key 3" (VPN_PASS) -> "Save". The new username and password are retained there and don't change when I start the container. Each time I try to start the docker container, it immediately changes the binhex-delugevpn/openvpn/credentials.conf file to the old username and password, so of course it returns a can't connect error. Just changing Key 2 and Key 3 doesn't work, so I'm curious where else the user and password are saved? It looks like when the container star
  10. I just got a new username and password from PIA. I changed the two fields in the Docker XML GUI editor (https://TOWER/Docker/UpdateContainer?xmlTemplate=edit:/boot/config/plugins/dockerMan/templates-user/my-binhex-delugevpn.xml), clicked "Save", and noticed it didn't change the 'binhex-delugevpn/openvpn/credentials.conf', so I changed that as well. Going back to that XML I see the new username and password are saved. When I clicked to start the Docker container, I saw in the log "SIGTERM[soft,auth-failure] received, process exiting" and when I `cat credentials.conf` I noticed the old user and
  11. Thanks @johnnie.black! I'm using Chrome Version 63.0.3239.132 (Official Build) (64-bit) on a vanilla Ubuntu 18.04 OS and have entries saved, so I see the space wasn't lacking in my cmd in the WebGUI. I edited my original post to avoid another person copy/pasting the wrong cmd. There might be an issue with my browser/OS still, because copy/pasting cmds with "code" formatting in this forum doesn't work despite no unusual formatting appearing when I put it into Sublime Text first. For example, the two cmds @John_M print usage errors and the text is clearly correct. When copy/pasting this hap
  12. Wow, that might've worked! Immediately after entering that into terminal, the WebGUI had a orange menu pop up indicating unRAID Cache disk message: 05-05-2018 11:16 Warning [TOWER] - Cache pool BTRFS too many profiles WDC_WD5001FZWX-00ZHUA0_WD-WXA1D6542HUS (sdn) This warning almost seems indicative of RAID conversion activity After 5 min, nothing yet has printed to stdout or stderr, but I can see the command still running with `htop` and both disks in the Main WebGUI show active read/write speeds (170 ~MB/s max). I'll update as solved after it complete
  13. My issue sounds the same as a recent post here, but the solutions didn't work. The command recommended in the FAQ -dconvert=raid0 -mconvert=raid1 looks to issue the command properly in the syslog but does nothing. No errors are printed in the syslog or in the WebGUI. I restarted the server, re-issued the command, and still no conversion. my btrfs balance status: Data, single: total=1.95TiB, used=1 .94TiB System, single: total=32.00MiB, used=240.00KiB Metadata,g single: total=5.00GiB, used=3.69GiB GlobalReserve, single: total=512.00MiB, used=0.00B No balance f
  14. I've had issues deleting items in Deluge, whether it's a few or many (80-100s). When I select all, right click "Remove Torrent" and select "Remove With Data", I've never got a rapid response. The menu stays up, and clicking a second or third time still doesn't remove the menu. Often a few seconds later, I get a weird "The connection to the webserver has been lost!" and get kicked out of the webserver. When I go back in a few seconds later the files are usually removed. I don't think this an issue unique to binhex's version, but what are others doing to cleanup occasionally? Maybe skip the webs
  15. @dmacias thanks for the addition. Now with jq, it's easy to cleanup the movies list when it get too large from "Lists" adding too many. The HOST and API_KEY vars have to be assigned. #!/bin/sh HOST=http://serverIPaddress:7878 #Radarr port default is 7878 API_KEY=32charString #Radarr > Settings > General ids=$(curl --silent $HOST/api/movie -X GET -H "X-Api-Key: $API_KEY" \ | jq '.[] | select(.monitored == true) | .id') for id in $ids; do echo "Deleting movie id $id" curl --silent $HOST/api/movie/$id -X DELETE -H "X-Api-Key: $API_KEY" done Also, to batch clean
  16. Could `jq` be considered to add as an install option in the Nerd Tools pack? https://stedolan.github.io/jq/ It's a simple JSON parsing binary and an example use case for it is to mass remove movies from Radarr. I tried using some of the lists in Radarr and it added far too many movies, so I'd like to wipe them clean but would take a lot of effort to just wipe the Radarr Docker and reconfig everything. The shell script that uses `jq` is here: https://gist.github.com/pstadler/bc0afefe35f608e9552e764b31f45f19
  17. Thanks! It's especially useful to know the parity numbered disks do matter. The config/super.dat is a binary file... no wonder grep -e 'WDC_' -e 'HGST_' -e 'ST4000' didn't work anywhere in the flash that I looked edit: After each server was shutdown, moving the super.dat files between the server flash drives worked well. After booting up (autostart array turned off on both), it allowed me to change the cache disks before starting the array.
  18. I have two unraid servers but one holds half the disks/slots, so I need to physically swap the array disks. I'd like to keep my cache and usb drives where they are. I can't backup my array data until this is done, so I just wanted to make sure I fully understand the process. Johnnie Black had a recent post that helps but just want clarity from this, because I can't see what options I have after clearing the disk config until I do so: 1) For each server, save the info listed in the webGUI's Main of "Device" and "Identification" mappings. 2) Use the webGUI's Tools -> "N
  19. Since your secondary (backup) server is at a different location, that makes me wonder if it's usually powered off? If so, you might find it easiest to just create a cron job to execute a simple shell script that involves wakeonlan and rsync. For now, I open a `screen -S share_name` and rsync one share, open another screen and do a second share. I've asked for guidance on the best rsync options to use but didn't seem to get much of an answer, perhaps because it might be more tailored to each person's needs. For example, how you handle symbolic links. This is what I use o
  20. If you don't want a command line program, check out https://mediacompanion.codeplex.com/ I use it for TV Shows and Movies. It unify your collection with renaming, fetch art/metadata, even trailers.
  21. After restarting the server I can now telnet in.
  22. I have two unraid boxes with the same OS 6 version. On one, I am able to `telnet <IP-address>` then enter root as user and a password I have saved from the WebGUI address <IP>/Users/UserEdit?name=root but the other server I'm unable to do the same. On both, I am able to access the WebGUI just fine with my password. I also tried re-entering my password in the WebGui for the server I can't telnet into, clicked "Change", then "Done" but still am unable to telnet into the system. What could be wrong?
  23. Gosh, sorry, yes `dd if=/dev/sdo of=/dev/sdk bs=4k conv=noerror,sync status=progress` is working as expected to copy the disk. If it finishes without error, do I then pull out the sdo drive off the "Disk 4" slot on the array and re-start the array with sdk in place?
  24. Mount it, so it has a path to give dd of=<path>