Xardis

Members
  • Posts

    9
  • Joined

  • Last visited

Posts posted by Xardis

  1. 2 hours ago, ich777 said:

    Like the post says, you have to click on "Show more settings ..." in the template then change the value from "2456" to something like "2466", then delete the entry "UDP - Game Port Range" entirely, then click on "Add another Path, Port, Variable, Label or Device" from the drop down select "Port" at container port enter "2466-2468", at host port enter "2466-2468", at connection type select "UDP" from the drop down, click on "Add" and "Apply".

     

    Now you have a server running on port 2466.

     

    This is how the new entry should look like:

    grafik.png.484bb15969aff9563c931d1d9f041c53.png

    Yes, this is exactly the part I missed. I didn't pick the correct Config Type on this step. When I recreated with Port configured, it worked great! Thanks for your response - much appreciated!

    • Like 1
  2. 2 hours ago, ich777 said:

    Can you give me a screenshot from your template please?

    I think I fixed this myself, root cause was user error. When I created the new port range, I didn't pick the right option in the drop-down menu - picked variable instead of port. Now the port redirection appears to be working properly.

    • Like 1
  3. On 3/2/2021 at 4:02 PM, ich777 said:

    Yes, but you do this with the Variable in the 'Show More Settings' section of the Template.

     

    Keep in mind that for every container the Game Port itself has to be set in the GAME_PORT variable like mentioned above.

     

     

    This is the way you would do it (this is tested and working btw):

    grafik.thumb.png.a3e4e22653cc2a5543daed533a251f69.png

     

    I have a question about this process. I'm trying to setup a second Valheim server. I installed a second copy of the Valheim container and set it up with different variables. I tried deleting the value from UDP - Game Port Range and added updated ports to the GAME_PORT section.  However, when the container starts, it's not remapping any ports at all. It's still trying to use the default 2456 range.

     

    Next, I tried removing the UDP - Game Port Range section completely and added the ports in the GAME_PORT section. Now, no networking values are created.

     

    What is the proper way to add a second server with this container?

  4. 49 minutes ago, hogfixer said:

    Hello,

     

    Grasping at straws here.  What repository for influxdb are you using?  is it "influxdb:1.8.4-alpine"? 

     

    image.thumb.png.c83753f956a3b238fdf06006494c9727.png

     

    See this message 

     

    Edit - updating the repository worked like a charm! Thank you very much!

     

    Hey - thanks for the reply. I don't really know all of the different variables needed to help solve these issues yet - I'm very new to troubleshooting these contains. I'm using the repository - "influxdb:alpine". I'll review this post as well and try modifying my repository to this version as well. Everything is pointing to a permissions issue with logging in, but I know I've got the correct username/password combo configured.

  5. Hi everyone -- new user here trying to perform initial setup. I've followed the guide and setup the telegraf.conf file per the documentation and the InfluxDB output settings. For some reason when I go to start up Telegraf, I get a 401 unauthorized error when telegraf attempts to create the telegraf db. I've tried to configure a token, but that variable isn't recognized. I tried setting up a username and password and updated those settings in the telegraf.conf file but no luck. output.influxdb config settings and error are below.

     

    outputs.influxdb config

     

    # Configuration for sending metrics to InfluxDB
    [[outputs.influxdb]]
      ## The full HTTP or UDP URL for your InfluxDB instance.
      ##
      ## Multiple URLs can be specified for a single cluster, only ONE of the
      ## urls will be written to each interval.
      # urls = ["unix:///var/run/influxdb.sock"]
      # urls = ["udp://127.0.0.1:8089"]
    urls = ["http://myprivateip:8086"]

      ## The target database for metrics; will be created as needed.
      ## For UDP url endpoint database needs to be configured on server side.
      #  database = "telegraf"

      ## The value of this tag will be used to determine the database.  If this
      ## tag is not set the 'database' option is used as the default.
      # database_tag = ""

      ## If true, the 'database_tag' will not be included in the written metric.
      # exclude_database_tag = false

      ## If true, no CREATE DATABASE queries will be sent.  Set to true when using
      ## Telegraf with a user without permissions to create databases or when the
      ## database already exists.
      # skip_database_creation = false

      ## Name of existing retention policy to write to.  Empty string writes to
      ## the default retention policy.  Only takes effect when using HTTP.
      # retention_policy = ""

      ## The value of this tag will be used to determine the retention policy.  If this
      ## tag is not set the 'retention_policy' option is used as the default.
      # retention_policy_tag = ""

      ## If true, the 'retention_policy_tag' will not be included in the written metric.
      # exclude_retention_policy_tag = false

      ## Write consistency (clusters only), can be: "any", "one", "quorum", "all".
      ## Only takes effect when using HTTP.
      # write_consistency = "any"

      ## Timeout for HTTP messages.
      # timeout = "5s"

      ## HTTP Basic Auth
    username = "telegraf"
    password = "mypassword"

      ## Token for authentication
      # token = "$INFLUX_TOKEN"

      ## HTTP User-Agent
      # user_agent = "telegraf"

      ## UDP payload size is the maximum packet size to send.
      # udp_payload = "512B"

      ## Optional TLS Config for use on HTTP connections.
      # tls_ca = "/etc/telegraf/ca.pem"
      # tls_cert = "/etc/telegraf/cert.pem"
      # tls_key = "/etc/telegraf/key.pem"
      ## Use TLS but skip chain & host verification
      # insecure_skip_verify = false

      ## HTTP Proxy override, if unset values the standard proxy environment
      ## variables are consulted to determine which proxy, if any, should be used.
      # http_proxy = "http://corporate.proxy:3128"

      ## Additional HTTP headers
      # http_headers = {"X-Special-Header" = "Special-Value"}

      ## HTTP Content-Encoding for write request body, can be set to "gzip" to
      ## compress body or "identity" to apply no encoding.
      # content_encoding = "gzip"

      ## When true, Telegraf will output unsigned integers as unsigned values,
      ## i.e.: "42u".  You will need a version of InfluxDB supporting unsigned
      ## integer values.  Enabling this option will result in field type errors if
      ## existing data has been written.
      # influx_uint_support = false

     

    Error from telegraf log

     

    021-08-28T03:41:43Z W! [outputs.influxdb] When writing to [http://myprivateip:8086]: database "telegraf" creation failed: 401 Unauthorized
    2021-08-28T03:41:53Z E! [outputs.influxdb] E! [outputs.influxdb] Failed to write metric (will be dropped: 401 Unauthorized):