mika91

Members
  • Posts

    26
  • Joined

  • Last visited

Posts posted by mika91

  1. I do not understand.

    This setting controll  array notification frequency, isn’t it?

    You say that it will send notification  regardless the status?

    So what the meaning of notification level settings ?

     

    What I need is to check array health once a day, and send email only for failure.

    How to achieve that?

  2. Hello @mgutt,

     

    Nice work with this power consumption tweaking guide !

    I use this script from many years on my nas (OMV then Unraid), without any problem. (6 sata HDD with spindown + 2 sata SSD, DVB-t tuner)

    It's basically setting pci/sata power management to auto.

     

    I'll try your undervolting guide as soon as I have free time. ^^

     

     

  3. Hi,

     

    Just installed the swag container yesterday, and all is working fine so far.

    Now I need to limit access to the services.
     

    Regarding access control, after reading documentation and config files, it seems choice are: basic auth, ldap, authelia or organizr auth.

    Except for jellyfin, all other services just need authorization (sonarr, radarr, jackett, qbitorrent, ...) 
    I'd like to keep it as simple as possible, as well at configuration side but for user experience too.

    Ideally:

    • login once, then access all services (except Jellyfin as it needs authentication and do not support OIDC)
    • centralize unraid users with reverse proxy ones: active directory / ldap ?
    • web ui to add/edit users 

    Another point is to get access to my docker services both on external an local network.

    Is there a way, with some kind of DNS override, to access my services locally using the xxx.duckdns.org URL (when connected to my local network, xxx.duckdns.org will redirect to the unraid box IP)

    Maybe using a services dashboard like heimdall/organizr/ombi, will help to access service 'transparently' whatever local or external ?

     

    Thanks

  4. Sure, nothing complex.
    Just run

    powertop -r powertop.html

    Then you move the file wherever you can open it with a web brower.
    Go to the 'tuning' tab, and copy/paste the tweaks  you want to apply in the /etc/boot/go file

    My go file looks like

    #!/bin/bash
    
    # -------------------------------------------------
    # Start the Management Utility
    # -------------------------------------------------
    /usr/local/sbin/emhttp &
    
    # -------------------------------------------------
    # enable jellyfin hardware transcoding on intel
    # -------------------------------------------------
    modprobe i915
    chown -R nobody:users /dev/dri
    chmod -R 777 /dev/dri
    
    # -------------------------------------------------
    # fix seagate not stay spun-down
    # -------------------------------------------------
    #hdparm -B 255 /dev/disks/by-id/ata-ST3000DM001-1CH166_Z1F59K90
    
    # -------------------------------------------------
    # powertop tweaks
    # -------------------------------------------------
    # Enable SATA link power management
    for i in /sys/class/scsi_host/host*/link_power_management_policy
    #do echo 'min_power' > $i;
    do echo 'med_power_with_dipm' > $i;
    done
    # NMI watchdog should be turned off
    # echo '0' > '/proc/sys/kernel/nmi_watchdog';
    
    # VM writeback timeout
    echo '1500' > '/proc/sys/vm/dirty_writeback_centisecs';
    
    # Runtime PM for I2C Adapter (i915 gmbus dpb)
    for i in /sys/bus/i2c/devices/i2c-*/device/power/control
    do echo 'auto' > $i;
    done
    
    # Autosuspend for USB device
    for i in echo /sys/bus/usb/devices/*/power/control
    do echo 'auto' > $i;
    done
    
    # Runtime PM for disk
    for i in /sys/block/sd*/device/power/control
    do echo 'auto' > $i;
    done
    
    # Runtime PM for PCI devices
    for i in /sys/bus/pci/devices/????:??:??.?/power/control;
    do echo 'auto' > $i;
    done
    
    # Runtime PM for port ata od PCI devices
    for i in /sys/bus/pci/devices/????:??:??.?/ata*/power/control;
    do echo 'auto' > $i;
    done
    
    # Disable wake on lan
    ethtool -s eth0 wol d
    
    
    

    Finally, export another report and verify all tweaks are applied.

  5. ok, so I created a new 'my-bridge' network as suggested, and put all my containers in.

    And now it's working, I can ping containers using their name.

     

    I guess there is a good reason to explain why DNS it's not working on default bridge... 
    But for anyone dealing with reverse proxy (or any containers interaction such as bazarr with sonarr/radarr), the feature is missing
    And because unRAID is docker/VM oriented, maybe a better documentation and/or UI (create network, use a default network with dns feature, ...) would be an improvement.

     

    Whatever, the community and forum are very responsive ;)

    Thanks
     

     

  6. 3 minutes ago, shaunmccloud said:

    Are you using the default bridge network or did you create your own?  For pinging by name to work you need to create your own.

    I use the default one.

    I'll try with a custom network (strange that it works with default bridge network, using docker-compose on OMW)

     

    Thanks

  7. Hi,

     

    I can't succed to ping container from another container using its name !


    All my containers are in the same 'bridge' network.
    When I run 'docker inspect'  command, I see all the containers (sonarr, radarr, bazarr, jellyfin...)
    But if I open a console on a container, a 'ping sonarr' returns 'Name does not resolve'

     

    The --name argument is set for all containers.

    Let's see dns files in a container:

     

    /etc/resolv.conf

    # Generated DNSv4 entries:
    nameserver 192.168.1.11  # pi-hole docker adress
    nameserver 1.1.1.1
    nameserver 1.0.0.1

    /etc/hosts

    127.0.0.1       localhost
    ::1     localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    172.17.0.9      7677bf67772b


    Any help ?
    Thanks

  8. Done some more tests tonight.
    All docker containers stopped.

     

    Manually spin-down the 'faulty' disk -> hdparm staus is 'standby'

    After 15 minutes exactly, the disk spin up (butunraid continue to mark it as spun-down)

    I checked 'file activity', it's clear: nothing on any disk.

    Could it be a firmware issue of the disk (seagate barracuda 7200 ST3000DM001), or a tweak needed ?

    However, it sounds unraid rely on the command it sends to the disks to determine their status (no 'real-time' status)

  9. It's an empty data disk.
    If I press manually the spindown/up buttons in the GUI, it responds accordingly. (and hdparm -C command reflects it)

    But after a certain time, the disk spin up (hdparm confirm it) but stay 'standby' in the dashboard.

    No file activity. (excpect on /mnt/cache)

     

  10. Hi everyone,

     

    I have trouble with disk spinning down too, but only with one of them.
    The others go and stay spin down correctly.

    In the dashboard tab, the disk status is'standby', but it spins in reality.

    If I run a hdparm -C command, its state is active.

     

    So what command uses unraid/dashboard to say the disk is active/standby ?

     





     

  11. Hi,

     

    Just migrate from OMV to Unraid
    I have 3 data disks, one parity and 2 SSD cache disks.

    Now I wonder how parity works when moving data between disks, using CLI (mv /mnt/disk1/stuff/* /mnt/disk2/stuff/).

    Do I need to launch a job to re-compute the parity (as snapraid), or it's done automatically ?(even if I don't mv/copy through /mnt/user(0) folders)
     

  12. Hello,

    I try to configure a reverse proxy in my VPS.
    For now, I have my docker services (portainer, whoami, grafana, prometheus, ....) available through XXX.mydomain.duckdns.org (and basic auth for each services).

    Pretty happy with it... but have twho minor problems:

    • Fail to use Deluge with reverse proxy: get a '502 bad gateway'
      I enable the proxy-conf as for other services, witout success. 
      Try with/without basic auth
       
    • Is there a way to 'share' the auth, so I don't need to login for each service ? (looking for a simple solution)

    Thanks for your help
    Mickaël