spants

Community Developer
  • Posts

    621
  • Joined

  • Last visited

  • Days Won

    1

Posts posted by spants

  1. 3 minutes ago, danioj said:

    That makes sense. Loss of data availability and time to fix an issue is I agree something you would prefer to not have to deal with. Hope all is back up and running for you. 


    Thanks - Still working on it in the background 🙂
    I use Proxmox as a Hypervisor with unRaid as a VM. I was in the process of removing encryption from my drives for the possibility of moving the drives to a MergerFS and Snapraid system on the host instead of unRaid (or possibly ZFS).

  2. 2 hours ago, danioj said:


    I’ve stepped back from the forum in recent times but felt compelled to login and respond. 
     

    (Un)Raid is not for backup, it’s for for availability. If you are sensitive to “Loss” of data you should take appropriate steps to back it up based on your risk appetite for the unexpected. 

     

    I had the same problems - I spent hours trying to fix and ordered a replacement drive. It is the potential loss of online data and TIME that caused me headaches.

    • Like 1
    • Upvote 1
  3. 21 hours ago, goinsnoopin said:

    Update to post above:  

     

    I rolled my docker tag from latest to the 3.0.1 release of about a month ago and all functions as it is supposed to.

    The releases 3.0.1-1 (23 days ago) and 3.0.2 (16 days ago) I get the error above.   For now I am staying rolled back to 3.0.1 release.

     

    Please check with the owner of node-red-contrib-power-monitor as it may be an issue there (npm/node version?). The template just loads the official nodered docker so there is nothing that I can do to fix it.

  4. I havent pulled any templates!

     

    My pihole template pulls the offical pihole docker and I have not modified that in any way. Unraid 6.10+ caused some issues with permissions with docker data files that the template doesnt change because I am not modifying the docker. Work arounds have been discussed previously.

     

    Note that I have moved to Proxmox, with unRaid as a VM and Adguard as an LXC, so I dont use pihole anymore. Hopefully existing users can support if I can't.

     

    For people with 'port already in use' errors - you need to give pihole its own IP address on a custom/bridged network as it cannot share the same address as unraid.

  5. Hi all,

    As you are discovering, this docker is quite old and needs to be updated. If you can bear with me, please try the manual steps to get a later version of MQTT and solve permissions problems.

     

    Please follow these steps and stop any existing MQTT container. I am using a directory called "/mnt/user/appdata/mos/" for my config - change if you wish.

     

    1) In a shell on unRaid, create the mosquitto directories

     

    mkdir -p /mnt/user/appdata/mos/config
    mkdir -p /mnt/user/appdata/mos/data
    mkdir -p /mnt/user/appdata/mos/log

     

    2) create a configuration file

    nano /mnt/user/appdata/mos/config/mosquitto.conf

     

    with the following text

    persistence true
    persistence_location /mosquitto/data/
    user mosquitto
    # Listen on all interfaces 
    listener 1883
    #Allow connection without authentication
    allow_anonymous true
    log_dest file /mosquitto/log/mosquitto.log
    log_dest stdout

     

    3) Set the ownership of the directories to nobody:users

    chown -R nobody:users /mnt/user/appdata/mos

     

    4) download and start the docker (called mqttnew for testing)

    sudo docker run -itd -p 1883:1883 -e PUID=1000 -e PGID=1000 \
    --name=mqttnew \
    --net=bridge \
    -v /mnt/user/appdata/mos/config:/mosquitto/config \
    -v /mnt/user/appdata/mos/data:/mosquitto/data \
    -v /mnt/user/appdata/mos/log:/mosquitto/log \
    eclipse-mosquitto

     

    If you want to add users and disable anonomous logins:

    5) On the running docker icon, right click and choose CONSOLE and type: (replace <username>)

    mosquitto_passwd -c /mosquitto/config/credentials <username>

     

    6) stop the docker

    7) edit the /mnt/user/appdata/mos/config/mosquitto.conf file

    nano /mnt/user/appdata/mos/config/mosquitto.conf

     

    to look like:

    persistence true
    persistence_location /mosquitto/data/
    user mosquitto
    # Listen on all interfaces 
    listener 1883
    #Allow connection without authentication
    allow_anonymous false
    log_dest file /mosquitto/log/mosquitto.log
    log_dest stdout
    password_file /mosquitto/config/credentials

     

    8 - test and let me know how you get on. I will template this if it works for all.

     

     

    • Thanks 2
    • Upvote 1
  6. I have now virtualised my unraid in proxmox. I passed through the sas falcon controller (ibm something flashed to IT mode), GTX 1060 for Emby transcoding, a couple of usb devices including the unraid usb stick, enocean usb and usb zigbee controller. I created a BOND network interface and used this as an E1000 network card. The paravirtualised network card dropped packets (as detailed before). 

    It is all working great! 

     

    On the same proxmox - Opnsense (in is dedicated network port, out is network BOND), MQTT LXC container, Home Assistant Virtual machine, NodeRed LXC for testing, and Zorin VM.

     

    Server is a Asus Strix x570-F board, AMD 5900 with 64GB ram.

  7. 12 minutes ago, live4soccer7 said:

    @spants Yes, they are all there. I have done everything suggested in the forum/thread here.

     

    image.thumb.png.f05d6626c68da3c874201322bcb39363.png

     

    I'm quite stumped on this. I'm thinking of nuking the whole thing. Deleting the image and the appdata folder for MQTT and installing again from scratch.

     

    I don't think there is much in the folder itself that would need to be saved. Without persistence, I think it would just be the mosquito.conf and the passwords.mqtt. I could manually open those with nano and copy the contents.

     

     

    Yes you could do that. I had to CHMOD my directory as the persistence db wasnt saving.

     

    Just rename it after stopping the docker.... and then restart. You may have to set the permissions on the new directory.

  8. 34 minutes ago, live4soccer7 said:

    After updating Unraid to 6.10 today, I was unable to start MQTT.

     

    1653129413: mosquitto version 1.4.8 (build date 2020-01-27 00:25:20+0000) starting
    1653129413: Config loaded from /config/mosquitto.conf.
    1653129413: Error: Unable to open pwfile "/config/passwords.mqtt".
    1653129413: Error opening password file "/config/passwords.mqtt".
    1653129593: Error: Unable to open log file /config/log/mosquitto.log for writing.
    1653129593: mosquitto version 1.4.8 (build date 2020-01-27 00:25:20+0000) starting
    1653129593: Config loaded from /config/mosquitto.conf.
    1653129593: Error: Unable to open pwfile "/config/passwords.mqtt".
    1653129593: Error opening password file "/config/passwords.mqtt".

     

    I have probably 25 other dockers that didn't have an issue. I've had this MQTT docker installed for years and never ran into this. I checked the GUI UID in the settings and they're proper. I did attempted to do a chown -R, but that was unsuccessful. I am also unable to access the mqtt folder through the Windows Network share on a remote machine on the network. I can access any other folders. I find this a bit strange, any ideas? I have a lot of things that run through MQTT, so it is quite important to get back up and running.

     

    if you shell on to unraid can you see the directory?
    can you use the filemanager plugin to see if the files are there?
    You might have to CHMOD -r 777 (or just RW privs) on the mqtt app directory (beware of the consequences!) as unraid changed the permissions/owners for appdata a while back

     

    Let me know how you get on.

    I use 6.10 with lots of mqtt clients with this. I should really get around to looking at building a more modern mqtt broker and template....

     

     

     

  9. 1 hour ago, abra5umente said:

    It seems as though every day this breaks for me - when I restart the docker after doing a backup, it moves all the keys around, resulting in the key for the USB ID of the printer being changed to the setting for camera, etc.

    I don't have a camera plugged in and I have removed those entries to allow it to start - it works fine until it restarts and then it dies, so I have to reinstall it again.

     

    Any workaround?

     

    If you use the "by-id" serial identification this won't happen as it uses the identity of the printer.  If you use ttyACM0 or ttyUSB1 methods, these can change

     

  10. On 3/19/2022 at 8:55 PM, 007craft said:


    When I use /dev/serial/by-id/usb-1a86_USB_Serial-if00-port0 (The only entry I have, and is indeed my printer as when I unplug it, that entry goes away), it doesn't work.  But when I use /dev/ttyUSB0 it works.  Why is this?

     

    I have no idea - it should work! (sorry, I know that isn't a proper answer. I will reinstall my setup and check in a couple of days)

  11. 11 hours ago, 007craft said:

    Is there a way to get multiple webcams working with this template?  I know it can be done, and theres an octoprint plugin to view multi webcams easily and octolapse also works with multiple webcams.  I just cant figure out how to pass multiple cameras into the container.  A second mjpeg streaming instance needs to be made for the second webcam I believe.

     

    You probably could by adding extra keys, but you can also spin up another docker (use one for each printer)-that is what I did!

     

  12. 54 minutes ago, bdydrp said:

    Not sure if i should post this in this mqtt thread or Nginx Proxy Manager thread, but since i have NPM woking for other proxys, i thought i would start here

    What i would like to do is be able to reach my mqtt broker form outside my local network. 

    I have a duckdns name set..eg. mymqtt.duckdnsorg

    In NPM have a a host a ssuch

    image.png.8d84df5576b4daecfbfc4d168d9ea48c.png

     

    But on my phone or nodered i cant access my mqtt broker

    Is this possible to achieve?

     

    I know i can leave my vpn running 24/7 on the phone, and just access it that way. but i'm looking for a different solution so i dont have to do that on my wifes phone

     

    Cheers

     

    just create a strong user/password and use port forwarding from your router to the mqtt port?. 

  13. 8 hours ago, OneMeanRabbit said:

    I'm getting a weird situation with node-red specifically (tried multiple images - same issue).  When it pulls the image and tries to copy /data into my persistent mapping - it fails.  It specifically is creating folders/files with:

     

    sonny:ssh-allow

     

    permissions, but I cannot figure out how to solve it....This is my exact issue!  And here - forces 1000 or 1001 UID which makes sense because that matches the user (not sure where "ssh-access" comes from) my /etc/passwd file.

    Solution attempt #1 - kinda fixes it - Tried adding "--user nobody" to Extra Parameters, and it at least installs and runs immediately..but with sonny:1000 vs. sonny:ssh-access...

     

    Every other docker I have doesn't do this and most use nobody:users - especially when I set PGID/PUID/UMASK variables.  I tried doing manually adding those specific variables, but no dice. 

     

    I've googled everywhere, and it *maybe* a recent sshd_config change since 6.9?  Anyway I can force the docker to run with specific permissions nobody:user?

     

    yes, I see a few people on the internet see the same problem. I wonder if adding 

    --user="nobody:users"

    to extra parameters would make a difference?.
    Otherwise you may have to chmod the data directory = 
    https://github.com/node-red/node-red-docker/wiki/Permissions-and-Persistence

  14. On 1/19/2022 at 10:06 PM, jeuser said:

    Hello,

    is this the right place for support for the "zigbee2mqtt"-docker?

     

    I tried to setup it and also edited the configuration.yaml but it won't start.

    What does "- frontend must be object" mean in the log?

     

    Thank you. 🙂

     

    homeassistant: false
    permit_join: true
    mqtt:
      base_topic: zigbee2mqtt
      server: mqtt://192.168.1.163
      user: loxberry
      password: PASSWORD
    serial:
      port: >-
        /dev/serial/by-id/usb-ITead_Sonoff_Zigbee_3.0_USB_Dongle_Plus_3c97c5fcdac9eb1194998f4f1d69213e-if00-port0
    advanced:
      homeassistant_legacy_entity_attributes: false
      legacy_api: false
    device_options:
      legacy: false
    frontend:
    port: 9442

     

    Using '/app/data' as data directory
    
    
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    READ THIS CAREFULLY
    
    Refusing to start because configuration is not valid, found the following errors:
    - frontend must be object
    
    If you don't know how to solve this, read https://www.zigbee2mqtt.io/guide/configuration
    
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

     

     

     

    Its not my docker, but did you fix it? I use the zigbee2mqtt docker as well so I will try and help

    • Like 1
  15. On 1/24/2022 at 5:59 PM, Shrike said:

    Any chance of changing the underlying node-red image to 2.1.6-16 so it'd be possible to use addons that require NodeJs 16?

     

    2022-01-24T17:58:54.815Z [err]  Not compatible with your version of node/npm: node-red-contrib-discord-advanced@3.1.1
    2022-01-24T17:58:54.815Z [err] npm ERR! notsup Required: {"node":">=16.6.0"}
    2022-01-24T17:58:54.815Z [err] npm ERR! 
    2022-01-24T17:58:54.815Z [err] notsup Actual:   {"npm":"6.14.15","node":"14.18.2"}

     

     

    You can change your own: chgange the repository field to  nodered/node-red:2.1.6-16

  16. 1 hour ago, Andiroo2 said:

     

    I just tried a fresh pull and still the same behaviour.  I can't get the GUI to load, but the system reports positive status:

    pihole status
    
      [✓] FTL is listening on port 53
         [✓] UDP (IPv4)
         [✓] TCP (IPv4)
         [✓] UDP (IPv6)
         [✓] TCP (IPv6)
    
      [✓] Pi-hole blocking is enabled

     

    ...and if I tail the log, I see activity:

    # pihole -t
      [i] Press Ctrl-C to exit
    08:09:17: forwarded 197.1.168.192.in-addr.arpa to 1.0.0.2
    08:09:17: forwarded 197.1.168.192.in-addr.arpa to 1.0.0.2
    08:09:19: query[AAAA] diag.meethue.com from 192.168.1.103
    08:09:19: forwarded diag.meethue.com to 1.1.1.2
    08:09:19: forwarded diag.meethue.com to 1.0.0.2
    08:09:19: forwarded diag.meethue.com to 1.0.0.2
    08:09:22: query[PTR] 197.1.168.192.in-addr.arpa from 127.0.0.1

     

    I just can't get the GUI to load to set it up fully.  Screenshot of the docker page is attached.  What am I missing?

     

     

    is this with a new blank appdata/pihole directory? try a different name name to make sure (I had issues with permissions from an old installation). Is 192.168.1.99 already in use elsewhere?
    ... thats all I can think of at the moment

    • Thanks 1
  17. 4 hours ago, Andiroo2 said:

    For those that are coming here to troubleshoot a new Pihole docker setup in 2022, the app marked "Official" in Community Apps doesn't yet work on Unraid out of the box.  The template being pulled from docker has changed and the Unraid template hasn't been updated to use the new/correct variables yet.  There are some changes listed in the thread here that may get it working for you, but for now, don't pull your hair out if it's not working out of the box.

     

    If I'm wrong, please delete this post or flag it...I'm not a spokesperson for this docker template...just someone that has pulled some hair out and now (I think?) understands where things stand.

     

    I updated it a few days ago - let me know if it doesnt work for you. I tested it on a new adddata directory to be sure.

    I have not added "env. variable 'DNSMASQ_USER' with value = 'root'" in a couple of posts up as this is a temporary docker issue.