Jump to content

cardo

Members
  • Content Count

    77
  • Joined

  • Last visited

Community Reputation

2 Neutral

About cardo

  • Rank
    Advanced Member

Converted

  • Gender
    Undisclosed
  1. I was having the same issue and enabling Privoxy worked for me too. Never had to have this enabled until the docker pull from today.
  2. This is working perfectly thanks. The only odd thing for me is I can’t get faster than 30MB/sec using the next gen servers, even one that’s not too far from my location and the port is reporting open by ruTorrent as well. Same torrent without port forwarding working gets at least 82MB/sec on my gigabit connection using Mullvad. I wonder if others with fast connections are seeing similar results.
  3. Same here after following binhex’s recommendations. I’m using Mullvad.
  4. Thanks for that. I was able to get your Deluge docker up to 62-64MB/sec by unchecking incoming and outgoing UDP, but it’s still roughly 20 fewer than rTorrent using Mullvad as the provider with. port forwarding not working. I’m curious to see if PIA is faster once you get done testing next gen and update the rTorrent container.
  5. I’m seeing slow performance as well, but I suspect it’s on the PIA side. Strangely, binhex’s rTorrent VPN docker using Mullvad without forwarding working I can get 82-85MB/sec on my gigabit connection, but the same torrent with next gen in DelugeVPN won’t get above 22-24MB/sec and that’s using the high performance options with the ItConfig plugin.
  6. And when you check the port status in rTorrent’s GUI, it shows the forwarded port as open? I’m set up exactly the same as you other than I’m using a different VPN location and I get the exclamation mark in the status bar with the message xxxxx: Port is closed. Where xxxxx is the forwarded port.
  7. So, the port status shows open in the status bar?
  8. Can you provide more information about how you configured the container/router, because I set this up 4-5 days ago and it is still failing for me. Here were my steps: 1. Set up the port forward on Mullvad. 2. set up a port forwarding rule on my router from anywhere to my private IP and port I’ve set up on Mullvad. It is set for both TCP/UDP. 3. Created two port entries in the container, one for UDP and one for TCP and specified the port on Mullvad and my router’s port forward rule. 4. Edited the .torrent.rc file and specified the port like this: network.port_range.set = xxxx-xxxx where xxxx is the port number. 5. When starting the container and going to Settings > Connection > Port used for income connection shows my port. Yet the status still shows the exclamation mark with the port being closed.
  9. I’ve also manually forwarded the port in my firewall and added two port entries in the container one for TCP and another for UDP and it still fails both from rTorrent’s port status as well as the external tester.
  10. Has anyone who switched to Mullvad get port forwarding to work? I know the strict port forward is ignored if don’t have PIA, but I’ve added a port forward for my account over at Mullvad and have gone into ruTorrent front end and choose settings > connection > port used for incoming connections and set it to the port and even tried 1234-1234 where 1234 is the real port number. It doesn’t do anything for me. The status icon at the bottom is still a red exclamation mark. I have a gigabit connection and without port forwarding I get about 60MB/sec on a well seeded torrent, I used to get as high as 85MB/sec with PIA and port forwarding enabled. EDIT: I should add I copied the rtorrent.rc file to .rtorrent.rc with the ports specified from Mullvad and the port status still is red.
  11. I’m in the U.S. and Mullvad was significantly slower for me than PIA. That’s why I switched back. I ended up getting 3 years of service too. It really pisses me off too because without the port forwarding my speed is cut significantly.
  12. If I wanted prevent anyone from accessing domain.com, which .conf would the allow/deny go? I am really new to nginx.
  13. Thanks for the response, so if I have a reverse proxy set up for Ombi like request.domain.com, adding the following to ombi.sub domain.conf will block someone from connecting to domain.com too? allow 192.168.0.0/16; deny all; I have the swag container set to only sub domains and cname record only for request.domain.com.
  14. Hi All, I set up the SWAG docker container last weekend and have reverse proxied all of the services I want except one, Pi-Hole. I had it working when I was using a physical Pi-Hole on my 192.168.0.0 network, and I have Pi-Hole running fine when I use the custom network as per @SpaceInvaderOne’s video, but I am unable to use the needed network that is shared with the SWAG container for the all of the reverse proxy containers as it is on the internal 172.18.0.0 network and I need it to be on my 192.168 network. The other issue is that UnRAID is already using port 80 and 443. I know I can change those, but port 67 is still be used by something and I’m not sure what. I tried searching this thread, but didn’t have much luck. I’m certain it’s something easy I’m missing, but just don’t know what. EDIT: After some more digging I determined that libvert binds to port 67 which makes pihole not start unless I disable my vm manager. I was able to get pihole to work by specifying the letsencrypt custom interface and specifying the IP for the pihole docker container, but now VM Manager won’t start because the pihole docker has port 67 bound now. I also just realized that my pihole is using the unRAID default internal ip and not the one I specified so that won’t work. Any recommendations/best practices here? Also, I set up Plex to reverse proxy via a subfolder as required so I’m reversing the root domain, is there a .conf file I can add the allow/deny entry so the root site domain.com is only accessible from my internal network? I have all of the other services locked down via the appropriate file in proxy-confs.