drogg

Members
  • Posts

    52
  • Joined

  • Last visited

1 Follower

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

drogg's Achievements

Rookie

Rookie (2/14)

2

Reputation

  1. I'd love to know how you set up the radarr/sonarr bot!
  2. @mgutt I followed this guide to a T and I'm shocked at how well my Plex is running. Performance is already 100x better, and that's on a Celeron 4900 - so who knows what would happen if I upgraded to a better CPU. Most videos, even 4k rips, load within 1-2 seconds - and those are coming from an rclone remote. The cache trick especially helped the speed on an NVMe - but 8GB RAM transcoding has improved the experience for my other users as well. Thank you for this guide - it has transformed my Plex experience!
  3. Just going to keep bumping this in hopes of help. It seems like I have extremely high iowait. What causes this? I run one NVMe, one HDD. I keep everything besides seeding downloads on the cache, and I wouldn't expect to slow my server to a crawl whenever Sonarr or Lidarr copy files. Any help would be much appreciated! I'm at a complete loss here,
  4. I've actually been watching it for the last 10 minutes without a scan, and after the rclone mount has been added. Plex is at 2%, max right now (no scans), while streaming a video. I'm going to start every docker one at a time to see if maybe a docker has gone wild. EDIT: Things were going like they should be until I opened NZBGet. As soon as it opened, the CPU and process shot up and won't subside. Interestingly, this was happening on my previous install...when I was using Sabnzbd. EDIT EDIT: According to advanced view on the Docker tab, NZBGet is only using 1%. So I'm thinking it's not actually NZBGet after all. EDIT EDIT EDIT: It just appears out of nowhere 11 minutes after the server is rebooted. I installed the Open Files plugin and it showed me a random video file was open, so killing that has fixed the error. I will keep monitoring.
  5. Stopping the array drops it to 1% (if that).
  6. Ok, just want to follow up. I did a complete reinstall - only carried over my license number. The ONLY other thing I'm running is a mergerfs mount with rclone and Sonarr/Radarr/DelugeVPN, but I'm not seeing how those would be hammering the CPU all day. Any ideas? Diagnostics attached. scout-diagnostics-20201221-2009.zip
  7. First off, I want to say the setup for this is super easy and I appreciate your hard work, DZMM. I started from scratch on a smaller server this weekend and I was able to have this up and running in no time. I'm seeing that my cache drive is being eaten up by the "mount_rclone" share, even after reset. My cache size is set to 400GB, which I copied from the scripts. Is this normal/expected? Is there a need for it to be so large? What exactly is cache doing here?
  8. So we don't need to run your script anymore (which worked wonders btw) and can instead just follow the new docker image?
  9. Not sure what the syslog server is. How would I check? What should I be looking out for in safe mode?
  10. Hi all! I am having an issue that I just can't seem to put my finger on. I constantly have 50% or more of my CPU being used and I have no idea what's causing it. I've attached a pic of terminal with htop running beside it as well as graphs from a direct play on Plex. I've tried turning off Docker, VMs, and it's still hovering at 50%. I only have 1 cache and 1 data drive (system running on an HP290). I know this Celeron isn't the highest performing CPU, but this seems a bit odd. FWIW, I was having the same issue on my older Xeon 1226v3 on my old machine. Meanwhile, my memory is also being hammered by Log and I don't know what that means. Any ideas? scout-diagnostics-20201212-0730.zip
  11. I actually got it figured out after adding --sysctl net.ipv6.conf.all.disable_ipv6=0 to the extra parameters (thank you @materka!) . This appears to be needed for all VPN containers using Mullvad - or at least the few I've tried since.
  12. Can you give me the command to run? Sorry, not super advanced in the terminal side yet. EDIT: adding --sysctl net.ipv6.conf.all.disable_ipv6=0 as mentioned above fixed it!
  13. I removed the first OpenVPN variable and added this. Then went to Mullvad and ensured I grabbed the .ovpn from NL, UDP 53. Is this what I’m supposed to do? Using OpenVPN provider: MULLVAD Starting OpenVPN using config mullvad_nl_udp53.ovpn Setting OPENVPN credentials... adding route to local network 192.168.1.0/24 via 172.17.0.1 dev eth0 Wed Jul 8 22:18:18 2020 Note: option tun-ipv6 is ignored because modern operating systems do not need special IPv6 tun handling anymore. Wed Jul 8 22:18:18 2020 OpenVPN 2.4.7 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Sep 5 2019 Wed Jul 8 22:18:18 2020 library versions: OpenSSL 1.1.1c 28 May 2019, LZO 2.10 Wed Jul 8 22:18:18 2020 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts Wed Jul 8 22:18:18 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]185.65.134.140:53 Wed Jul 8 22:18:18 2020 Socket Buffers: R=[212992->1048576] S=[212992->1048576] Wed Jul 8 22:18:18 2020 UDP link local: (not bound) Wed Jul 8 22:18:18 2020 UDP link remote: [AF_INET]185.65.134.140:53 Wed Jul 8 22:18:18 2020 TLS: Initial packet from [AF_INET]185.65.134.140:53, sid=551c02a7 5c360811 Wed Jul 8 22:18:18 2020 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this Wed Jul 8 22:18:18 2020 VERIFY OK: depth=2, C=SE, ST=Gotaland, L=Gothenburg, O=Amagicom AB, OU=Mullvad, CN=Mullvad Root CA v2, emailAddress=security@mullvad.net Wed Jul 8 22:18:18 2020 VERIFY OK: depth=1, C=SE, ST=Gotaland, O=Amagicom AB, OU=Mullvad, CN=Mullvad Intermediate CA v2, emailAddress=security@mullvad.net Wed Jul 8 22:18:18 2020 VERIFY KU OK Wed Jul 8 22:18:18 2020 Validating certificate extended key usage Wed Jul 8 22:18:18 2020 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication Wed Jul 8 22:18:18 2020 VERIFY EKU OK Wed Jul 8 22:18:18 2020 VERIFY OK: depth=0, C=SE, ST=Gotaland, O=Amagicom AB, OU=Mullvad, CN=nl-ams-010.mullvad.net, emailAddress=security@mullvad.net Wed Jul 8 22:18:19 2020 WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1557', remote='link-mtu 1558' Wed Jul 8 22:18:19 2020 WARNING: 'comp-lzo' is present in remote config but missing in local config, remote='comp-lzo' Wed Jul 8 22:18:19 2020 Control Channel: TLSv1.3, cipher TLSv1.3 TLS_CHACHA20_POLY1305_SHA256, 4096 bit RSA Wed Jul 8 22:18:19 2020 [nl-ams-010.mullvad.net] Peer Connection Initiated with [AF_INET]185.65.134.140:53 Wed Jul 8 22:18:20 2020 SENT CONTROL [nl-ams-010.mullvad.net]: 'PUSH_REQUEST' (status=1) Wed Jul 8 22:18:20 2020 PUSH: Received control message: 'PUSH_REPLY,dhcp-option DNS 10.7.0.1,redirect-gateway def1 bypass-dhcp,route-ipv6 0000::/2,route-ipv6 4000::/2,route-ipv6 8000::/2,route-ipv6 C000::/2,comp-lzo no,route-gateway 10.7.0.1,topology subnet,socket-flags TCP_NODELAY,ifconfig-ipv6 fdda:d0d0:cafe:53::1000/64 fdda:d0d0:cafe:53::,ifconfig 10.7.0.2 255.255.0.0,peer-id 1,cipher AES-256-GCM' Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: compression parms modified Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: --socket-flags option modified Wed Jul 8 22:18:20 2020 NOTE: setsockopt TCP_NODELAY=1 failed Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: --ifconfig/up options modified Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: route options modified Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: route-related options modified Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: peer-id set Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: adjusting link_mtu to 1624 Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: data channel crypto options modified Wed Jul 8 22:18:20 2020 Data Channel: using negotiated cipher 'AES-256-GCM' Wed Jul 8 22:18:20 2020 Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key Wed Jul 8 22:18:20 2020 Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key Wed Jul 8 22:18:20 2020 ROUTE_GATEWAY 172.17.0.1/255.255.0.0 IFACE=eth0 HWADDR=02:42:ac:11:00:06 Wed Jul 8 22:18:20 2020 GDG6: remote_host_ipv6=n/a Wed Jul 8 22:18:20 2020 ROUTE6: default_gateway=UNDEF Wed Jul 8 22:18:20 2020 TUN/TAP device tun0 opened Wed Jul 8 22:18:20 2020 TUN/TAP TX queue length set to 100 Wed Jul 8 22:18:20 2020 /sbin/ip link set dev tun0 up mtu 1500 Wed Jul 8 22:18:20 2020 /sbin/ip addr add dev tun0 10.7.0.2/16 broadcast 10.7.255.255 Wed Jul 8 22:18:20 2020 /sbin/ip -6 addr add fdda:d0d0:cafe:53::1000/64 dev tun0 RTNETLINK answers: Permission denied Wed Jul 8 22:18:20 2020 Linux ip -6 addr add failed: external program exited with error status: 2 Wed Jul 8 22:18:20 2020 Exiting due to fatal error Wed Jul 8 22:18:20 2020 SENT CONTROL [nl-ams-010.mullvad.net]: 'PUSH_REQUEST' (status=1) Wed Jul 8 22:18:20 2020 PUSH: Received control message: 'PUSH_REPLY,dhcp-option DNS 10.7.0.1,redirect-gateway def1 bypass-dhcp,route-ipv6 0000::/2,route-ipv6 4000::/2,route-ipv6 8000::/2,route-ipv6 C000::/2,comp-lzo no,route-gateway 10.7.0.1,topology subnet,socket-flags TCP_NODELAY,ifconfig-ipv6 fdda:d0d0:cafe:53::1000/64 fdda:d0d0:cafe:53::,ifconfig 10.7.0.2 255.255.0.0,peer-id 1,cipher AES-256-GCM' Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: compression parms modified Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: --socket-flags option modified Wed Jul 8 22:18:20 2020 NOTE: setsockopt TCP_NODELAY=1 failed Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: --ifconfig/up options modified Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: route options modified Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: route-related options modified Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: peer-id set Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: adjusting link_mtu to 1624 Wed Jul 8 22:18:20 2020 OPTIONS IMPORT: data channel crypto options modified Wed Jul 8 22:18:20 2020 Data Channel: using negotiated cipher 'AES-256-GCM' Wed Jul 8 22:18:20 2020 Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key Wed Jul 8 22:18:20 2020 Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key Wed Jul 8 22:18:20 2020 ROUTE_GATEWAY 172.17.0.1/255.255.0.0 IFACE=eth0 HWADDR=02:42:ac:11:00:06 Wed Jul 8 22:18:20 2020 GDG6: remote_host_ipv6=n/a Wed Jul 8 22:18:20 2020 ROUTE6: default_gateway=UNDEF Wed Jul 8 22:18:20 2020 TUN/TAP device tun0 opened Wed Jul 8 22:18:20 2020 TUN/TAP TX queue length set to 100 Wed Jul 8 22:18:20 2020 /sbin/ip link set dev tun0 up mtu 1500 Wed Jul 8 22:18:20 2020 /sbin/ip addr add dev tun0 10.7.0.2/16 broadcast 10.7.255.255 Wed Jul 8 22:18:20 2020 /sbin/ip -6 addr add fdda:d0d0:cafe:53::1000/64 dev tun0 RTNETLINK answers: Permission denied Wed Jul 8 22:18:20 2020 Linux ip -6 addr add failed: external program exited with error status: 2 Wed Jul 8 22:18:20 2020 Exiting due to fatal error
  14. I cannot figure the Transmission_VPN out for the life of me. I'm trying to use it with Mullvad. I've tried renaming the ovpn file "mullvad_nl_ams.ovpn", I've tried "Netherlands.ovpn", as well as just default.ovpn and always make sure it matches up. Every time I get "Wed Jul 8 17:56:42 2020 Linux ip -6 addr add failed: external program exited with error status: 2". Any help? I can provide full logs if needed.
  15. Hi, changed port in rtorrent.rc to 13438 per my Airvpn settings, but still not getting a green check in rutorrent (and it doesn't appear to be working on any other open port checker). Does rtorrent itself need to be restarted or can I just restart the Docker? Is there a deeper issue? Update: All clear on the Airvpn side, but still have the issue locally with the alert. Seems like maybe my changes to rtorrent.rc aren't saved and submitted to rutorrent?